RTV forum PL | NewsGroups PL

Wzmacniacz operacyjny się wzbudza

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Wzmacniacz operacyjny się wzbudza

Goto page Previous  1, 2, 3  Next

Paweł Pawłowicz
Guest

Wed Dec 04, 2019 2:24 pm   



W dniu 03.12.2019 o 22:42, Queequeg pisze:
Quote:
Paweł Pawłowicz <pawel.pawlowicz13_at_gmaildotcom> wrote:

Gdzie dokładnie powinien być ten opornik?

Kondensator, nie opornik. Od punktu, gdzie łączą się trzy oporniki 1M,
do masy.

Hmm. Ok, jeśli poprawiony wzmacniacz nie pomoże, to tak zrobię.

4. Jeśli nie pomoże, dodałbym jakiś elektrolit filtrujący napięcie
zasilania w górnej części.

To już jest, 100uF (w nowej wersji zmieniłem na 220uF, a C6 na 100uF,
żeby nowy C13 -- 22uF -- był mniejszy od nich, ale rozsądnie duży).

Myślałem o wzmacniaczu antenowym.

Tzn. o samej antenie aktywnej, mini-whip?

Tak. Tam też dałbym opornik 15 omów i elektrolit blokujący zasilanie, za
opornikiem. Wstawiając opornik w "dolnej" części układu możesz
spowodować więcej szkody, niż pożytku. Kabel robi za zbieracz śmiecia.

Quote:
Nowa wizja jest taka:

Schemat:

http://www.chmurka.net/r/usenet/whip-amp/amp3.png

PCB:

http://www.chmurka.net/r/usenet/whip-amp/pcb2.png

PBC z włączonymi symbolami elementów (zaciemnia PCB ale widać, co gdzie
jest):

http://www.chmurka.net/r/usenet/whip-amp/pcb3.png

Na PCB niebieskie pady są tylko od strony ścieżek (od strony elementów
będzie wylana masa z lekko wyfrezowanymi otworami tam, gdzie przechodzą
elementy). Pady bordowe łączą się i ze stroną ścieżek i z tą wylaną masą.

Będzie lepiej? Masz / macie jakieś sugestie?

Ani trochę mi się to nie podoba. Na schemacie masz prostą drogę od
konektora wejściowego do wejścia opampa. Na płytce wije się ona przez
"większą połowę" płytki. Ta ścieżka powinna być krótka.
Piotr dał Ci bardzo dobrą radę, aby wykorzystać laminat dwustronny i
całą jedną stronę dedykować masie.

P.P.

Queequeg
Guest

Wed Dec 04, 2019 4:16 pm   



Paweł Pawłowicz <pawel.pawlowicz13_at_gmaildotcom> wrote:

Quote:
Tak. Tam też dałbym opornik 15 omów i elektrolit blokujący zasilanie, za
opornikiem. Wstawiając opornik w "dolnej" części układu możesz
spowodować więcej szkody, niż pożytku. Kabel robi za zbieracz śmiecia.

Ok. Najpierw spróbuję ze wzmacniaczem a jak nie pomoże, to zdejmę whipa i
przerobię.

Inna sprawa, że whip jest sprawdzony, myślę że tysiące ludzi z niego
korzystają (to popularna konstrukcja)...

Quote:
Ani trochę mi się to nie podoba. Na schemacie masz prostą drogę od
konektora wejściowego do wejścia opampa. Na płytce wije się ona przez
"większą połowę" płytki. Ta ścieżka powinna być krótka.

Hmm, a gdyby konektor był bliżej wejścia opampa, za to cewka, która go
zasila (z gónej części schematu) dalej?

Quote:
Piotr dał Ci bardzo dobrą radę, aby wykorzystać laminat dwustronny i
całą jedną stronę dedykować masie.

Tak właśnie w tym projekcie jest. Bordowe pady łączą się z tą masą,
niebieskie będą po drugiej stronie (po nawierceniu) lekko wyfrezowane,
żeby się nie stykały. Dodatkowo wylałem masę dookoła obwodów wejściowych
po stronie ścieżek.

--
https://www.youtube.com/watch?v=9lSzL1DqQn0

Piotr Gałka
Guest

Wed Dec 04, 2019 5:17 pm   



W dniu 2019-12-04 o 14:24, Paweł Pawłowicz pisze:

Quote:
Piotr dał Ci bardzo dobrą radę, aby wykorzystać laminat dwustronny i
całą jedną stronę dedykować masie.

Tak projektuję wszystkie cyfrowe płytki, ale jak naście lat temu
przerabiałem na tę modłę płytkę na której było wyjście C/A przepuszczone
przez OpAmpa to wzmacniacz zaczął się wzbudzać. Zwiększyła się pojemność
między ścieżką z wyjścia wzmacniacza a GND a wzmacniacze 'nie lubią'
obciążenia pojemnościowego.
Dlatego nie pisałem, że na pewno tak trzeba tylko, że ja tak robię.
Wydaje mi się, że poradziłem sobie z tym wzbudzaniem dodając jakąś małą
pojemność w sprzężeniu - dlatego pisałem, że chyba tak. Nie chce mi się
szukać dokumentacji z przełomu wieków.
P.G.

Janusz
Guest

Wed Dec 04, 2019 10:59 pm   



W dniu 2019-12-03 o 22:42, Queequeg pisze:
Quote:
Paweł Pawłowicz <pawel.pawlowicz13_at_gmaildotcom> wrote:

Gdzie dokładnie powinien być ten opornik?

Kondensator, nie opornik. Od punktu, gdzie łączą się trzy oporniki 1M,
do masy.

Hmm. Ok, jeśli poprawiony wzmacniacz nie pomoże, to tak zrobię.

4. Jeśli nie pomoże, dodałbym jakiś elektrolit filtrujący napięcie
zasilania w górnej części.

To już jest, 100uF (w nowej wersji zmieniłem na 220uF, a C6 na 100uF,
żeby nowy C13 -- 22uF -- był mniejszy od nich, ale rozsądnie duży).

Myślałem o wzmacniaczu antenowym.

Tzn. o samej antenie aktywnej, mini-whip?

Nowa wizja jest taka:

Schemat:

http://www.chmurka.net/r/usenet/whip-amp/amp3.png

PCB:

http://www.chmurka.net/r/usenet/whip-amp/pcb2.png

PBC z włączonymi symbolami elementów (zaciemnia PCB ale widać, co gdzie
jest):

http://www.chmurka.net/r/usenet/whip-amp/pcb3.png

Na PCB niebieskie pady są tylko od strony ścieżek (od strony elementów
będzie wylana masa z lekko wyfrezowanymi otworami tam, gdzie przechodzą
elementy). Pady bordowe łączą się i ze stroną ścieżek i z tą wylaną masą.

Będzie lepiej? Masz / macie jakieś sugestie?

Będzie lepiej, wejście od wyjścia jest dość daleko i rozdzielone masą,

zastanawia mnie tylko czemu rozdzieliłeś masy przy wzm. Sekcja zasilania
na wejściu nie jest dobrym
pomysłem, daj ją z lewej na prawą stronę tak aby masa zasilania i
wyjściowa była wspólnym punktem i od niego dopiero poprowadź do wejścia.

--
Janusz

Janusz
Guest

Wed Dec 04, 2019 11:02 pm   



Jeszcze jedno, jednowarsatwowa powinna wystarczyć.
--
Janusz

Queequeg
Guest

Fri Dec 06, 2019 12:41 pm   



Piotr Gałka <piotr.galka_at_cutthismicromade.pl> wrote:

Quote:
Rail to rail nie jest za free.

Tak... ja tam nie potrzebuję rail-to-rail. Może w ogóle zmienić ten
wzmacniacz np. na TL071, i zasilić go bezpośrednio z 12V (ew. przez
filtr RC)?

--
https://www.youtube.com/watch?v=9lSzL1DqQn0

Queequeg
Guest

Fri Dec 06, 2019 2:01 pm   



Janusz <janusz_kk_at_o2.pl> wrote:

Quote:
Będzie lepiej, wejście od wyjścia jest dość daleko i rozdzielone masą,
zastanawia mnie tylko czemu rozdzieliłeś masy przy wzm. Sekcja zasilania
na wejściu nie jest dobrym
pomysłem, daj ją z lewej na prawą stronę tak aby masa zasilania i
wyjściowa była wspólnym punktem i od niego dopiero poprowadź do wejścia.

Hmm, czy jeśli chcę wylać masę po drugiej stronie, to nadal powinienem w
ten sposób prowadzić masę?

Podejście kolejne -- zmieniłem wzmacniacz na TL071 w DIP8.

http://www.chmurka.net/r/usenet/whip-amp/amp4.png
http://www.chmurka.net/r/usenet/whip-amp/pcb4.png

Będę chciał to dziś wieczorem / jutro wytrawić i zobaczyć, jak się
zachowa.

Laminat dwustronny nic mnie nie kosztuje, więc chcę go użyć i właśnie
wylać masę po drugiej stronie. Chyba że przez zwiększoną pojemność
każdej ze ścieżek do masy zrobi to więcej szkody niż pożytku...?

--
https://www.youtube.com/watch?v=9lSzL1DqQn0

Paweł Pawłowicz
Guest

Fri Dec 06, 2019 3:38 pm   



W dniu 06.12.2019 o 13:01, Queequeg pisze:
Quote:
Janusz <janusz_kk_at_o2.pl> wrote:

Będzie lepiej, wejście od wyjścia jest dość daleko i rozdzielone masą,
zastanawia mnie tylko czemu rozdzieliłeś masy przy wzm. Sekcja zasilania
na wejściu nie jest dobrym
pomysłem, daj ją z lewej na prawą stronę tak aby masa zasilania i
wyjściowa była wspólnym punktem i od niego dopiero poprowadź do wejścia.

Hmm, czy jeśli chcę wylać masę po drugiej stronie, to nadal powinienem w
ten sposób prowadzić masę?

Podejście kolejne -- zmieniłem wzmacniacz na TL071 w DIP8.

http://www.chmurka.net/r/usenet/whip-amp/amp4.png
http://www.chmurka.net/r/usenet/whip-amp/pcb4.png

Będę chciał to dziś wieczorem / jutro wytrawić i zobaczyć, jak się
zachowa.

Tak dla spokoju sumienia, dodałbym jeszcze mały kondensator równolegle
do potencjometru. A przynajmniej miejsce na niego na płytce.

P.P.

Janusz
Guest

Fri Dec 06, 2019 6:22 pm   



W dniu 2019-12-06 o 13:01, Queequeg pisze:
Quote:
Janusz <janusz_kk_at_o2.pl> wrote:

Będzie lepiej, wejście od wyjścia jest dość daleko i rozdzielone masą,
zastanawia mnie tylko czemu rozdzieliłeś masy przy wzm. Sekcja zasilania
na wejściu nie jest dobrym
pomysłem, daj ją z lewej na prawą stronę tak aby masa zasilania i
wyjściowa była wspólnym punktem i od niego dopiero poprowadź do wejścia.

Hmm, czy jeśli chcę wylać masę po drugiej stronie, to nadal powinienem w
ten sposób prowadzić masę?

Podejście kolejne -- zmieniłem wzmacniacz na TL071 w DIP8.

http://www.chmurka.net/r/usenet/whip-amp/amp4.png
http://www.chmurka.net/r/usenet/whip-amp/pcb4.png

Będę chciał to dziś wieczorem / jutro wytrawić i zobaczyć, jak się
zachowa.

Laminat dwustronny nic mnie nie kosztuje, więc chcę go użyć i właśnie
wylać masę po drugiej stronie. Chyba że przez zwiększoną pojemność
każdej ze ścieżek do masy zrobi to więcej szkody niż pożytku...?

Powinno być ok.


--
Janusz

Queequeg
Guest

Mon Dec 09, 2019 12:47 am   



Paweł Pawłowicz <pawel.pawlowicz13_at_gmaildotcom> wrote:

Quote:
Tak dla spokoju sumienia, dodałbym jeszcze mały kondensator równolegle
do potencjometru. A przynajmniej miejsce na niego na płytce.

Dodałem. Nie lutowałem go, ale zrobiłem miejsce.

Niestety... nadal nie ma sukcesu. Tym razem oscylacje wyglądają tak:

http://www.chmurka.net/r/usenet/whip-amp/osc5.png

To przy PR-ku skręconym na minimum. Przy zwiększaniu wzmocnienia amplituda
oscylacji odpowiednio rośnie.

I tak samo jak poprzednio -- pojawiają się po dołączeniu whipa.

Co jeszcze mogę sprawdzić, zmienić...? Może pojemność ścieżek do wylanej
po drugiej stronie masy robi swoje?

--
https://www.youtube.com/watch?v=9lSzL1DqQn0

Janusz
Guest

Mon Dec 09, 2019 8:59 am   



W dniu 2019-12-08 o 23:47, Queequeg pisze:
Quote:
Paweł Pawłowicz <pawel.pawlowicz13_at_gmaildotcom> wrote:

Tak dla spokoju sumienia, dodałbym jeszcze mały kondensator równolegle
do potencjometru. A przynajmniej miejsce na niego na płytce.

Dodałem. Nie lutowałem go, ale zrobiłem miejsce.

Niestety... nadal nie ma sukcesu. Tym razem oscylacje wyglądają tak:

http://www.chmurka.net/r/usenet/whip-amp/osc5.png

To przy PR-ku skręconym na minimum. Przy zwiększaniu wzmocnienia amplituda
oscylacji odpowiednio rośnie.

I tak samo jak poprzednio -- pojawiają się po dołączeniu whipa.
Testujesz na starej płytce czy już na nowej?



--
Janusz

Queequeg
Guest

Mon Dec 09, 2019 11:55 am   



Janusz <janusz_kk_at_o2.pl> wrote:

Quote:
Testujesz na starej płytce czy już na nowej?

Na nowej.

--
https://www.youtube.com/watch?v=9lSzL1DqQn0

Janusz
Guest

Mon Dec 09, 2019 12:26 pm   



W dniu 2019-12-09 o 10:55, Queequeg pisze:
Quote:
Janusz <janusz_kk_at_o2.pl> wrote:

Testujesz na starej płytce czy już na nowej?

Na nowej.

To cienko, kable wejściowy i wyjściowy masz ekranowane?

bo może po nich się sprzęga, chociaż 15khz to trochę za mało na kable,
to chyba po zasilaniu.

--
Janusz

Paweł Pawłowicz
Guest

Mon Dec 09, 2019 12:57 pm   



W dniu 2019-12-09 o 12:36, Queequeg pisze:
Quote:
Janusz <janusz_kk_at_o2.pl> wrote:

To cienko, kable wejściowy i wyjściowy masz ekranowane?

Tak. Zasilający i do LEDa nie są ekranowane (LED jest wyprowadzony na
obudowie na krótkim przewodzie), ale oba sygnałowe są.

bo może po nich się sprzęga, chociaż 15khz to trochę za mało na kable,
to chyba po zasilaniu.

Masz pomysł, jak to jeszcze ugryźć?

Będę chciał najpierw spróbować zmniejszyć R2, nawet 10x (i proporcjonalnie
zwiększyć C9, ale teraz C9 i tak jest odłączony, nie podłączałem jeszcze
przełączników filtrów). Tylko R2 = 1k wprowadzi... nie wiem jak to
określić -- nierównomierność impedancji? Na wyjściu mini-whipa jest
wtórnik z rezystorem 220R w emiterze. Zastanawiam się, czy i jak wpłynie
to na filtr R2 + C9.

Obawiam się, że nic Cię nie uchroni przed wlezieniem na dach i
poblokowaniem zasilania na płytce przy antenie.

P.P.

Queequeg
Guest

Mon Dec 09, 2019 1:36 pm   



Janusz <janusz_kk_at_o2.pl> wrote:

Quote:
To cienko, kable wejściowy i wyjściowy masz ekranowane?

Tak. Zasilający i do LEDa nie są ekranowane (LED jest wyprowadzony na
obudowie na krótkim przewodzie), ale oba sygnałowe są.

Quote:
bo może po nich się sprzęga, chociaż 15khz to trochę za mało na kable,
to chyba po zasilaniu.

Masz pomysł, jak to jeszcze ugryźć?

Będę chciał najpierw spróbować zmniejszyć R2, nawet 10x (i proporcjonalnie
zwiększyć C9, ale teraz C9 i tak jest odłączony, nie podłączałem jeszcze
przełączników filtrów). Tylko R2 = 1k wprowadzi... nie wiem jak to
określić -- nierównomierność impedancji? Na wyjściu mini-whipa jest
wtórnik z rezystorem 220R w emiterze. Zastanawiam się, czy i jak wpłynie
to na filtr R2 + C9.

--
https://www.youtube.com/watch?v=9lSzL1DqQn0

Goto page Previous  1, 2, 3  Next

elektroda NewsGroups Forum Index - Elektronika Polska - Wzmacniacz operacyjny się wzbudza

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map