RTV forum PL | NewsGroups PL

Transceiver Kajman - problemy z uruchomieniem

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Transceiver Kajman - problemy z uruchomieniem

Goto page Previous  1, 2, 3  Next

Dariusz Dorochowicz
Guest

Mon Mar 07, 2022 2:44 pm   



W dniu 07.03.2022 o 14:11, J.F pisze:
Quote:
On Mon, 7 Mar 2022 11:53:24 +0100, Dariusz Dorochowicz wrote:
W dniu 06.03.2022 o 19:04, Atlantis pisze:
On 05.03.2022 21:13, Jacek Maciejewski wrote:

Rzuciłem jeszcze raz okiem na schemat transceivera
(https://sq7jhm.pzk.pl/images/_kajman1schemat.jpg) oraz na dokumentację
wzmacniacza TDA7056. Jedna rzecz zwróciła moją uwagę - w nocie
katalogowej na wejściu (pin 3) znajduje się 5k rezystor do masy.
Prawdopodobnie chodzi o polaryzację tego wejścia.

Nie wiem jaki dokument widziałeś, ale w dokumentacji
https://www.nxp.com/docs/en/data-sheet/TDA7056A.pdf
ewidentnie masz na wejściu kondensator i żadnych elementów
polaryzujących wejście. Ten rezystor jest oddzielony od układu
kondensatorem. Bezpośrednie podłączenie potencjometru jest tu raczej
mocno niewskazane.

Ale na wstepie

"In conventional DC volume circuits the control or input
stage is AC coupled to the output stage via external
capacitor to keep the offset voltage low.

In the TDA7056A the DC volume stage is integrated into
the input stage so that coupling capacitors are not required
and a low offset voltage is maintained."

No i nie calkiem rozumiem, co maja na mysli Smile

Faktycznie, aż tak dokładnie to mi się nie chciało przeglądać. No to by
znaczyło, że jednak ten kondensator nie jest konieczny.

Quote:
W przypadku transceivera ten rezystor został pominięty, a wejście jest
podłączone bezpośrednio do suwaka potencjometru regulującego głośność.
Znajduje się tam za to kondensator 22nF.

Druga rzecz - na schemacie przy T1 znajduje się rezystor 470k oznaczony
gwiazdką. Jest tez podana informacja, że napięcie na kolektorze powinno
wynosić 7,5V. Domyślam się więc, że rezystor trzeba dobrać. Ten fakt mi
umknął. Czy tutaj może leżeć przyczyna problemów, które obserwuję?

Gwiazdka na schematach oznacza że element jest dobierany. Przy
tranzystorach tego typu to średni pomysł, raczej z tych słabszych. Tzn
da się, i to będzie działać, ale to rozwiązanie z wcześniejszej epoki.
Dodając niewiele elementów da się zrobić układ znacznie stabilniejszy i
bez potrzeby dobierania elementów.

Ale moze nie trzeba wiekszej stabilnosci Smile

Pewnie nie, natomiast już sama potrzeba dobierania rezystora to taki
średni pomysł, ale w tym układzie nie da się tego uniknąć. Mamy dużą
zmianę wzmocnienia w zależności od egzemplarza i od warunków pracy.
Fakt, że warunki odbioru też się zmieniają, więc regulacja wzmocnienia i
tak musi być.

Pozdrawiam

DD

Atlantis
Guest

Mon Mar 07, 2022 6:16 pm   



Ok, dodałem tłumik antenowy w postaci potencjometru liniowego 1k na
wejściu odbiornika, jeszcze przed filtrem pasmowym. Efekt jego działania
jest na razie taki, że przy próbie zbyt dużego skręcenia sygnału coś w
radiu zaczyna się wzbudzać. Jednak to raczej nie wina samego tłumika,
ponieważ wcześniej bez podłączonej anteny też piszczało.

Jacek Maciejewski
Guest

Mon Mar 07, 2022 7:05 pm   



Dnia Mon, 7 Mar 2022 18:16:11 +0100, Atlantis napisał(a):

Quote:
Ok, dodałem tłumik antenowy w postaci potencjometru liniowego 1k na
wejściu odbiornika, jeszcze przed filtrem pasmowym. Efekt jego działania
jest na razie taki, że przy próbie zbyt dużego skręcenia sygnału coś w
radiu zaczyna się wzbudzać. Jednak to raczej nie wina samego tłumika,
ponieważ wcześniej bez podłączonej anteny też piszczało.

A już wypieprzyłeś ten 470 pF na próbę?
--
Jacek
I hate haters.

Janusz
Guest

Mon Mar 07, 2022 8:33 pm   



W dniu 2022-03-07 o 19:05, Jacek Maciejewski pisze:
Quote:
Dnia Mon, 7 Mar 2022 18:16:11 +0100, Atlantis napisał(a):

Ok, dodałem tłumik antenowy w postaci potencjometru liniowego 1k na
wejściu odbiornika, jeszcze przed filtrem pasmowym. Efekt jego działania
jest na razie taki, że przy próbie zbyt dużego skręcenia sygnału coś w
radiu zaczyna się wzbudzać. Jednak to raczej nie wina samego tłumika,
ponieważ wcześniej bez podłączonej anteny też piszczało.

A już wypieprzyłeś ten 470 pF na próbę?
Się uczepiłeś, przecież to nie on się wzbudza tylko TDA, ma tam kiepskie

filtrowanie i tyle. Ten 470p jest przecież na mcz i tylko ogranicza
pasmo, tam więcej niż 3khz nie trzeba i pewnie tyle on robi.

--
Janusz

Janusz
Guest

Mon Mar 07, 2022 8:46 pm   



W dniu 2022-03-06 o 20:38, Jacek Maciejewski pisze:
Quote:
Dnia Sun, 6 Mar 2022 19:04:39 +0100, Atlantis napisał(a):

Rzuciłem jeszcze raz okiem na schemat transceivera
(https://sq7jhm.pzk.pl/images/_kajman1schemat.jpg) oraz na dokumentację
wzmacniacza TDA7056. Jedna rzecz zwróciła moją uwagę - w nocie
katalogowej na wejściu (pin 3) znajduje się 5k rezystor do masy.
Prawdopodobnie chodzi o polaryzację tego wejścia.
W przypadku transceivera ten rezystor został pominięty, a wejście jest
podłączone bezpośrednio do suwaka potencjometru regulującego głośność.
Znajduje się tam za to kondensator 22nF.
To jest OK.

Druga rzecz - na schemacie przy T1 znajduje się rezystor 470k oznaczony
gwiazdką. Jest tez podana informacja, że napięcie na kolektorze powinno
wynosić 7,5V. Domyślam się więc, że rezystor trzeba dobrać.
Normalne przy takim sposobie ale z uwagi na b. mały sygnał w tym
miejscu, wartości napięcia kolektora mogą się zmieniać w szerokim
zakresie bez wyraźnego wpływu na cokolwiek.

Ten fakt mi
umknął. Czy tutaj może leżeć przyczyna problemów, które obserwuję?
Nie.

Przy okazji zgłoszę dwa zastrzeżenia do projektu:

1. Odbiornik ma wejście zrobione na scalaku z wzmacniaczem przed 1
mieszaczem. To bardzo złe rozwiazanie z uwagi na modulację skrośną,
Gdzie ty tam masz wzmacniacz?

sygnał z anteny wchodzi na filtr i 1 ne612, a jak popatrzymy na schemat
wewnętrzny to widać że jest to wejście(baza) modulatora. On owszem może
być przesterowany ale to nie jest wzmacniacz.
Wzmacniacz a raczej generator jest ale na nogach 6,7.
Na pewno patrzysz na ten sam schemat?


--
Janusz

Atlantis
Guest

Mon Mar 07, 2022 10:11 pm   



On 07.03.2022 20:33, Janusz wrote:

Quote:
Się uczepiłeś, przecież to nie on się wzbudza tylko TDA, ma tam kiepskie
filtrowanie i tyle. Ten 470p jest przecież na mcz i tylko ogranicza
pasmo, tam więcej niż 3khz nie trzeba i pewnie tyle on robi.

Może sprostuję, bo sprawa jest bardziej złożona. Składam w tej chwili
równolegle dwa egzemplarze tego radia. W obydwu wzbudzał się TDA,
właściwie w dokładnie ten sam sposób. Grzał się niemiłosiernie i nie
dawał żadnego normalnego sygnału na wyjściu głośnikowym, chociaż
sprawdziłem kilka różnych egzemplarzy.

W obydwu radyjkach wymontowałem więc ten problematyczny układ i podałem
sygnał audio na wejście zewnętrznego wzmacniacza (wejście AUX głośnika
bluetooth). Jak wygląda sytuacja?

Pierwszy egzemplarz radia działa względnie normalnie. Udało mi się
zrobić na nim jakieś nasłuchy na prowizorycznej antenie longwire. Jednak
jeśli próbuję włączyć radio bez podłączonej anteny, to się wzbudza i
zaczyna wyć. Tak samo reaguje na choćby minimalne skręcenie tłumika
antenowego.

Drugi egzemplarz zachowuje się inaczej. Sygnał za tranzystorem T1 jest
bardzo cichy. Ledwo co słychać, nawet po podkręceniu głośności do
maksimum. Wydaje mi się nawet, że nieco lepiej jest, jeśli pobieram
sygnał przed tranzystorem, chociaż i tak jest bardzo cicho.

I jeszcze jedno pytanie: czy napięcie na kolektorze T1 faktycznie ma
wynosić 7,5V? Schemat (https://sq7jhm.pzk.pl/images/_kajman1schemat.jpg)
ma bardzo niską rozdzielczość i ledwo co na nim widać, jednak taka
interpretacja tej grupki pikseli wydaje mi się najbardziej
prawdopodobna. Tyle tylko, że przy rezystorze 470k mierzone napięcie
wychodzi mi tam w okolicy 5V. Żeby podnieść do 7,5V, trzeba dać
rezystancję powyżej 1M.

Jacek Maciejewski
Guest

Mon Mar 07, 2022 10:15 pm   



Dnia Mon, 7 Mar 2022 20:46:15 +0100, Janusz napisał(a):

Quote:
Gdzie ty tam masz wzmacniacz?

Aaaa, faktycznie, chyba zmyśliłem ten wzmacniacz. Odszczekuję zatem, ale
i tak mieszacze w ukł. Gilberta nie są zbyt odporne na intermodulacje.
--
Jacek
I hate haters.

Jacek Maciejewski
Guest

Mon Mar 07, 2022 10:17 pm   



Dnia Mon, 7 Mar 2022 22:11:20 +0100, Atlantis napisał(a):

Quote:
I jeszcze jedno pytanie: czy napięcie na kolektorze T1 faktycznie ma
wynosić 7,5V?

Każde napięcie między 3 a 8 V będzie dobre, nie przeżywaj. Problemy leżą
gdzie indziej.
--
Jacek
I hate haters.

J.F
Guest

Mon Mar 07, 2022 10:31 pm   



On Mon, 7 Mar 2022 22:11:20 +0100, Atlantis wrote:
Quote:
On 07.03.2022 20:33, Janusz wrote:
Może sprostuję, bo sprawa jest bardziej złożona. Składam w tej chwili
równolegle dwa egzemplarze tego radia. W obydwu wzbudzał się TDA,
właściwie w dokładnie ten sam sposób. Grzał się niemiłosiernie i nie
dawał żadnego normalnego sygnału na wyjściu głośnikowym, chociaż
sprawdziłem kilka różnych egzemplarzy.

W obydwu radyjkach wymontowałem więc ten problematyczny układ i podałem
sygnał audio na wejście zewnętrznego wzmacniacza (wejście AUX głośnika
bluetooth). Jak wygląda sytuacja?

Pierwszy egzemplarz radia działa względnie normalnie. Udało mi się
zrobić na nim jakieś nasłuchy na prowizorycznej antenie longwire. Jednak
jeśli próbuję włączyć radio bez podłączonej anteny, to się wzbudza i
zaczyna wyć. Tak samo reaguje na choćby minimalne skręcenie tłumika
antenowego.

Drugi egzemplarz zachowuje się inaczej. Sygnał za tranzystorem T1 jest
bardzo cichy. Ledwo co słychać, nawet po podkręceniu głośności do
maksimum. Wydaje mi się nawet, że nieco lepiej jest, jeśli pobieram
sygnał przed tranzystorem, chociaż i tak jest bardzo cicho.

Dziwaczne. Rzeklbym, ze tranzystor do sprawdzenia ...

Quote:
I jeszcze jedno pytanie: czy napięcie na kolektorze T1 faktycznie ma
wynosić 7,5V? Schemat (https://sq7jhm.pzk.pl/images/_kajman1schemat.jpg)
ma bardzo niską rozdzielczość i ledwo co na nim widać, jednak taka
interpretacja tej grupki pikseli wydaje mi się najbardziej
prawdopodobna. Tyle tylko, że przy rezystorze 470k mierzone napięcie
wychodzi mi tam w okolicy 5V. Żeby podnieść do 7,5V, trzeba dać
rezystancję powyżej 1M.

Bez znaczenia.

Co gorsza - to raczej oznacza, ze T1 jest dobry, wiec trzeba szukac
innego powodu.

J.

Atlantis
Guest

Mon Mar 07, 2022 11:41 pm   



Ok, z pomocą autora projektu udało mi się rozwiązać problem TDA. Nie
zwróciłem uwagi na fakt, że posiadane przeze mnie układy są w wersji
"A", która posiada nieco inny schemat aplikacyjny. Pin 5 nie może wisieć
w powietrzy, ale musi być podłączony przez potencjometr do masy - w ten
sposób realizowana jest regulacja głośności.
I faktycznie, zbudowałem układ w oparciu o schemat stąd:
https://www.nxp.com/docs/en/data-sheet/TDA7056A.pdf
Główna różnica jest taka, że zamiast 100k, użyłem potencjometru 250k
(akurat taki miałem pod ręką).

I faktycznie, wzmacniacz zdaje się pracować prawidłowo - jeśli dotykam
wejścia pęsetą, słyszę pogłos sieciowy w głośniku. Jego głośność mogę
też regulować potencjometrem. Układ się nie grzeje.

Niestety, kiedy próbuję podłączyć wyjście T1 z wejściem TDA, w głośniku
słychać jedynie cichy pisk...

LordBluzgÂŽ
Guest

Tue Mar 08, 2022 2:59 am   





Atlantis
Guest

Tue Mar 08, 2022 7:37 am   





Jacek Maciejewski
Guest

Tue Mar 08, 2022 8:39 am   



Dnia Mon, 7 Mar 2022 23:41:04 +0100, Atlantis napisał(a):

Quote:
Niestety, kiedy próbuję podłączyć wyjście T1 z wejściem TDA, w głośniku
słychać jedynie cichy pisk...

Zastąp dławik w bazie T1 opornikiem 100 om. I/albo wywal 470 p.
--
Jacek
I hate haters.

Janusz
Guest

Tue Mar 08, 2022 11:51 am   



W dniu 2022-03-07 o 22:15, Jacek Maciejewski pisze:
Quote:
Dnia Mon, 7 Mar 2022 20:46:15 +0100, Janusz napisał(a):

Gdzie ty tam masz wzmacniacz?

Aaaa, faktycznie, chyba zmyśliłem ten wzmacniacz. Odszczekuję zatem, ale
Oki Smile


Quote:
i tak mieszacze w ukł. Gilberta nie są zbyt odporne na intermodulacje.
A to inna sprawa, mnie bardziej dziwi brak stopnia wejściowego na jakimś

fecie najlepiej dwubramkowym bardziej odpornym na modulacje a i dającym
zrobić na nim ARW i wsadzić go np. między filtry na wejściu.

--
Janusz

Jacek Maciejewski
Guest

Tue Mar 08, 2022 2:25 pm   



Dnia Tue, 8 Mar 2022 11:51:59 +0100, Janusz napisał(a):

Quote:
A to inna sprawa, mnie bardziej dziwi brak stopnia wejściowego na jakimś
fecie najlepiej dwubramkowym bardziej odpornym na modulacje a i dającym
zrobić na nim ARW i wsadzić go np. między filtry na wejściu.

Jeśli mogę swoje 3 grosze wetknąć, to IMO na KF żadnego wzmacniacza
przed 1 mieszaczem a już w szczególności na niższych pasmach
amatorskich. ARW przed pośrednią nic nie poprawia, więc po co
komplikować? Natomiast ARW na pośredniej zrobionej na scalaku w rodzaju
TCA440 ma wielką dynamikę, całkiem dobrze działa i jest prosta jak
nocnik w obsłudze.
Aktualnie używam TRx-a z 1 mieszaczem na 2xBF256 przeciwsobnie i
pośrednią na kaskodzie na tych BF (1 stopień) plus właśnie TCA440. I
oczywiście bez wzmacniacza w.cz. Czułość 10 dB od poziomu szumu lepsza
od 1 uV.
--
Jacek
I hate haters.

Goto page Previous  1, 2, 3  Next

elektroda NewsGroups Forum Index - Elektronika Polska - Transceiver Kajman - problemy z uruchomieniem

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map