RTV forum PL | NewsGroups PL

Termostat: LM57 Texas Instrument

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Termostat: LM57 Texas Instrument

Goto page 1, 2  Next

Pszemol
Guest

Thu Aug 02, 2018 12:38 am   



Czy ktoś używał tego termostatu z tytułu?
http://www.tij.co.jp/jp/lit/ds/symlink/lm57.pdf

Mam problem i podejrzewam jakiś problem z samo-ogrzewaniem się.
Obseruję woltomierzem wyjście analogowe i po włączeniu napięcia
zasilającego układ sam się nagrzewa w ciągu pół godziny temperatura
zgłaszana na tym wyjściu wzrasta o 7 stopni...

Ale to nie koniec. Używam tego układu do załączania opto-triaka
(przez tranzystor bipolarny podłączony do odwracającego TOver)
i po osiągnięciu progu temperatury i załączeniu "grzałki"
wyjście to wyłącza grzałkę po kilku minutach zgłaszając osiągnięcie
10-stopniowej histerezy, mimo że grzałka nie jest do triaka
w ogóle podłączona, więc temperatura musi narastać od samego
faktu załączenia układu.

Co posprawdzałem - ano wyjście odwracające TOver, które
pracuje w układzie otwartego kolektora, zasilane jest z pull-upa
4,7kohm z Vcc (3,3V). Podłączona tam jest także baza tranzytora
NPN który steruje opto-triakiem. Czyli prąd wyjścia w stanie LOW
gdy open drain przewodzi jest rzędu 0,6-0,7mA. Czy tak mały
prąd może powodować samoogrzewanie się układu? Datasheet
pokazuje opornik 100kohm w roli pullup... ciekawe....

A może 4,7k jest ok i po prostu jakiś inny komponent blisko się grzeje?

J.F.
Guest

Thu Aug 02, 2018 6:27 am   



Dnia Wed, 1 Aug 2018 19:38:51 -0500, Pszemol napisał(a):
Quote:
Czy ktoś używał tego termostatu z tytułu?
http://www.tij.co.jp/jp/lit/ds/symlink/lm57.pdf

Mam problem i podejrzewam jakiś problem z samo-ogrzewaniem się.
Obseruję woltomierzem wyjście analogowe i po włączeniu napięcia
zasilającego układ sam się nagrzewa w ciągu pół godziny temperatura
zgłaszana na tym wyjściu wzrasta o 7 stopni...

Ale to nie koniec. Używam tego układu do załączania opto-triaka
(przez tranzystor bipolarny podłączony do odwracającego TOver)
i po osiągnięciu progu temperatury i załączeniu "grzałki"
wyjście to wyłącza grzałkę po kilku minutach zgłaszając osiągnięcie
10-stopniowej histerezy, mimo że grzałka nie jest do triaka
w ogóle podłączona, więc temperatura musi narastać od samego
faktu załączenia układu.

Co posprawdzałem - ano wyjście odwracające TOver, które
pracuje w układzie otwartego kolektora, zasilane jest z pull-upa
4,7kohm z Vcc (3,3V). Podłączona tam jest także baza tranzytora
NPN który steruje opto-triakiem. Czyli prąd wyjścia w stanie LOW
gdy open drain przewodzi jest rzędu 0,6-0,7mA. Czy tak mały
prąd może powodować samoogrzewanie się układu? Datasheet
pokazuje opornik 100kohm w roli pullup... ciekawe....

A napiecie na tym wyjsciu jakie wtedy ?

0.5V*0.7mA = 0.35mW, a rezystancja termiczna 0.183 C/mW ... nie, to
nie jest 7 st

Quote:
A może 4,7k jest ok i po prostu jakiś inny komponent blisko się grzeje?

Wielce prawdopodobne ... ale skad ta reakcja na wlaczenie optotriaka ?

-zmierz tem opornik, czy aby na pewno 4.7k
-zmien na 47k
-dodaj drugi na drugie TOver - bedzie stale grzanie
-zmierz zasilanie - moze ono plywa, albo smieci lataja,
-punkt 8.3.6.3 ... i 9.1.1
-dodaj kondensator na zasilaniu,
-a trip test dobry ? Moze mierzysz co innego

-i jeszcze taki cytat
To minimize self-heating, the load current on VTEMP should be
minimized

-tak z ciekawosci ... doklej mu jakis czujnik temperatury i zmierz :-)

J.

Marek
Guest

Thu Aug 02, 2018 8:11 am   



On Wed, 1 Aug 2018 19:38:51 -0500, "Pszemol" <Pszemol_at_PolBox.com>
wrote:
Quote:
Mam problem i podejrzewam jakiś problem z samo-ogrzewaniem się.
Obseruję woltomierzem wyjście analogowe i po włączeniu napięcia
zasilającego układ sam się nagrzewa w ciągu pół godziny temperatura
zgłaszana na tym wyjściu wzrasta o 7 stopni...
Ale to nie koniec. Używam tego układu do załączania opto-triaka
(przez tranzystor bipolarny podłączony do odwracającego TOver)
i po osiągnięciu progu temperatury i załączeniu "grzałki"

Ja bym użył cyfrowy termostat ds1821, ma programowalne trip-pointy
może sam od razu wysterować swoim wyjściem optiotriak.

--
Marek

Pszemol
Guest

Thu Aug 02, 2018 12:33 pm   



"J.F." <jfox_xnospamx_at_poczta.onet.pl> wrote in message
news:oqxj3efyo6tg.1bbaprdrwim49$.dlg_at_40tude.net...
Quote:
Dnia Wed, 1 Aug 2018 19:38:51 -0500, Pszemol napisał(a):
Czy ktoś używał tego termostatu z tytułu?
http://www.tij.co.jp/jp/lit/ds/symlink/lm57.pdf

Mam problem i podejrzewam jakiś problem z samo-ogrzewaniem się.
Obseruję woltomierzem wyjście analogowe i po włączeniu napięcia
zasilającego układ sam się nagrzewa w ciągu pół godziny temperatura
zgłaszana na tym wyjściu wzrasta o 7 stopni...

Ale to nie koniec. Używam tego układu do załączania opto-triaka
(przez tranzystor bipolarny podłączony do odwracającego TOver)
i po osiągnięciu progu temperatury i załączeniu "grzałki"
wyjście to wyłącza grzałkę po kilku minutach zgłaszając osiągnięcie
10-stopniowej histerezy, mimo że grzałka nie jest do triaka
w ogóle podłączona, więc temperatura musi narastać od samego
faktu załączenia układu.

Co posprawdzałem - ano wyjście odwracające TOver, które
pracuje w układzie otwartego kolektora, zasilane jest z pull-upa
4,7kohm z Vcc (3,3V). Podłączona tam jest także baza tranzytora
NPN który steruje opto-triakiem. Czyli prąd wyjścia w stanie LOW
gdy open drain przewodzi jest rzędu 0,6-0,7mA. Czy tak mały
prąd może powodować samoogrzewanie się układu? Datasheet
pokazuje opornik 100kohm w roli pullup... ciekawe....

A napiecie na tym wyjsciu jakie wtedy ?

0.5V*0.7mA = 0.35mW, a rezystancja termiczna 0.183 C/mW ... nie, to
nie jest 7 st

Według datasheeta, przy prądzie <600uA napięcie <0,2V.

Quote:
A może 4,7k jest ok i po prostu jakiś inny komponent blisko się grzeje?

Wielce prawdopodobne ... ale skad ta reakcja na wlaczenie optotriaka ?

Nie wiem, zwłaszcza że teraz się zastanowiłem, że wyjście zanegowane
(źle go nazwałem "odwracające" wczoraj) /TOver jest aktywne, gdy
temperatura otoczenia jest powyżej Ttrip ustawione u mnie na 24C.
Aktywne, czyli wyjście LOW i tranzystor open colector przewodzi.
Grzałka wtedy jest wyłączona Smile)

Quote:
-zmierz tem opornik, czy aby na pewno 4.7k
-zmien na 47k
-dodaj drugi na drugie TOver - bedzie stale grzanie

Drugi TOver, ten niezanegowany, jest push-pull, nie open colector.

Quote:
-zmierz zasilanie - moze ono plywa, albo smieci lataja,
-punkt 8.3.6.3 ... i 9.1.1
-dodaj kondensator na zasilaniu,
-a trip test dobry ? Moze mierzysz co innego

Trip jest dobry: według wyjścia analogowego grzałka się
załącza przy napięciu 1.028 i wyłacza przy temperaturze
10 C wyższej.

Quote:
-i jeszcze taki cytat
To minimize self-heating, the load current on VTEMP should be
minimized

-tak z ciekawosci ... doklej mu jakis czujnik temperatury i zmierz Smile

Smile no... muszę się tym ciut więcej pobawić.

Pszemol
Guest

Thu Aug 02, 2018 12:35 pm   



"Marek" <fake_at_fakeemail.com> wrote in message
news:almarsoft.6406822713984649711_at_news.neostrada.pl...
Quote:
On Wed, 1 Aug 2018 19:38:51 -0500, "Pszemol" <Pszemol_at_PolBox.com> wrote:
Mam problem i podejrzewam jakiś problem z samo-ogrzewaniem się.
Obseruję woltomierzem wyjście analogowe i po włączeniu napięcia
zasilającego układ sam się nagrzewa w ciągu pół godziny temperatura
zgłaszana na tym wyjściu wzrasta o 7 stopni...
Ale to nie koniec. Używam tego układu do załączania opto-triaka
(przez tranzystor bipolarny podłączony do odwracającego TOver)
i po osiągnięciu progu temperatury i załączeniu "grzałki"

Ja bym użył cyfrowy termostat ds1821, ma programowalne trip-pointy może
sam od razu wysterować swoim wyjściem optiotriak.

Nie projektowałem tego urządzenia - dostałem tylko problem
do usunięcia na zasadzie "Brian, który zaprojektował tą płytkę już
u nas nie pracuje a mamy z nią kłopoty, czy możesz pomóc Przemku?"
Jeśli nie da się tego inaczej naprawić jak projektowanie od nowa
to wtedy pomyślę, ale wolałbym zrobić małą, prostą modyfikację.

J.F.
Guest

Thu Aug 02, 2018 1:22 pm   



Użytkownik "Pszemol" napisał w wiadomości grup
dyskusyjnych:pjutmh$r0n$1_at_dont-email.me...
"J.F." <jfox_xnospamx_at_poczta.onet.pl> wrote in message
Quote:
Dnia Wed, 1 Aug 2018 19:38:51 -0500, Pszemol napisał(a):
Co posprawdzałem - ano wyjście odwracające TOver, które
pracuje w układzie otwartego kolektora, zasilane jest z pull-upa
4,7kohm z Vcc (3,3V). Podłączona tam jest także baza tranzytora
NPN który steruje opto-triakiem. Czyli prąd wyjścia w stanie LOW
gdy open drain przewodzi jest rzędu 0,6-0,7mA. Czy tak mały
prąd może powodować samoogrzewanie się układu? Datasheet
pokazuje opornik 100kohm w roli pullup... ciekawe....

A napiecie na tym wyjsciu jakie wtedy ?

0.5V*0.7mA = 0.35mW, a rezystancja termiczna 0.183 C/mW ... nie, to
nie jest 7 st

Według datasheeta, przy prądzie <600uA napięcie <0,2V.

Ale zmierz, to sie moze duzo wyjasnic.

Quote:
A może 4,7k jest ok i po prostu jakiś inny komponent blisko się
grzeje?
Wielce prawdopodobne ... ale skad ta reakcja na wlaczenie
optotriaka ?

Nie wiem, zwłaszcza że teraz się zastanowiłem, że wyjście zanegowane
(źle go nazwałem "odwracające" wczoraj) /TOver jest aktywne, gdy
temperatura otoczenia jest powyżej Ttrip ustawione u mnie na 24C.
Aktywne, czyli wyjście LOW i tranzystor open colector przewodzi.
Grzałka wtedy jest wyłączona Smile)

No tak, to nawet jak sie grzeje od pradu rezystora, to tym bardziej
bedzie wyjscie przewodzic i grzalki nie wlaczac.

Ale skoro tak ... to jak spowodowales wlaczenie grzalki ?
Trzeba bylo uklad schlodzic, czy prog jest ustawiony wyzej ?
Bo skoro grzalka odlaczona, to sie nie powinien przestawic ... wiec
moze jakies zaklocenia lapie ?

Quote:
-dodaj drugi na drugie TOver - bedzie stale grzanie
Drugi TOver, ten niezanegowany, jest push-pull, nie open colector.

To nam nie przeszkadza w kwestii wyrowania mocy strat, ale jak teraz
patrze - chyba nie ona jest przyczyną.

Quote:
-zmierz zasilanie - moze ono plywa, albo smieci lataja,
-punkt 8.3.6.3 ... i 9.1.1
-dodaj kondensator na zasilaniu,
-a trip test dobry ? Moze mierzysz co innego

Trip jest dobry: według wyjścia analogowego grzałka się
załącza przy napięciu 1.028 i wyłacza przy temperaturze
10 C wyższej.

Ale ja o linii Trip_test. Jesli przestawisz - to mierzysz wartosc
zadaną.
I cos tam pisza o resetowaniu tą linia - moze program resetuje co pare
minut ?

J.

Marek
Guest

Thu Aug 02, 2018 1:31 pm   



On Thu, 2 Aug 2018 07:35:07 -0500, "Pszemol" <Pszemol_at_PolBox.com>
wrote:
Quote:
Jeśli nie da się tego inaczej naprawić jak projektowanie od nowa
to wtedy pomyślę, ale wolałbym zrobić małą, prostą modyfikację.

Jeśli urządzenie jest termostatem z fixed trip points to nie ma nic
prostszego i pewnego za razem niż zamiana na ds1821 z
predefiniowanymi ustawieniami.

--
Marek

J.F.
Guest

Thu Aug 02, 2018 2:49 pm   



Użytkownik "Pszemol" napisał w wiadomości grup
dyskusyjnych:pjv38f$vbc$1_at_dont-email.me...
J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
Quote:
Nie wiem, zwłaszcza że teraz się zastanowiłem, że wyjście
zanegowane
(źle go nazwałem "odwracające" wczoraj) /TOver jest aktywne, gdy
temperatura otoczenia jest powyżej Ttrip ustawione u mnie na 24C.
Aktywne, czyli wyjście LOW i tranzystor open colector przewodzi.
Grzałka wtedy jest wyłączona Smile)

Ale skoro tak ... to jak spowodowales wlaczenie grzalki ?
Trzeba bylo uklad schlodzic, czy prog jest ustawiony wyzej ?
Bo skoro grzalka odlaczona, to sie nie powinien przestawic ... wiec
moze jakies zaklocenia lapie ?

Testuje w termotronie - ustawiam temperature powietrza na 4C i
urządzenie w
obudowie się schładza, aż wnętrze przejdzie przez próg termostatu i
włączy
grzałkę (zamiast grzałki jest tam teraz brzęczyk).
Problem polega na tym, że jak tylko układ się przełączy na grzanie to
następuje auto-podgrzewanie się, bo za parę minut temperaturę chip
zgłasza
10C większą.

Jak widac - nie od wyjscia /TOver sie nagrzewa, bo ono przestaje
przewodzic.
Grzac sie moze ten dodatkowy tranzystor, optotriak - ale przeciez nie
na tyle, zeby podgrzac naszego chipa o 10 C :-)

Palcem pomacac, co tam takiego goracego sie robi ? :-)

Quote:
Teraz patrzę na obwód optotriaka który jest załączany tym zanegowanym
Tover
przez tranzystor MMBTA05-TP.
Ten tranzystor załącza leda optotriaka przez opornik 150 ohm z 3.3V i
jednocześnie, (równolegle) innego leda (żółtego) dla sygnalizacji
załączenia grzania, też przez opornik 150 ohm. To już całkiem spory
prąd i
ten tranzystor może się grzać...

Nie powinien. To nam daje ok 10mA na opornik, bardzo przyzwoity prad,
tranzystor bez trudu powinien sie otworzyc i pozostac zimnym.
Ale sprawdzic warto ... czy aby na pewno sa to 150 ohm

A moze te oporniki grzeja chipa ?

J.

HF5BS
Guest

Thu Aug 02, 2018 3:26 pm   



Użytkownik "Pszemol" <Pszemol_at_PolBox.com> napisał w wiadomości
news:pjv38f$vbc$1_at_dont-email.me...
Quote:
Testuje w termotronie - ustawiam temperature powietrza na 4C i urządzenie
w
obudowie się schładza, aż wnętrze przejdzie przez próg termostatu i włączy
grzałkę (zamiast grzałki jest tam teraz brzęczyk).
Problem polega na tym, że jak tylko układ się przełączy na grzanie to
następuje auto-podgrzewanie się, bo za parę minut temperaturę chip zgłasza
10C większą.

Może jak się przełącza, to już mu tak zimno, iż dostaje dreszczy? A to, jak
wiemy, jest fizyczną/fizjologiczną reakcją na zimno i zmierza do ogrzania
organizmu. Może w ten deseń?

:))

--
Łapy, łapy, cztery łapy,
A na łapach pies kudłaty.
Kto dogoni psa? Kto dogoni psa?
Może ty? Może ty? Może jednak ja...?

PS. Oczywiście, to był żart Smile

Pszemol
Guest

Thu Aug 02, 2018 4:08 pm   



J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
Quote:
Użytkownik "Pszemol" napisał w wiadomości grup
dyskusyjnych:pjutmh$r0n$1_at_dont-email.me...
"J.F." <jfox_xnospamx_at_poczta.onet.pl> wrote in message
Dnia Wed, 1 Aug 2018 19:38:51 -0500, Pszemol napisał(a):
Co posprawdzałem - ano wyjście odwracające TOver, które
pracuje w układzie otwartego kolektora, zasilane jest z pull-upa
4,7kohm z Vcc (3,3V). Podłączona tam jest także baza tranzytora
NPN który steruje opto-triakiem. Czyli prąd wyjścia w stanie LOW
gdy open drain przewodzi jest rzędu 0,6-0,7mA. Czy tak mały
prąd może powodować samoogrzewanie się układu? Datasheet
pokazuje opornik 100kohm w roli pullup... ciekawe....

A napiecie na tym wyjsciu jakie wtedy ?

0.5V*0.7mA = 0.35mW, a rezystancja termiczna 0.183 C/mW ... nie, to
nie jest 7 st

Według datasheeta, przy prądzie <600uA napięcie <0,2V.

Ale zmierz, to sie moze duzo wyjasnic.

A może 4,7k jest ok i po prostu jakiś inny komponent blisko się
grzeje?
Wielce prawdopodobne ... ale skad ta reakcja na wlaczenie
optotriaka ?

Nie wiem, zwłaszcza że teraz się zastanowiłem, że wyjście zanegowane
(źle go nazwałem "odwracające" wczoraj) /TOver jest aktywne, gdy
temperatura otoczenia jest powyżej Ttrip ustawione u mnie na 24C.
Aktywne, czyli wyjście LOW i tranzystor open colector przewodzi.
Grzałka wtedy jest wyłączona Smile)

No tak, to nawet jak sie grzeje od pradu rezystora, to tym bardziej
bedzie wyjscie przewodzic i grzalki nie wlaczac.

Ale skoro tak ... to jak spowodowales wlaczenie grzalki ?
Trzeba bylo uklad schlodzic, czy prog jest ustawiony wyzej ?
Bo skoro grzalka odlaczona, to sie nie powinien przestawic ... wiec
moze jakies zaklocenia lapie ?

Testuje w termotronie - ustawiam temperature powietrza na 4C i urządzenie w
obudowie się schładza, aż wnętrze przejdzie przez próg termostatu i włączy
grzałkę (zamiast grzałki jest tam teraz brzęczyk).
Problem polega na tym, że jak tylko układ się przełączy na grzanie to
następuje auto-podgrzewanie się, bo za parę minut temperaturę chip zgłasza
10C większą.

Quote:
-dodaj drugi na drugie TOver - bedzie stale grzanie
Drugi TOver, ten niezanegowany, jest push-pull, nie open colector.

To nam nie przeszkadza w kwestii wyrowania mocy strat, ale jak teraz
patrze - chyba nie ona jest przyczyną.

Chyba nie - samogrzanie jest obserwowane gdy zanegowane Tover jest w stanie
wysokim... a więc prąd nie płynie przez open collector.

Teraz patrzę na obwód optotriaka który jest załączany tym zanegowanym Tover
przez tranzystor MMBTA05-TP.
Ten tranzystor załącza leda optotriaka przez opornik 150 ohm z 3.3V i
jednocześnie, (równolegle) innego leda (żółtego) dla sygnalizacji
załączenia grzania, też przez opornik 150 ohm. To już całkiem spory prąd i
ten tranzystor może się grzać... jeśli jest blisko tego termostatu LM57 na
płytce to będzie problem...

Quote:
-zmierz zasilanie - moze ono plywa, albo smieci lataja,
-punkt 8.3.6.3 ... i 9.1.1
-dodaj kondensator na zasilaniu,
-a trip test dobry ? Moze mierzysz co innego

Trip jest dobry: według wyjścia analogowego grzałka się
załącza przy napięciu 1.028 i wyłacza przy temperaturze
10 C wyższej.

Ale ja o linii Trip_test. Jesli przestawisz - to mierzysz wartosc
zadaną.
I cos tam pisza o resetowaniu tą linia - moze program resetuje co pare
minut ?

Trip test jest nieużywane, zwarte do masy.

Pszemol
Guest

Thu Aug 02, 2018 6:44 pm   



HF5BS <hf5bs_at_t.pl> wrote:
Quote:

Użytkownik "Pszemol" <Pszemol_at_PolBox.com> napisał w wiadomości
news:pjv38f$vbc$1_at_dont-email.me...
Testuje w termotronie - ustawiam temperature powietrza na 4C i urządzenie
w
obudowie się schładza, aż wnętrze przejdzie przez próg termostatu i włączy
grzałkę (zamiast grzałki jest tam teraz brzęczyk).
Problem polega na tym, że jak tylko układ się przełączy na grzanie to
następuje auto-podgrzewanie się, bo za parę minut temperaturę chip zgłasza
10C większą.

Może jak się przełącza, to już mu tak zimno, iż dostaje dreszczy? A to, jak
wiemy, jest fizyczną/fizjologiczną reakcją na zimno i zmierza do ogrzania
organizmu. Może w ten deseń?

:))

Dobre!
Napisze tak w raporcie dla szefa...

Pszemol
Guest

Thu Aug 02, 2018 11:18 pm   



"Marek" <fake_at_fakeemail.com> wrote in message
news:almarsoft.5738275406992878788_at_news.neostrada.pl...
Quote:
On Thu, 2 Aug 2018 07:35:07 -0500, "Pszemol" <Pszemol_at_PolBox.com> wrote:
Jeśli nie da się tego inaczej naprawić jak projektowanie od nowa
to wtedy pomyślę, ale wolałbym zrobić małą, prostą modyfikację.

Jeśli urządzenie jest termostatem z fixed trip points to nie ma nic
prostszego i pewnego za razem niż zamiana na ds1821 z predefiniowanymi
ustawieniami.

Widzę że to ma interface do komputera - ten mój układ
nie ma żadnej inteligencji, nie ma procka: ustawiony
jest próg na stałe, histereza 10C na stałe i pyka grzałką.

Gdyby można było zastosować normalny przełącznik
termiczny to sprawę załatwiłby jeden komponent, ale
ma to być rozwiązanie "beziskrowe" (czyli nie przekaźnik
ani jakiś bimetalowy zwieracz tylko silikonowy klucz).

Wyszedł z tego niezły overkill (z armaty do komara).

Pszemol
Guest

Fri Aug 03, 2018 12:12 am   



J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
Quote:
Użytkownik "Pszemol" napisał w wiadomości grup
dyskusyjnych:pjutmh$r0n$1_at_dont-email.me...
"J.F." <jfox_xnospamx_at_poczta.onet.pl> wrote in message
Dnia Wed, 1 Aug 2018 19:38:51 -0500, Pszemol napisał(a):
Co posprawdzałem - ano wyjście odwracające TOver, które
pracuje w układzie otwartego kolektora, zasilane jest z pull-upa
4,7kohm z Vcc (3,3V). Podłączona tam jest także baza tranzytora
NPN który steruje opto-triakiem. Czyli prąd wyjścia w stanie LOW
gdy open drain przewodzi jest rzędu 0,6-0,7mA. Czy tak mały
prąd może powodować samoogrzewanie się układu? Datasheet
pokazuje opornik 100kohm w roli pullup... ciekawe....

A napiecie na tym wyjsciu jakie wtedy ?

0.5V*0.7mA = 0.35mW, a rezystancja termiczna 0.183 C/mW ... nie, to
nie jest 7 st

Według datasheeta, przy prądzie <600uA napięcie <0,2V.

Ale zmierz, to sie moze duzo wyjasnic.

A może 4,7k jest ok i po prostu jakiś inny komponent blisko się
grzeje?
Wielce prawdopodobne ... ale skad ta reakcja na wlaczenie
optotriaka ?

Nie wiem, zwłaszcza że teraz się zastanowiłem, że wyjście zanegowane
(źle go nazwałem "odwracające" wczoraj) /TOver jest aktywne, gdy
temperatura otoczenia jest powyżej Ttrip ustawione u mnie na 24C.
Aktywne, czyli wyjście LOW i tranzystor open colector przewodzi.
Grzałka wtedy jest wyłączona Smile)

No tak, to nawet jak sie grzeje od pradu rezystora, to tym bardziej
bedzie wyjscie przewodzic i grzalki nie wlaczac.

Ale skoro tak ... to jak spowodowales wlaczenie grzalki ?
Trzeba bylo uklad schlodzic, czy prog jest ustawiony wyzej ?
Bo skoro grzalka odlaczona, to sie nie powinien przestawic ... wiec
moze jakies zaklocenia lapie ?

-dodaj drugi na drugie TOver - bedzie stale grzanie
Drugi TOver, ten niezanegowany, jest push-pull, nie open colector.

To nam nie przeszkadza w kwestii wyrowania mocy strat, ale jak teraz
patrze - chyba nie ona jest przyczyną.

Ano nie jest...

Otóż ten układ jest zasilany prosto z sieci...
Użyty jest beztransformatorowy zasilacz na NCP1014, ustawiony aby
produkował 11V i to jest podawane na micropower regulator LP2981. Oba
układy grzeją się sporo...

Z tego regulatora zasilana jest zielona LED sygnalizująca zasilanie (150
ohm opornik z 3.3V zielony led, czyli prawie 10mA).

Jak układ wykryje temperature niższą niż progowa, czyli włączy grzałkę, to
dostajemy dodatkowy pobór prądu rzędu 20mA bo mamy żółtą diodę
sygnalizującą załączenie grzałki i leda wewnątrz optotriaka, a właściwie
optycznie izolowanego sterownika normalnego triaka (układ MOC3020) czyli 2x
10mA przyrost prądu i regulator LP2981 się grzeje jeszcze bardziej gdy
grzałka włączona i podgrzewa termostat siedzący na laminacje FR4 obok...

Myślę, że dojdą dodatkowe problemy jak się to puści w Europie na dwukrotnie
większym napięciu sieciowym - pewnie NCP1014 będzie jeszcze cieplejszy :-(

Ech... nie ma chyba prostego sposobu aby to ponaprawiać "na szybko" -
trzeba to przeprojektować i odsunąć grzejące się elementy od termostatu,
ponacinać płytkę aby nie było termicznego połączenia przez włókna szklane
laminatu itp, itd...

Paweł Pawłowicz
Guest

Fri Aug 03, 2018 8:21 am   



W dniu 2018-08-03 o 00:12, Pszemol pisze:

[...]

Quote:
Myślę, że dojdą dodatkowe problemy jak się to puści w Europie na dwukrotnie
większym napięciu sieciowym - pewnie NCP1014 będzie jeszcze cieplejszy Sad

Niekoniecznie. Prądy będą mniejsze.

P.P.

Marek
Guest

Fri Aug 03, 2018 9:51 am   



On Thu, 2 Aug 2018 18:18:03 -0500, "Pszemol" <Pszemol_at_PolBox.com>
wrote:
Quote:
Widzę że to ma interface do komputera -

Interfejs 1wire, najprostszy jaki może być. W sieci na pewno
znajdziesz narzędzia do zaprogramowania ds1821 z pc. Są też do tego
tony bibliotek do popularnych mcu/Raspi/whatever

Quote:
ten mój układ
nie ma żadnej inteligencji, nie ma procka: ustawiony
jest próg na stałe, histereza 10C na stałe i pyka grzałką.

I idelamie pasuje do niego ds1821. Programujesz w nim raz trip pointy
i zapominasz.

Quote:
Gdyby można było zastosować normalny przełącznik
termiczny to sprawę załatwiłby jeden komponent,

Dokładnie taki jest ds1821. Jeden komponent po zaprogramowamiu
zachowuje się jak fizyczny przełącznik, który wyjściem on/off może
wysterować czymkolwiek.

--
Marek

Goto page 1, 2  Next

elektroda NewsGroups Forum Index - Elektronika Polska - Termostat: LM57 Texas Instrument

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map