RTV forum PL | NewsGroups PL

Switch D-link i AP D-link się nie widzą

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Switch D-link i AP D-link się nie widzą

Marek
Guest

Thu Dec 15, 2022 12:29 pm   



Natknąłem się na dziwny problem. Chciałem do czegoś wykorzystać stary
AP (DWL2000) podłączając go do zarządzalnego (budżetowego) switcha w
miarę współczesnego (seria DGS-1210). Wpierw AP podłączyłem do
laptopa (po eth) i go skonfigurowałem na odpowiednie statyczne
parametry sieci. Następnie podłączam go do switach'a i.. dupa. Switch
go nie widzi. Na porcie switcha zmienia się tylko licznik TX a
licznik RX 0. Ponieważ w sieci lata trochę broadcastów to obie diody
link (portu switcha i AP) migają normalnie. Switch zgłasza
prawidłowy link 100M FDX (AP ma interfejs 100M FDX). Test przewodu
OK. Próby wymuszenia na stałe MDI/MDIX nic nie dają. Próby na innych
portach to samo. Wyłączenie PoE na porcie (switch wspiera PoE) nic
nie zmienia. Podłączenie AP z powrotem do laptopa - komunikacja z AP
jest prawidłowa.
Na switch'u nie mam żadnych egzotycznych konfiguracji, nie
wykorzystuję jego funkcji zarządzalnych.

Co może być przyczyną, że nie chce działać? Czy w ciągu 15 lat (tyle
mniej więcej czasu dzieli oba urządzenia) coś się zmieniło w
ethernecie, że jest jakaś niekompatybilność? Zastrzegam, że jak dotąd
ten switch nie robił żadnych problemów z innymi urządzeniami ani ten
AP z innymi urządzeniami również...

--
Marek

Cezar
Guest

Thu Dec 15, 2022 2:23 pm   



On 15/12/2022 11:29, Marek wrote:
Quote:
Natknąłem się na dziwny problem. Chciałem do czegoś wykorzystać stary AP
(DWL2000) podłączając go do zarządzalnego (budżetowego) switcha w miarę
współczesnego (seria DGS-1210). Wpierw AP podłączyłem do laptopa (po
eth) i go skonfigurowałem na odpowiednie statyczne parametry sieci.
Następnie podłączam go do switach'a i.. dupa. Switch go nie widzi. Na
porcie switcha zmienia się tylko licznik TX a licznik RX 0. Ponieważ w
sieci lata trochę broadcastów to obie diody link  (portu switcha i AP)
migają normalnie. Switch zgłasza prawidłowy link 100M FDX (AP ma
interfejs 100M FDX). Test przewodu OK. Próby wymuszenia na stałe
MDI/MDIX nic nie dają. Próby na innych portach to samo. Wyłączenie PoE
na porcie (switch wspiera PoE) nic nie zmienia. Podłączenie AP z
powrotem do laptopa - komunikacja z AP jest prawidłowa.
Na switch'u nie mam żadnych egzotycznych konfiguracji, nie wykorzystuję
jego funkcji zarządzalnych.

Co może być przyczyną, że nie chce działać? Czy w ciągu 15 lat (tyle
mniej więcej czasu dzieli oba urządzenia) coś się zmieniło w ethernecie,
że jest jakaś niekompatybilność? Zastrzegam, że jak dotąd ten switch nie
robił żadnych problemów z innymi urządzeniami ani ten AP z innymi
urządzeniami również...


moze brak Auto-MDIX? Spróbuj połączyć kablem z krosem.

c.

J.F
Guest

Thu Dec 15, 2022 3:39 pm   



On Thu, 15 Dec 2022 12:29:29 +0100, Marek wrote:
Quote:
Natknąłem się na dziwny problem. Chciałem do czegoś wykorzystać stary
AP (DWL2000) podłączając go do zarządzalnego (budżetowego) switcha w
miarę współczesnego (seria DGS-1210). Wpierw AP podłączyłem do
laptopa (po eth) i go skonfigurowałem na odpowiednie statyczne
parametry sieci. Następnie podłączam go do switach'a i.. dupa. Switch
go nie widzi. Na porcie switcha zmienia się tylko licznik TX a
licznik RX 0. Ponieważ w sieci lata trochę broadcastów to obie diody
link (portu switcha i AP) migają normalnie.

A tak w miare synchronicznie migają, czy kazda w swoim tempie?

Quote:
Switch zgłasza
prawidłowy link 100M FDX (AP ma interfejs 100M FDX). Test przewodu
OK. Próby wymuszenia na stałe MDI/MDIX nic nie dają. Próby na innych
portach to samo. Wyłączenie PoE na porcie (switch wspiera PoE) nic
nie zmienia. Podłączenie AP z powrotem do laptopa - komunikacja z AP
jest prawidłowa.
Na switch'u nie mam żadnych egzotycznych konfiguracji, nie
wykorzystuję jego funkcji zarządzalnych.

Co może być przyczyną, że nie chce działać? Czy w ciągu 15 lat (tyle
mniej więcej czasu dzieli oba urządzenia) coś się zmieniło w
ethernecie, że jest jakaś niekompatybilność? Zastrzegam, że jak dotąd
ten switch nie robił żadnych problemów z innymi urządzeniami ani ten
AP z innymi urządzeniami również...

Kabelek ten sam, co laczy do laptopa?

Podejrzewam problem MDI/MDIX. Masz skrosowany kabelek pod ręką?
Choc niby rozpoznaja

Ale jesli nie to ..
-port na switchu jakis specjalny ... a zamien kabelki.
zaraz - laptop na tym porcie dziala?

-zapomniala sie jakas reguła,
-VLAN powlączane ... DWL2000 to ich chyba nie ma

-kabel slabo kontaktuje i odpowiednio wygiety w laptopie dziala.

J.

Marek
Guest

Thu Dec 15, 2022 6:05 pm   



On Thu, 15 Dec 2022 13:23:17 +0000, Cezar <cezar91_at_tlen.pl.invalid>
wrote:
Quote:
moze brak Auto-MDIX? Spróbuj połączyć kablem z krosem.

Wszystkie sposoby i możliwości z MDIX zawiodły. Okazało się, że
źródłem problemu jest tryb "client mode" AP. W tym trybie podłączony
bezpośrednio do laptopa jest widoczny, podłączony do jakiekolwiek
switcha "widzi" tylko laptopa podłączonego do tego switach'a a nie
widzi żadnych innych IP urządzeń z tej samej sieci na tym samym
switch'u. Nie rozumiem tego jak to możliwe.
Wszystkie urządzenia wraz z tym laptopem są w tej samej podsieci.
Wygląda było tak jakby włączenie konfiguracji "client mode" zapisalo
gdzieś na AP Mac zrodlowy komputera, z którego dokonano konfiguracji
(przez interfejs webowy AP) i po restarcie odpowiadał na arp *tylko*
z tego komputera. Dziw nad dziwy.

--
Marek

J.F
Guest

Thu Dec 15, 2022 6:37 pm   



On Thu, 15 Dec 2022 18:05:01 +0100, Marek wrote:
Quote:
On Thu, 15 Dec 2022 13:23:17 +0000, Cezar <cezar91_at_tlen.pl.invalid
wrote:
moze brak Auto-MDIX? Spróbuj połączyć kablem z krosem.

Wszystkie sposoby i możliwości z MDIX zawiodły. Okazało się, że
źródłem problemu jest tryb "client mode" AP. W tym trybie podłączony
bezpośrednio do laptopa jest widoczny, podłączony do jakiekolwiek
switcha "widzi" tylko laptopa podłączonego do tego switach'a a nie
widzi żadnych innych IP urządzeń z tej samej sieci na tym samym
switch'u. Nie rozumiem tego jak to możliwe.

Cos mi skleroza podpowiada, ze to moze byc tryb umożliwiajacy
podłącznie komputer tylko z Ethernetem, do sieci Wifi.
Taka po prostu "karta wifi" podlaczona przez interfejs ethernet,
czyli inną kartę.

https://eu.dlink.com/uk/en/support/faq/access-points-and-range-extenders/what-do-the-modes-mean-on-my-ap

Ale w tym trybie AP nie jest chyba Access Pointem ... sprawdzales,
czy siec wifi z niego jest widoczna?

Natomiast co by to mialo zmieniac w dzialaniu AP ...
jakos sie zafiksowal na pierwszym MAC z ethernetu, i innych nie
obslugiwał?
Bo zasadniczo spodziewa sie wtedy tylko jednego komputera na kablu.
Chociaz ... a czemu nie kilka?

Quote:
Wszystkie urządzenia wraz z tym laptopem są w tej samej podsieci.
Wygląda było tak jakby włączenie konfiguracji "client mode" zapisalo
gdzieś na AP Mac zrodlowy komputera, z którego dokonano konfiguracji
(przez interfejs webowy AP) i po restarcie odpowiadał na arp *tylko*
z tego komputera. Dziw nad dziwy.

Moze niekoniecznie, patrząc na powyzsze.
Chyba musi po Wifi stosowac MAC komputera, bo jak mialby chocby ARP
działać?

Ale zeby go zapamiętał na stałe? Troche dziwne mi sie wydaje.

No i powinienes móc sie dostac do niego z tego laptopa przez switch -
chyba, ze tego nie probowałes.

Pozostaje maly test - podlaczyc do jednego kompa, skonfigurowac,
podlaczyc do drugiego kompa. I zobaczyc co wyjdzie przed restartem i
po.

poza tym w tym trybie powinien pchac w kabel wszystko co przychodzi
po wifi ... no ale jesli nic sie do wifi nie podlączylo, to i nic nie
pcha.

J.

heby
Guest

Thu Dec 15, 2022 6:45 pm   



On 15/12/2022 18:05, Marek wrote:
Quote:
problemu jest tryb "client mode" AP. W tym trybie podłączony
bezpośrednio do laptopa jest widoczny, podłączony do jakiekolwiek
switcha "widzi" tylko laptopa podłączonego do tego switach'a  a nie
widzi żadnych innych IP urządzeń z tej samej sieci na tym samym
switch'u. Nie rozumiem tego jak to możliwe.

To się nazywa isolation mode[1], w wielu routerach jest to możliwe do
zmiany. Robi się to w prosty sposób, każdy pakiet urządzenia wifi musi
najpierw być obrobiony przez AP wifi, aby mógł być rozesłany, jako
broadcast do innych (urządzenia wzajemnie się nie słyszą bezpośrednio,
to nie jest sieć typu ethernet). I tutaj się wstawia filtr... Dodatkowo
bywa, że ten sam efekt filtracji jest pomiędzy ethernetem i wifi.

[1]
https://support.denon.com/app/answers/detail/a_id/3746/~/wireless%2C-ap-or-client-isolation

Paweł Pawłowicz
Guest

Thu Dec 15, 2022 9:09 pm   



W dniu 15.12.2022 o 18:05, Marek pisze:
Quote:
On Thu, 15 Dec 2022 13:23:17 +0000, Cezar <cezar91_at_tlen.pl.invalid> wrote:
moze brak Auto-MDIX?  Spróbuj połączyć kablem z krosem.

Wszystkie sposoby i możliwości z MDIX zawiodły. Okazało się, że źródłem
problemu jest tryb "client mode" AP. W tym trybie podłączony
bezpośrednio do laptopa jest widoczny, podłączony do jakiekolwiek
switcha "widzi" tylko laptopa podłączonego do tego switach'a  a nie
widzi żadnych innych IP urządzeń z tej samej sieci na tym samym
switch'u. Nie rozumiem tego jak to możliwe.
Wszystkie urządzenia wraz z tym laptopem są w tej samej podsieci.
Wygląda było tak jakby włączenie konfiguracji "client mode" zapisalo
gdzieś na AP Mac zrodlowy komputera, z którego dokonano konfiguracji
(przez interfejs webowy AP) i po restarcie odpowiadał na arp *tylko* z
tego komputera. Dziw nad dziwy.

Czy jest jakiś powód, dla którego nie możesz go przełączyć w tryb AP?
Warto też pamiętać o open WRT.

Paweł

Mirek
Guest

Thu Dec 15, 2022 10:13 pm   



On 15.12.2022 15:39, J.F wrote:

Quote:
-kabel slabo kontaktuje i odpowiednio wygiety w laptopie dziala.


Kontakt to pierwsze co bym sprawdził.
Zdarzyło mi się, że druciki nie mieściły się w przegródki rj-ki.

--
Mirek.

Mirek
Guest

Thu Dec 15, 2022 10:21 pm   



On 15.12.2022 21:09, Paweł Pawłowicz wrote:

Quote:
Warto też pamiętać o open WRT.

DWL2000 niekompatybilny.

--
Mirek.

Marek
Guest

Thu Dec 15, 2022 11:23 pm   



On Thu, 15 Dec 2022 18:45:56 +0100, heby <heby_at_poczta.onet.pl> wrote:
Quote:
To się nazywa isolation mode[1], w wielu routerach jest to możliwe
do

Nie, to nie o to chodzi. Mialo byc "WiFi client mode", czyli AP staje
się "kartą wifi" jak pisał J.F.

--
Marek

elektroda NewsGroups Forum Index - Elektronika Polska - Switch D-link i AP D-link się nie widzą

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map