RTV forum PL | NewsGroups PL

SIM800L - problemy z zasięgiem

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - SIM800L - problemy z zasięgiem

Atlantis
Guest

Sat May 18, 2019 12:48 pm   



Jeszcze raz wracam do tematu, który poruszałem już wcześniej.
Mam urządzenie z chińskim modułem SIM800L, takim jak ten:
https://allegro.pl/oferta/8032765153
Moja wersja jest trochę wcześniejsza, zamiast tej helikalnej antenki
jest wlutowany w płytę odcinek wygiętego pod kątem goldpina o
odpowiedniej (mam nadzieję) długości.

Problem polega na tym, że moduł co jakiś czas gubi zasięg. Dioda na nim
miga z częstotliwością 1Hz, co oznacza właśnie brak zalogowania w sieci.
Na numer przypisany do karty SIM nie da się dodzwonić (poczta głosowa) a
po wysłaniu SMS-a nie dostaje się potwierdzenia doręczenia. Często
(chociaż nie zawsze) pomaga fizyczne odłączenie i ponowne podłączenie
urządzenia do prądu. Często po jakimś czasie (nawet kilkudziesięciu
minutach) modułowi udaje się ponownie zalogować. Urządzenie jest
zainstalowane w centrum dużego miasta.

Myślę, że można już na wstępie wykluczyć problemy z zasilaniem. Za
zasilanie całości odpowiada zasilacz 5V/2A. Sam moduł GSM jest zasilany
napięciem 3,5V, generowanym przez moduł przetwornicy impulsowej, o
wydajności 3A. W pobliżu modułu znajduje się kilka kondensatorów
tantalowych 220uF. Reszta elektroniki jest zasilana przez LDO 3,3V.

Żeby było ciekawiej - zbudowałem też drugą wersję tego samego
urządzenia. Projekt PCB zawiera co prawda niewielkie poprawki, ale nie
wydaje mi się, żeby były to rzeczy krytyczne - po prostu trochę
zracjonalizowałem rozmieszczenie paru elementów na PCB. To drugie
urządzenie działa w tej chwili testowo u mnie w domu, teren wiejski,
jakieś 30 km od przedmieść. I właśnie z tym drugim nie ma najmniejszego
problemu - działa 100% prawidłowo i stabilnie.

Jedyny eksperyment jaki mi w tej chwili przychodzi to podmiana. Jednak
zanim to zrobię, chciałbym się upewnić jeszcze co do jednego, bo
występuje jeszcze jedna zmienna - operator. Pierwsze urządzenie pracuje
w Orange, drugie ma włożoną tymczasowo kartę Play'a.

Czy jest teoretycznie możliwe, żeby Orange miał problem z zasięgiem GSM
(bo pamiętajmy, że SIM800L nowszych sieci nie wspiera) w centrum dużego
miasta?

Atlantis
Guest

Sat May 18, 2019 12:52 pm   



I jeszcze jedno pytanie: czy korzystając z anteny wlutowanej w taką
płytkę (czy to helikalnej z drutu, czy to typu "długi goldpin")
powinienem zdemontować gniazdko UFL? Ono nie przeszkadza w czymś
przypadkiem? Pytam, bo pamiętam, że często w modułach WiFi (ESP8266,
ESP32) korzystanie z gniazdka antenowego zamiast anteny PCB wymaga
przelutowania jednego kondensatora 0R. Tutaj gniazdko jest połączone
bezpośrednio do pina, do którego ma być przylutowana antena...

Bytomir Szimoza
Guest

Sat May 18, 2019 2:56 pm   



https://mapabts.pl

Atlantis
Guest

Sat May 18, 2019 3:40 pm   



Mam jeszcze jedną hipotezę, o którą chciałbym zapytać.
Moduł GSM jest zasilany z takiego modułu impulsowego:
https://allegro.pl/oferta/7405674255

Jak wspominałem całość jest zasilana z zasilacza impulsowego 5V/2A (w
praktyce mierzone napięcie wynosi nieco ponad 5,1V).

W internecie natknąłem się na informację, że te moduły z LM2596S
wymagają przynajmniej 1,5V różnicy pomiędzy napięciem wejściowym i
wyjściowym. Tak więc w tej chwili napięcie zasilania modułu jest
ustawione na 3,5V.

Datasheet SIM800L mówi, że zakres dopuszczalnych napięć wynosi 3,4-4,2V,
przy czym 4V to napięcie zalecane.

Jak widać wszystko mocno "na styk". Czy taka sytuacja może teoretycznie
powodować problemy z zasięgiem?

Jeśli tak, może powinienem zastosować zasilacz 6V/2A i ustawić
przetwornicę na 4V na wyjściu?

Janusz
Guest

Sat May 18, 2019 3:55 pm   



W dniu 2019-05-18 o 14:48, Atlantis pisze:

Quote:
Czy jest teoretycznie możliwe, żeby Orange miał problem z zasięgiem GSM
(bo pamiętajmy, że SIM800L nowszych sieci nie wspiera) w centrum dużego
miasta?

Ma, ja tak mam na obrzeżach miasta, mam nokie3510 do alarmu i w
zależności jak ją obrócę to zasięg mam albo nie, a jest na 1 piętrze, z
tel miałem podobnie, na parterze
raz był zasięg raz nie, w końcu zmieniłem operatora na
tmobile i mam zasięg nawet w piwnicy Smile

Atlantis
Guest

Sat May 18, 2019 4:20 pm   



On 18.05.2019 17:55, Janusz wrote:

Quote:
Ma, ja tak mam na obrzeżach miasta, mam nokie3510 do alarmu i w
zależności jak ją obrócę to zasięg mam albo nie, a jest na 1 piętrze, z
tel miałem podobnie, na parterze
raz był zasięg raz nie, w końcu zmieniłem operatora na
tmobile i mam zasięg nawet w piwnicy Smile

Hmm... Zaobserwowałem jeszcze jedną rzecz - moduł w przypadku braku
połączenia nie tylko miga z częstotliwością 1Hz (brak połączenia z
siecią). Często można zaobserwować cykl - seria 7-10 mignięć, kilka
sekund przerwy, kolejna seria i tak dalej. W kodzie mam co prawda
zaimplementowane automatyczne restartowanie modułu, gdyby w trakcie
konfiguracji zwrócił ERROR, ale nie sądzę, żeby tu leżała przyczyna.
Konfiguracja to tak naprawdę sprawdzanie odpowiedzi na "AT", wyłączenie
echa, ustawienie sposobu obsługi SMS-ów i wyczyszczenie starych
wiadomości. Nie ma tak niczego, co mogłoby być nieprzewidywalne albo
zależne od warunków zewnętrznych.

Stąd może przyczyna leży gdzieś po stronie zasilania? Jeszcze jeden
spory kondensator low-ESR przy pinach SIM800L? Podnieść napięcie
zasilania modułu do 4V?

Zbych
Guest

Sat May 18, 2019 7:56 pm   



Atlantis wrote on 18.05.2019 14:48:

Quote:
Moja wersja jest trochę wcześniejsza, zamiast tej helikalnej antenki
jest wlutowany w płytę odcinek wygiętego pod kątem goldpina o
odpowiedniej (mam nadzieję) długości.

I jaka to jest długość? Ten wygięty kawałek sterczy pionowo czy poziomo
w stosunku do płaszczyzny ziemi?

Quote:
Problem polega na tym, że moduł co jakiś czas gubi zasięg. Dioda na nim
miga z częstotliwością 1Hz, co oznacza właśnie brak zalogowania w sieci.
Na numer przypisany do karty SIM nie da się dodzwonić (poczta głosowa) a
po wysłaniu SMS-a nie dostaje się potwierdzenia doręczenia. Często
(chociaż nie zawsze) pomaga fizyczne odłączenie i ponowne podłączenie
urządzenia do prądu. Często po jakimś czasie (nawet kilkudziesięciu
minutach) modułowi udaje się ponownie zalogować. Urządzenie jest
zainstalowane w centrum dużego miasta.

A masz jakąś możliwość wyświetlania poziomu sygnału z tego modułu
(rssi)? Bo antenę masz dziadowską, nie wiadomo jakie otoczenie (anteny i
modułu), jaką odległość od BTS. Może moduł jest na granicy możliwości i
stąd utrata połączenia i problem z ponownym nawiązaniem.

Marek
Guest

Sat May 18, 2019 8:39 pm   



On Sat, 18 May 2019 18:20:32 +0200, Atlantis <marekw1986NOSPAM_at_wp.pl>
wrote:
Quote:
Hmm... Zaobserwowałem jeszcze jedną rzecz - moduł w przypadku braku
połączenia nie tylko miga z częstotliwością 1Hz (brak połączenia z
siecią).

"Brak połączenia" to mało precyzyjne. W większości modułów równe
miganie 1Hz oznacza szukanie sieci, owszem chwilowo brak połączenia
ale moduł nie siedzi a laurach tylko szuka. Co może oznaczać
faktycznie problem z zasięgiem (anteną) a nie samym modułem.
Status sieci zwraca polecenie at+creg? . Kod który zwróci oznacza
aktualny stan, zweryfikuj go z dokumentacją.
A propos sieci 2G, kiedyś były plany stopniowego wygaszania wsparcia
2G u niektórych operatorów. Może to już się dzieje.

--
Marek

jacek pozniak
Guest

Sat May 18, 2019 10:30 pm   



Quote:
Jeszcze raz wracam do tematu, który poruszałem już wcześniej.
Mam urządzenie z chińskim modułem SIM800L, takim jak ten:
https://allegro.pl/oferta/8032765153
Moja wersja jest trochę wcześniejsza, zamiast tej helikalnej antenki
jest wlutowany w płytę odcinek wygiętego pod kątem goldpina o
odpowiedniej (mam nadzieję) długości.

Goldpin to chyba nie ma wystarczającej długosci aby sie dopasować do

długości fali

jp

Atlantis
Guest

Sun May 19, 2019 5:39 am   



On 19.05.2019 00:30, jacek pozniak wrote:

Quote:
Goldpin to chyba nie ma wystarczającej długosci aby sie dopasować do
długości fali

To nie jest zwykły goldpin, dlatego napisałem to słowo w cudzysłowie. Po
prostu element ten jest wykonany z tego samego typu drutu i na jednej z
końcówek ma plastikowy element przylegający do płytki. Prawdopodobnie
Chińczycy wykorzystali tę samą maszynę, której używa się do produkcji
goldpinów.

Różnica jest w długości - drucik będzie miał łącznie jakieś niecałe 3 cm
długości, łączne z częścią wlutowaną w płytkę. Po jakichś 5 mm jest
wygięty pod kątem nieco ponad 100 stopni, tak więc po wlutowaniu w
płytkę dłuższa część odstaje od niej pod kątem kilkunastu stopni.

Takie "antenki" były fabrycznie wlutowywane w te czerwone moduły jeszcze
jakiś rok czy dwa lata temu. Wtedy właśnie kupiłem kilka sztuk. Z tego
co widzę, teraz Chińczycy zmienili koncepcję i dołączają do nich albo
małe antenki helikalne z kawałka drutu, albo antenki wytrawione na
kawałku PCB.

Atlantis
Guest

Sun May 19, 2019 5:47 am   



On 18.05.2019 21:56, Zbych wrote:

Quote:
I jaka to jest długość? Ten wygięty kawałek sterczy pionowo czy poziomo
w stosunku do płaszczyzny ziemi?

Trochę ponad 2 cm. Drut odstaje o kilkanaście stopni od płaszczyzny PCB,
a więc w tej chwili jest (prawie) poziomo do płaszczyzny ziemi. Zawsze
mi się wydawało, że w przypadku GSM to nie powinno mieć znaczenia - w
końcu telefon powinien działać w każdej pozycji...


Quote:
A masz jakąś możliwość wyświetlania poziomu sygnału z tego modułu
(rssi)? Bo antenę masz dziadowską, nie wiadomo jakie otoczenie (anteny i
modułu), jaką odległość od BTS. Może moduł jest na granicy możliwości i
stąd utrata połączenia i problem z ponownym nawiązaniem.

W tj chwili nie mam możliwości sprawdzenia sygnału. To znaczy mógłbym na
swoim module, ale jak mówiłem - w jego przypadku problem nie występuje.
Co do anteny - na początku podłączyłem do tego modułu normalną,
przykręcaną do obudowy antenę GSM. Na początku działało, ale potem
zaczęły się pojawiać problemy podobne do opisywanych wcześniej.
Wtedy roboczo założyłem, że może antena jest niedopasowana. Zdjąłem więc
górę metalowej obudowy, zdemontowałem antenę zewnętrzną i ponownie
wlutowałem tę z "goldpina".

Wydawało się, że to rozwiązało problem, ten jednak po chwili powrócił.

Próbowałem też "żonglować" kilkoma różnymi modułami, jednak bez skutki.

Właściwie jedyna rzecz jaka przychodzi mi do głowy, to umieszczenie
mojego modułu na miejscu szwankującego. Może faktycznie coś co zrobiłem
podczas "racjonalizowania" projektu ma znaczenie, jeśli chodzi o jakość
zasilania na przykład?

szod
Guest

Sun May 19, 2019 3:42 pm   



W dniu 18-05-2019 o 14:48, Atlantis pisze:

Quote:
Problem polega na tym, że moduł co jakiś czas gubi zasięg. Dioda na nim
miga z częstotliwością 1Hz, co oznacza właśnie brak zalogowania w sieci.

Może karta w gnieździe źle kontaktuje? Albo z samą kartą jest coś nie tak?

Marek
Guest

Sun May 19, 2019 4:41 pm   



On Sun, 19 May 2019 07:47:06 +0200, Atlantis <marekw1986NOSPAM_at_wp.pl>
wrote:
Quote:
W tj chwili nie mam możliwości sprawdzenia sygnału. To znaczy
mógłbym na
swoim module, ale jak mówiłem - w jego przypadku problem nie
występuje.

Polecam na przyszłość dodać do swojego interpretera poleceń sms
możliwość wysłania (i odebrania odpowiedzi) dowolnej komendy at,.
przydaje się w nagłych przypadkach.

--
Marek

elektroda NewsGroups Forum Index - Elektronika Polska - SIM800L - problemy z zasięgiem

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map