RTV forum PL | NewsGroups PL

Problem z MCU IDE

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Problem z MCU IDE

Stachu Chebel
Guest

Mon Mar 28, 2022 12:09 am   



Już kiedyś o tym pisałem, ale dopiero teraz zabrałem się za temat na serio.
Mikrokontroler ma odczytać sygnał analogowy, zrobić filtrację i wypluć sygnał
analogowy. Wybrałem mikrokontroler, który ma na pokładzie ADC i DAC.
Konkretnie jest to MKL16Z32VFT4. Pobrałem ze strony NXP MCUExpresso IDE
oraz odpowiedni SDK i nadal nie mogę napisać softu.
Krok po kroku robię tak:
- na odsłonie powitalnej wybieram Create a New Project
- teraz klikam Go straight to the Wizard
- na panelu SDK MCUs wybieram MKL16Z32xxx4 i klikam Next
- Teraz wyświetla się okno, w którym wybieram konkretny MCU, drivery,
rodzaj projektu (C/C++) i takie tam...

I tutaj kończy się cała przygoda. Cokolwiek nie wyklikam, na tej odsłonie,
klawisz Next prowadzący do kolejnej części Wizarda jest nieaktywny.
Co do Pani Nędzy robię źle?

Marcin
Guest

Mon Mar 28, 2022 2:08 pm   



On Monday, March 28, 2022 at 12:09:44 AM UTC+2, Stachu Chebel wrote:
Quote:
Już kiedyś o tym pisałem, ale dopiero teraz zabrałem się za temat na serio.
Mikrokontroler ma odczytać sygnał analogowy, zrobić filtrację i wypluć sygnał
analogowy. Wybrałem mikrokontroler, który ma na pokładzie ADC i DAC.
Konkretnie jest to MKL16Z32VFT4. Pobrałem ze strony NXP MCUExpresso IDE
oraz odpowiedni SDK i nadal nie mogę napisać softu.
Krok po kroku robię tak:
- na odsłonie powitalnej wybieram Create a New Project
- teraz klikam Go straight to the Wizard
- na panelu SDK MCUs wybieram MKL16Z32xxx4 i klikam Next
- Teraz wyświetla się okno, w którym wybieram konkretny MCU, drivery,
rodzaj projektu (C/C++) i takie tam...

I tutaj kończy się cała przygoda. Cokolwiek nie wyklikam, na tej odsłonie,
klawisz Next prowadzący do kolejnej części Wizarda jest nieaktywny.
Co do Pani Nędzy robię źle?

Cześć,

Własnie sprawdziłem na MCUXpresso IDE v11.5.0 [Build 7232] [2022-01-11].
Po zainstalowaniu sdk SDK_2.x_MKL16Z32xxx4 da sie normalnie stworzyć projekt przez wizzarda, w wersji bare metal i free rtos.
Parę screen shootow: https://www.bawolski.net/index.html
Niestety dla tego procesora nie ma "board'a" w SDK, i nie ma przykladow do peryferiow. ( normalnie : File->New->Import example from SDK...)

Marcin

Stachu Chebel
Guest

Tue Mar 29, 2022 3:40 pm   



poniedziałek, 28 marca 2022 o 14:08:31 UTC+2 Marcin napisał(a):
Quote:
On Monday, March 28, 2022 at 12:09:44 AM UTC+2, Stachu Chebel wrote:
Już kiedyś o tym pisałem, ale dopiero teraz zabrałem się za temat na serio.
Mikrokontroler ma odczytać sygnał analogowy, zrobić filtrację i wypluć sygnał
analogowy. Wybrałem mikrokontroler, który ma na pokładzie ADC i DAC.
Konkretnie jest to MKL16Z32VFT4. Pobrałem ze strony NXP MCUExpresso IDE
oraz odpowiedni SDK i nadal nie mogę napisać softu.
Krok po kroku robię tak:
- na odsłonie powitalnej wybieram Create a New Project
- teraz klikam Go straight to the Wizard
- na panelu SDK MCUs wybieram MKL16Z32xxx4 i klikam Next
- Teraz wyświetla się okno, w którym wybieram konkretny MCU, drivery,
rodzaj projektu (C/C++) i takie tam...

I tutaj kończy się cała przygoda. Cokolwiek nie wyklikam, na tej odsłonie,
klawisz Next prowadzący do kolejnej części Wizarda jest nieaktywny.
Co do Pani Nędzy robię źle?
Cześć,

Własnie sprawdziłem na MCUXpresso IDE v11.5.0 [Build 7232] [2022-01-11].
Po zainstalowaniu sdk SDK_2.x_MKL16Z32xxx4 da sie normalnie stworzyć projekt przez wizzarda, w wersji bare metal i free rtos.
Parę screen shootow: https://www.bawolski.net/index.html
Niestety dla tego procesora nie ma "board'a" w SDK, i nie ma przykladow do peryferiow. ( normalnie : File->New->Import example from SDK...)

Marcin

Dzięki,
Udało się przebrnąć dalej, tworząc na starcie nowy Workspace. Diabli wiedzą dlaczego tak musi być.
Istotnie, nie ma borda i przykładów dla tego MCU. Jest trochę więcej dla MKL46Z256VLH4, więc dorzuciłem
odpowiednii SDK. Mam nadzieję, że syntax softwarowy będzie kompatybilny. Trochę słabo to wszystko
udokumentowane, ale mam nadzieję że metodą prób i błędów jakoś to ogarnę.

elektroda NewsGroups Forum Index - Elektronika Polska - Problem z MCU IDE

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map