RTV forum PL | NewsGroups PL

Nokia N800 - dziwna awaria ekranu

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Nokia N800 - dziwna awaria ekranu

Atlantis
Guest

Sun Jul 31, 2022 6:30 pm   



Mam w swojej kolekcji urządzenie Nokia N800 - taki wczesny tablet,
pracujący na Linuksie i przystosowany do wyświetlania stron WWW i
multimediów na niezbyt dużym ekranie. Przed 2010 rokiem robił wrażenie,
dzisiaj to już tylko historyczny artefakt.
Pomijając niemal zupełną bezużyteczność (procesor nie uciągnie żadnej
współczesnej strony ani streama z sieci, no może poza audio) urządzenie
jeszcze niedawno było całkiem sprawne. Jednak gdy jakiś czas temu
spróbowałem je właczyć zauważyłem, że coś dziwnego dzieje się z ekranem.
Obraz był niejako przełamany - na dole wyświetlał się pasek z częścią
treści, na górze niepasująca inna część.
Odłożyłem go do szuflady z myślą, że wrócę to tematu później. No i gdy
wróciłem okazało się, że problem się pogłębił - teraz nie wyświetla
właściwie nic, poza jedną linią w dolnej części ekranu. Kolory w tej
linii są konsystentne z kolorystyką systemowego interfejsu.

Co ciekawe, tuż po starcie wyświetla się splash screen z nazwą
producenta. Gdyby nie to, pewnie założyłbym, że na 99% uszkodzona
została taśma albo złącze ekranu. Jednak jak widać przez chwilę (i za
każdym razem przy starcie) urządzenia ma do niego dostęp w całości.

Wygląda to tak:
https://www.youtube.com/watch?v=sR5T-pm2Hcw

Ktoś ma jakiś pomysł co do możliwego powodu i opcji naprawy? Urządzenie
(jak wspominałem jest obecnie bezużyteczne), ale ma dla mnie pewną
wartość sentymentalno-kolekcjonerską. Wink

Marek
Guest

Mon Aug 01, 2022 10:28 am   



On Sun, 31 Jul 2022 18:30:21 +0200, Atlantis <marekw1986NOSPAM_at_wp.pl>
wrote:
Quote:
https://www.youtube.com/watch?v=sR5T-pm2Hcw

Ciekawe ze splash wyświetlił chyba prawidłowo? W sensie pełną treść.
Bo jak to kwestia zdegradowanych połączeń kolumn/wierszy to by nic
nie było...

--
Marek

heby
Guest

Mon Aug 01, 2022 11:22 am   



On 31/07/2022 18:30, Atlantis wrote:
Quote:

Sposób w jaki gaśnie to logo (przemieszczające się zaciemnienie o
nierównych brzegach) świadczy o uszkodzeniu czegoś w sterowaniu, ekran
dostaje napięcie DC i zachodzi "elektroliza" wyświetlacza. W przypadku
mojego wyświetlacza w oscyloskopie, uszkodzenie taśmy powodowało, że
backplate nie dostawało napięcia przemiennego.

W efekcie ekran zapalał się na sekundę po czym blakł w kierunku czerni w
jakiś "geometryczny" sposób.

Jeśli weźmiesz dowolny wyświetlacz lcd "zegrkowy" i podepniesz na chwile
napięcie 1.5V na dowolne nogi, to zobaczysz podobne zjawisko: segment
się spolaryzuje a po sekundzie, dwóch, zaniknie mimo utrzymywania
napięcia. LCD wymaga napięcia AC.

Wnioskuje to po tym filmie, gdzie logo utrzymuje się znacznie dłużej:

https://youtu.be/ouWedBxyces?t=377

Innymi słowy - zjawisko jake widać na twoim sugeruje, że jest problem z
napięciem AC w LCD.

Atlantis
Guest

Mon Aug 01, 2022 3:48 pm   



On 01.08.2022 11:22, heby wrote:

Quote:
Innymi słowy - zjawisko jake widać na twoim sugeruje, że jest problem z
napięciem AC w LCD.

Twoim zdaniem jest to jeszcze do uratowania?
jakieś sugestie co do tego, gdzie powinienem rozpocząć debugowanie?

heby
Guest

Mon Aug 01, 2022 5:02 pm   



On 01/08/2022 15:48, Atlantis wrote:żuFn6dsO68v7u1IFZgZHD
Quote:
Innymi słowy - zjawisko jake widać na twoim sugeruje, że jest problem
z napięciem AC w LCD.
Twoim zdaniem jest to jeszcze do uratowania?

500zł używka na allegro ;)

Quote:
jakieś sugestie co do tego, gdzie powinienem rozpocząć debugowanie?

W moim przypadku do matrycy, juz po sterowniku, leciał sygnał oznaczony
M. Był 1-szy z brzegu taśmy i taśma pękając, przerwała go. Występuje na
nim sygnał prostokątny, o częstotliwości w granicach kilkudziesięckiu
Hz. Może zacznij od tego...

Ogólnie obejrzałbym taśmę. Ostatnio trafiłem na kilka, absolutnie nic
nie robiących, które pękły ze starości.

W moim przypadku ekran był cz-b i mozliwe, że kolorowe mają sterownik
wszysty wprost w szkło. Nie widziałem ich zbyt wiele. Tak czy inaczej,
to co widać, to wręcz na pewno "elektroliza", choć pewnie z tym
zjawiskiem nie ma za dużo wspólnego. Faktem jest, że utrzymanie dłużej
LCD w tym stanie właczonego, zniszczy go.

PS. U mnie obraz było widać ledwo-ledwo, w dodatku widocznosc zależała
od zawartości. Potem do mnie dotarło, że sygnał M to tak naprawdę jest
"wypadkowym kondensatorem" i coś się tam uśredniało.

J.F
Guest

Mon Aug 01, 2022 5:38 pm   



On Mon, 1 Aug 2022 15:48:57 +0200, Atlantis wrote:
Quote:
On 01.08.2022 11:22, heby wrote:
Innymi słowy - zjawisko jake widać na twoim sugeruje, że jest problem z
napięciem AC w LCD.

Twoim zdaniem jest to jeszcze do uratowania?
jakieś sugestie co do tego, gdzie powinienem rozpocząć debugowanie?

Zakladam, ze wlaczales pare razy, i ten splash jest ciagle widoczny
.... wiec jeszcze dziala i to dobrze.

Ale to zanikanie to nie jest jakis celowy efekt, zaprogramowany?

Bo pasek w dole swieci, i mam wrazenie, ze tam jest wiecej pikseli,
ale czarnych.

Moze zacząc od wgrania firmware ...

J.

P.S no i znow oscyloskop by sie przydal, choc sciezki tam niedostepne
Sad

heby
Guest

Mon Aug 01, 2022 6:40 pm   



On 01/08/2022 17:38, J.F wrote:
Quote:
Ale to zanikanie to nie jest jakis celowy efekt, zaprogramowany?

Kto wie, możliwe też, że ekran ma "softwareowe" sterowanie i padnięcie
firmware powoduje zaprzestanie "odwracania" matrycy. Niektóre stare
monitory mają tak, jak sie je wyłączy soft przyciskiem - matryca
przestaje być zasilana AC, a obraz zanika w ciągu sekund w identyczny
sposób.

J.F
Guest

Mon Aug 01, 2022 7:07 pm   



On Mon, 1 Aug 2022 18:40:16 +0200, heby wrote:
Quote:
On 01/08/2022 17:38, J.F wrote:
Ale to zanikanie to nie jest jakis celowy efekt, zaprogramowany?

Kto wie, możliwe też, że ekran ma "softwareowe" sterowanie i padnięcie
firmware powoduje zaprzestanie "odwracania" matrycy. Niektóre stare
monitory mają tak, jak sie je wyłączy soft przyciskiem - matryca
przestaje być zasilana AC, a obraz zanika w ciągu sekund w identyczny
sposób.

Ale tam na dole jest paseczek wyswietlany - wiec matryca dziala.

Atlantis swoj ulubiony telefon chyba zna, to moze wie,
ze normalnie tak nie ma.

Chyba ze ... a jakby sie odswiezanie/skanowanie na tej jednej linii
zatrzymalo?


J.

heby
Guest

Mon Aug 01, 2022 7:21 pm   



On 01/08/2022 19:07, J.F wrote:
Quote:
Chyba ze ... a jakby sie odswiezanie/skanowanie na tej jednej linii
zatrzymalo?

To może być interesujące wyjaśnienie. Jesli software ręcznie skanuje
linie wyświetlacza "odwracając" napiecie, to kto wie.

Atlantis
Guest

Fri Aug 05, 2022 9:44 am   



On 01.08.2022 17:38, J.F wrote:

Quote:
Zakladam, ze wlaczales pare razy, i ten splash jest ciagle widoczny
... wiec jeszcze dziala i to dobrze.

Tak. Efekt jest powtarzalny. Nie jestem w stanie zagwarantować, że
zawsze splash się pojawia (bo mogłem przeoczyć którąś sytuację) ale na
pewno występuje przy zdecydowanej większości prób włączenia.
Jednak nie jest ciągle widoczny, bo jest ten efekt zanikania.


Quote:
Ale to zanikanie to nie jest jakis celowy efekt, zaprogramowany?

Nie. W poprawnie działającym urządzeniu splash screen był widoczny o
wiele dłużej - do momentu, kiedy urządzenie było w stanie zacząć
inicjalizować interfejs użytkownika.


Quote:
Bo pasek w dole swieci, i mam wrazenie, ze tam jest wiecej pikseli,
ale czarnych.

Tak, ta jedna linia na dole się świeci, więc ekran nie gaśnie
całkowicie. Co więcej - gdy problem się zaczynał właśnie to miejsce było
granicą "złamania" wyświetlanego obrazu. Na górze wyświetlał się wtedy
kawałek interfejsu, a w tym dolnym pasku inna niepasująca część. Która?
Już nie pamiętam, być może właśnie pochodząca z samej góry wyświetlacza.
Potem właśnie przestało się wyświetlać cokolwiek poza tym chwilowym
splash screenem i pojedynczą linią pikseli na dole.


Quote:
Moze zacząc od wgrania firmware ...

Spróbuję. Jeśli jeszcze uda mi się je namierzyć, wraz z niezbędnymi
narzedziami...


Quote:
P.S no i znow oscyloskop by sie przydal, choc sciezki tam niedostepne
Sad

Od jakiegoś czasu mam już Siglenta, więc mogę sprawdzić sygnały. O ile
tylko uda mi się do nich dostać przy włączonym urządzeniu.

elektroda NewsGroups Forum Index - Elektronika Polska - Nokia N800 - dziwna awaria ekranu

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map