RTV forum PL | NewsGroups PL

ktoś tu zna RTC DS1678 ?

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - ktoś tu zna RTC DS1678 ?

Goto page 1, 2  Next

sundayman
Guest

Mon Jan 08, 2024 4:11 am   



Ostatnio mi się przytrafiła przykra wpadka z nim i potrzebuję wsparcia
duchowego. Tudzież informacji.

Adam GĂłrski
Guest

Mon Jan 08, 2024 2:52 pm   



W dniu 08.01.2024 o 03:11, sundayman pisze:
Quote:
Ostatnio mi się przytrafiła przykra wpadka z nim i potrzebuję wsparcia
duchowego. Tudzież informacji.

Pytaj.

Co do wsparcia duchowego.... "Na pewno dasz radę" , "całe życie przed
Tobą" , "Nie marnuj życia dla jednego scalaka" , "On nie jest tego wart..."

Pozdrawiam

Adam Górski

sundayman
Guest

Tue Jan 09, 2024 3:20 am   



Quote:
Co do wsparcia duchowego.... "Na pewno dasz radę" , "całe życie przed
Tobą" , "Nie marnuj życia dla jednego scalaka" , "On nie jest tego wart..."


Taaa...

No więc po wyprodukowaniu 800 szt. dynksa zawierającego ten RTC ujawnił
się ciekawy (tfu) problem.

Otóż - urządź napędzany baterią CR2032, możliwie najlepszą jaką można
kupić ( zawsze w TME brałem Vartę ). Jest to sterownik, który docelowo
jest montowany "w terenie" i tam zasilany z czego tam mają.

Ale wychodząc ode mnie miał ustawianą datę, czas itp. Oraz włączany MIP
- czyli rejestrację otworzenia obudowy za pomocą kontaktrona. Takie
zabezpieczenie - dlatego też wybrałem kiedyś ten układ bo ma to jako
jedyny chyba. I może dlatego jest w chuj drogi...

No i dataszicie stoi jak byk, że Vbat (oscylator on) pobiera to max.
500nA. Napisane też, że jak jest Vcc większe niż Vbat to przechodzi na
zasilanie z tego Vcc. U mnie jest zasilanie 5V więc niby OK.

Nigdy nie mierzyłem ile toto faktycznie pobiera, bo nawet nie miałem
bardzo czym te 500nA zmierzyć. Poza tym wszystko było OK.
Aparaty po powieszeniu w terenie działały średnio 4 lata. Potem bateria
padała. Znaczy ona tam jest tylko do czasu i nie wpływa na działanie,
ale to mniejsza.

Ostatnio zdarzyło się, że dostałem na aktualizację firmware urządzenia,
które leżały dłużej niż zwykle na półce. Na przykład 10 mcy.
Włączam - a tu bateria rozładowana ! Trafiam na taki jeden, potem drugi.

Myślę sobie - nosz kurwa mać. Najpierw pomyślałem, że może lewe baterie.
Ale - teraz mam pikoampreomierz Keithleya i pomierzyłem.
No i chuj mnie strzelił. Wychodzi mi tak (prąd pobierany z baterii CR2032) :


przy braku zasilania Vcc - pobór 26,8uA ( włączony MIP ), albo 25uA (
wyłączony MIP).

Przy obecności Vcc - 5.5uA (włączony MIP ) albo 900nA ( wyłączony MIP ).


Czyli te 900nA ( miało być 300 typowo ?? ) to jest kiedy jest Vcc. I MIP
wyłączone. A jak leży na półce to wpierdala prawie 27uA !

Ergo - jak już wisi dynks powieszony docelowo - to z bogiem sprawa.
Bateria trzyma parę lat. Ale jak leży w magazynie to po roku niecały
chuj bombki strzela.

No kurwa mać. Czy ja nie umiem tego dataszita przeczytać, że tego nie
wiedziałem - czy o co kaman ??

Druga sprawa:

W przyszłości oczywiście to zmienię. Dam inny RTC ( ten MIP już mam w
dudzie ) itp itd.
No ale te nadal leżące urządzenia musiałem ratować - wymieniłem baterie,
i dałem taki pasek, który trzeba wyciągnąć po zainstalowaniu i
podłączeniu. Kurwa jak w chińskim pilocie.

Ale tu jest nowa niespodzianka.
Ten jebany DS1678 jak nie ma podłączonej baterii a jest Vcc - to kurwa
nie działa jak należy. To niby jest napisane :


"If a battery or other energy source is not used, VBAT should be
connected directly to ground"

Czyli jest taki cyrk, że jak bateria jest "nie aktywowana" a urządzenie
jest podłączone (np. do testów ) to nie można poprawnie ustawić czasu.
Wcześniej się tym nie przejmowałem, bo przecież nie przyszło mi do łba,
że będę musiał oddawać sprzęt bez podłączonej baterii.

W sumie zostało mi tych urządzeń do oddania kilkadziesiąt, więc jebał to
pies.

Ale - czy to ja coś zjebałem, czy oni tą dokumentację - czy co ?
To mnie interesuje.

Ten Keithley 485, którym mierzę może nie jest super dokładny - może
powiedzmy jak mi wychodzi 900nA to tam jest faktycznie te 400, które
powinny być.
No ale dlaczego te chuje nie napisały, że to jest pobór przy obecności Vcc ?

sundayman
Guest

Tue Jan 09, 2024 3:27 am   



W dniu 2024-01-09 o 02:20, sundayman pisze:

Quote:
urządź napędzany baterią CR203

znaczy ten RTC tą baterią tylko. Cały urządź ma swoje zasilanie
oczywiście Smile

Dariusz Dorochowicz
Guest

Tue Jan 09, 2024 7:45 am   



W dniu 09.01.2024 o 02:20, sundayman pisze:
Quote:

Co do wsparcia duchowego.... "Na pewno dasz radę" , "całe życie przed
Tobą" , "Nie marnuj życia dla jednego scalaka" , "On nie jest tego
wart..."


Taaa...

No więc po wyprodukowaniu 800 szt. dynksa zawierającego ten RTC ujawnił
się ciekawy (tfu) problem.

Otóż - urządź napędzany baterią CR2032, możliwie najlepszą jaką można
kupić ( zawsze w TME brałem Vartę ). Jest to sterownik, który docelowo
jest montowany "w terenie" i tam zasilany z czego tam mają.

Ale wychodząc ode mnie miał ustawianą datę, czas itp. Oraz włączany MIP
- czyli rejestrację otworzenia obudowy za pomocą kontaktrona. Takie
zabezpieczenie - dlatego też wybrałem kiedyś ten układ bo ma to jako
jedyny chyba. I może dlatego jest w chuj drogi...

No i dataszicie stoi jak byk, że Vbat (oscylator on) pobiera to max.
500nA. Napisane też, że jak jest Vcc większe niż Vbat to przechodzi na
zasilanie z tego Vcc. U mnie jest zasilanie 5V więc niby OK.

Nigdy nie mierzyłem ile toto faktycznie pobiera, bo nawet nie miałem
bardzo czym te 500nA zmierzyć. Poza tym wszystko było OK.
Aparaty po powieszeniu w terenie działały średnio 4 lata. Potem bateria
padała. Znaczy ona tam jest tylko do czasu i nie wpływa na działanie,
ale to mniejsza.

Ostatnio zdarzyło się, że dostałem na aktualizację firmware urządzenia,
które leżały dłużej niż zwykle na półce. Na przykład 10 mcy.
Włączam - a tu bateria rozładowana ! Trafiam na taki jeden, potem drugi.

Myślę sobie - nosz kurwa mać. Najpierw pomyślałem, że może lewe baterie.
Ale - teraz mam pikoampreomierz Keithleya i pomierzyłem.
No i chuj mnie strzelił. Wychodzi mi tak (prąd pobierany z baterii
CR2032) :


przy braku zasilania Vcc - pobór 26,8uA ( włączony MIP ), albo 25uA (
wyłączony MIP).

Przy obecności Vcc - 5.5uA (włączony MIP ) albo 900nA ( wyłączony MIP ).


Czyli te 900nA ( miało być 300 typowo ?? ) to jest kiedy jest Vcc. I MIP
wyłączone. A jak leży na półce to wpierdala prawie 27uA !

A wiesz, miałem niedawno partię trochę innych układów RTC, i to samo.
Mniej więcej tak samo powinien brać poniżej 1uA, a brał koło 25. Wymiana
układu na taki z innej partii pomogła. Te układy wyglądały nieco
inaczej, jakby lakierowane były czy coś. Po prawdzie to nawet nie wiem
jak się poza tym zachowywały, u mnie test poboru prądu z baterii jest
robiony rutynowo jako jeden z pierwszych - przy tych wartościach
wystarczy zwykły multimetr (u mnie więcej prądu z baterii idzie, właśnie
tak koło 20uA jak jest OK, wiec już coś widać).

Pozdrawiam

DD

sundayman
Guest

Tue Jan 09, 2024 7:45 am   



Quote:
A wiesz, miałem niedawno partię trochę innych układów RTC, i to samo.
Mniej więcej tak samo powinien brać poniżej 1uA, a brał koło 25. Wymiana
układu na taki z innej partii pomogła.


Mało pocieszające. Kupowałem zawsze wyłącznie albo w Farnellu albo w
RS-components. Żadnych dziwnych handlarzy. Ale dzięki za info.
Wezmę to pod uwagę na przyszłość, jakiś test dodam po montażu czy coś...

Adam GĂłrski
Guest

Tue Jan 09, 2024 12:30 pm   



A jak powyciągasz wszystkie kondensatory blokujące na zasilaniu ?

Pozdrawiam

Adam Górski

Quote:

Co do wsparcia duchowego.... "Na pewno dasz radę" , "całe życie przed
Tobą" , "Nie marnuj życia dla jednego scalaka" , "On nie jest tego
wart..."


Taaa...

No więc po wyprodukowaniu 800 szt. dynksa zawierającego ten RTC ujawnił
się ciekawy (tfu) problem.

Otóż - urządź napędzany baterią CR2032, możliwie najlepszą jaką można
kupić ( zawsze w TME brałem Vartę ). Jest to sterownik, który docelowo
jest montowany "w terenie" i tam zasilany z czego tam mają.

Ale wychodząc ode mnie miał ustawianą datę, czas itp. Oraz włączany MIP
- czyli rejestrację otworzenia obudowy za pomocą kontaktrona. Takie
zabezpieczenie - dlatego też wybrałem kiedyś ten układ bo ma to jako
jedyny chyba. I może dlatego jest w chuj drogi...

No i dataszicie stoi jak byk, że Vbat (oscylator on) pobiera to max.
500nA. Napisane też, że jak jest Vcc większe niż Vbat to przechodzi na
zasilanie z tego Vcc. U mnie jest zasilanie 5V więc niby OK.

Nigdy nie mierzyłem ile toto faktycznie pobiera, bo nawet nie miałem
bardzo czym te 500nA zmierzyć. Poza tym wszystko było OK.
Aparaty po powieszeniu w terenie działały średnio 4 lata. Potem bateria
padała. Znaczy ona tam jest tylko do czasu i nie wpływa na działanie,
ale to mniejsza.

Ostatnio zdarzyło się, że dostałem na aktualizację firmware urządzenia,
które leżały dłużej niż zwykle na półce. Na przykład 10 mcy.
Włączam - a tu bateria rozładowana ! Trafiam na taki jeden, potem drugi.

Myślę sobie - nosz kurwa mać. Najpierw pomyślałem, że może lewe baterie.
Ale - teraz mam pikoampreomierz Keithleya i pomierzyłem.
No i chuj mnie strzelił. Wychodzi mi tak (prąd pobierany z baterii
CR2032) :


przy braku zasilania Vcc - pobór 26,8uA ( włączony MIP ), albo 25uA (
wyłączony MIP).

Przy obecności Vcc - 5.5uA (włączony MIP ) albo 900nA ( wyłączony MIP ).


Czyli te 900nA ( miało być 300 typowo ?? ) to jest kiedy jest Vcc. I MIP
wyłączone. A jak leży na półce to wpierdala prawie 27uA !

Ergo - jak już wisi dynks powieszony docelowo - to z bogiem sprawa.
Bateria trzyma parę lat. Ale jak leży w magazynie to po roku niecały
chuj bombki strzela.

No kurwa mać. Czy ja nie umiem tego dataszita przeczytać, że tego nie
wiedziałem - czy o co kaman ??

Druga sprawa:

W przyszłości oczywiście to zmienię. Dam inny RTC ( ten MIP już mam w
dudzie ) itp itd.
No ale te nadal leżące urządzenia musiałem ratować - wymieniłem baterie,
i dałem taki pasek, który trzeba wyciągnąć po zainstalowaniu i
podłączeniu. Kurwa jak w chińskim pilocie.

Ale tu jest nowa niespodzianka.
Ten jebany DS1678 jak nie ma podłączonej baterii a jest Vcc - to kurwa
nie działa jak należy. To niby jest napisane :


"If a battery or other energy source is not used, VBAT should be
connected directly to ground"

Czyli jest taki cyrk, że jak bateria jest "nie aktywowana" a urządzenie
jest podłączone (np. do testów ) to nie można poprawnie ustawić czasu.
Wcześniej się tym nie przejmowałem, bo przecież nie przyszło mi do łba,
że będę musiał oddawać sprzęt bez podłączonej baterii.

W sumie zostało mi tych urządzeń do oddania kilkadziesiąt, więc jebał to
pies.

Ale - czy to ja coś zjebałem, czy oni tą dokumentację - czy co ?
To mnie interesuje.

Ten Keithley 485, którym mierzę może nie jest super dokładny - może
powiedzmy jak mi wychodzi 900nA to tam jest faktycznie te 400, które
powinny być.
No ale dlaczego te chuje nie napisały, że to jest pobór przy obecności
Vcc ?










Adam GĂłrski
Guest

Tue Jan 09, 2024 3:03 pm   



Zapytam inaczej.

Czy możesz wkleić kawałek schematu ?

Pozdrawiam

Adam Górski

Quote:
A jak powyciągasz wszystkie kondensatory blokujące na zasilaniu ?

Pozdrawiam

Adam Górski


Co do wsparcia duchowego.... "Na pewno dasz radę" , "całe życie przed
Tobą" , "Nie marnuj życia dla jednego scalaka" , "On nie jest tego
wart..."


Taaa...

No więc po wyprodukowaniu 800 szt. dynksa zawierającego ten RTC
ujawnił się ciekawy (tfu) problem.

Otóż - urządź napędzany baterią CR2032, możliwie najlepszą jaką można
kupić ( zawsze w TME brałem Vartę ). Jest to sterownik, który docelowo
jest montowany "w terenie" i tam zasilany z czego tam mają.

Ale wychodząc ode mnie miał ustawianą datę, czas itp. Oraz włączany
MIP - czyli rejestrację otworzenia obudowy za pomocą kontaktrona.
Takie zabezpieczenie - dlatego też wybrałem kiedyś ten układ bo ma to
jako jedyny chyba. I może dlatego jest w chuj drogi...

No i dataszicie stoi jak byk, że Vbat (oscylator on) pobiera to max.
500nA. Napisane też, że jak jest Vcc większe niż Vbat to przechodzi na
zasilanie z tego Vcc. U mnie jest zasilanie 5V więc niby OK.

Nigdy nie mierzyłem ile toto faktycznie pobiera, bo nawet nie miałem
bardzo czym te 500nA zmierzyć. Poza tym wszystko było OK.
Aparaty po powieszeniu w terenie działały średnio 4 lata. Potem
bateria padała. Znaczy ona tam jest tylko do czasu i nie wpływa na
działanie, ale to mniejsza.

Ostatnio zdarzyło się, że dostałem na aktualizację firmware
urządzenia, które leżały dłużej niż zwykle na półce. Na przykład 10 mcy.
Włączam - a tu bateria rozładowana ! Trafiam na taki jeden, potem drugi.

Myślę sobie - nosz kurwa mać. Najpierw pomyślałem, że może lewe baterie.
Ale - teraz mam pikoampreomierz Keithleya i pomierzyłem.
No i chuj mnie strzelił. Wychodzi mi tak (prąd pobierany z baterii
CR2032) :


przy braku zasilania Vcc - pobór 26,8uA ( włączony MIP ), albo 25uA (
wyłączony MIP).

Przy obecności Vcc - 5.5uA (włączony MIP ) albo 900nA ( wyłączony MIP ).


Czyli te 900nA ( miało być 300 typowo ?? ) to jest kiedy jest Vcc. I
MIP wyłączone. A jak leży na półce to wpierdala prawie 27uA !

Ergo - jak już wisi dynks powieszony docelowo - to z bogiem sprawa.
Bateria trzyma parę lat. Ale jak leży w magazynie to po roku niecały
chuj bombki strzela.

No kurwa mać. Czy ja nie umiem tego dataszita przeczytać, że tego nie
wiedziałem - czy o co kaman ??

Druga sprawa:

W przyszłości oczywiście to zmienię. Dam inny RTC ( ten MIP już mam w
dudzie ) itp itd.
No ale te nadal leżące urządzenia musiałem ratować - wymieniłem
baterie, i dałem taki pasek, który trzeba wyciągnąć po zainstalowaniu
i podłączeniu. Kurwa jak w chińskim pilocie.

Ale tu jest nowa niespodzianka.
Ten jebany DS1678 jak nie ma podłączonej baterii a jest Vcc - to kurwa
nie działa jak należy. To niby jest napisane :


"If a battery or other energy source is not used, VBAT should be
connected directly to ground"

Czyli jest taki cyrk, że jak bateria jest "nie aktywowana" a
urządzenie jest podłączone (np. do testów ) to nie można poprawnie
ustawić czasu.
Wcześniej się tym nie przejmowałem, bo przecież nie przyszło mi do
łba, że będę musiał oddawać sprzęt bez podłączonej baterii.

W sumie zostało mi tych urządzeń do oddania kilkadziesiąt, więc jebał
to pies.

Ale - czy to ja coś zjebałem, czy oni tą dokumentację - czy co ?
To mnie interesuje.

Ten Keithley 485, którym mierzę może nie jest super dokładny - może
powiedzmy jak mi wychodzi 900nA to tam jest faktycznie te 400, które
powinny być.
No ale dlaczego te chuje nie napisały, że to jest pobór przy obecności
Vcc ?











sundayman
Guest

Thu Jan 11, 2024 6:27 am   



W dniu 2024-01-09 o 14:03, Adam Górski pisze:
Quote:
Zapytam inaczej.

Czy możesz wkleić kawałek schematu ?



https://ibb.co/xfwhbNv

Nic nie ma tu odkrywczego.
Bateria jest włączona pomiędzy BAT VOLT a GND ( jest na płytce gniazdo
CR2032 ). Oczywiście tuż obok DS1678A, wszystko prosto i bez komplikacji.

K1 to kontaktron, który jest normalnie zwarty przez magnes na płycie
czołowej urządzenia. Jak się ją otwiera, magnes rozwiera kontaktron i
mamy zapisane zdarzenie w DS1678.

Magistrala I2C do atmegi 2561, VCC do ogólnego zasilania 5V.

Część zblurrowana to elementy, które były przewidziane do zastąpienia
baterii akumulatorem - nie montowane nigdy bo nie został to
przetestowane. Czyli tego po prostu nie ma.

Nie wydaje mnie się, żebyśmy tu coś odkryli...
Zwłaszcza, że kiedy VCC jest obecne no to prąd spada do tych kilkuset nA
( przy wyłączonym MIP ).

sundayman
Guest

Thu Jan 11, 2024 6:35 am   



W dniu 2024-01-09 o 11:30, Adam Górski pisze:
Quote:
A jak powyciągasz wszystkie kondensatory blokujące na zasilaniu ?

No nie mogę tego zrobić przecież, bo one są na zasilaniu całej płytki.
Więc to bez sensu.
Poza tym - nic nie ma przecież w dataszicie, że trzeba jakieś cuda
robić. Chociaż może być ciekawe sprawdzić - dać zasilanie do DS1678
przez diodę. Ale jakby to miało coś zmienić to dopiero byłby cyrk.

Ale sprawdzę niedługo. Albo inaczej - odłączę pin VCC w ogóle i
zobaczymy czy to coś zmienia na samej baterii.

Adam GĂłrski
Guest

Thu Jan 11, 2024 4:54 pm   



A ten pobór prądu to masz z zamkniętym K1 ?
No bo na moje oko to tu jest problem.

Oscylator masz zasilany z domeny Vbat, ale INT i logikę już nie.
No i jeżeli K1 jest zamknięty cały czas to domena VCC się zasila przez
R15. Tam jeszcze może być pull-down na INT wewnętrznie bo inaczej się
wyzwoli z powietrza.

K1 powinien być zwierany przy otwarciu. Wtedy pull down na INT nie
przeszkodzi.

Taką piękną mam teorię.

Pozdrawiam

Adam Górski

W dniu 11.01.2024 o 05:27, sundayman pisze:
Quote:
W dniu 2024-01-09 o 14:03, Adam Górski pisze:
Zapytam inaczej.

Czy możesz wkleić kawałek schematu ?



https://ibb.co/xfwhbNv

Nic nie ma tu odkrywczego.
Bateria jest włączona pomiędzy BAT VOLT a GND ( jest na płytce gniazdo
CR2032 ). Oczywiście tuż obok DS1678A, wszystko prosto i bez komplikacji.

K1 to kontaktron, który jest normalnie zwarty przez magnes na płycie
czołowej urządzenia. Jak się ją otwiera, magnes rozwiera kontaktron i
mamy zapisane zdarzenie w DS1678.

Magistrala I2C do atmegi 2561, VCC do ogólnego zasilania 5V.

Część zblurrowana to elementy, które były przewidziane do zastąpienia
baterii akumulatorem - nie montowane nigdy bo nie został to
przetestowane. Czyli tego po prostu nie ma.

Nie wydaje mnie się, żebyśmy tu coś odkryli...
Zwłaszcza, że kiedy VCC jest obecne no to prąd spada do tych kilkuset nA
( przy wyłączonym MIP ).




sundayman
Guest

Fri Jan 12, 2024 12:29 am   



W dniu 2024-01-11 o 15:54, Adam Górski pisze:
Quote:
A ten pobór prądu to masz z zamkniętym K1 ?

oj nie czytasz. Pisałem że :


przy braku zasilania Vcc - pobór 26,8uA ( włączony MIP ), albo 25uA (
wyłączony MIP).
Przy obecności Vcc - 5.5uA (włączony MIP ) albo 900nA ( wyłączony MIP ).


Przy czym istotne jest włączenie/wyłączenie MIP w układzie. Jeśli jest
MIP wyłączone, to nawet przy zwartym kontaktronie prąd spada.
A jeśli jest MIP włączony to przy wyłączeniu kontaktrona MIP się wyłącza
- ergo prąd spada.

Podsumowując - wpływ na prąd ma włączenie funkcji MIP ( co zresztą w
dataszicie jest chyba opisane, że jest upływność na wejściu INT ).


Quote:
Oscylator masz zasilany z domeny Vbat, ale INT i logikę już nie.
No i jeżeli K1 jest zamknięty cały czas to domena VCC się zasila przez
R15. Tam jeszcze może być pull-down na INT wewnętrznie bo inaczej się
wyzwoli z powietrza.

K1 powinien być zwierany przy otwarciu. Wtedy pull down na INT nie
przeszkodzi.

Teoria ładna, ale chyba nie Smile
Jak robiłem pomiary to kontaktron w ogóle był rozwarty cały czas o ile
pamiętam. Ale jeszcze wrócę do tego i dam znać.

Rutkowski, Jacek
Guest

Fri Jan 12, 2024 12:28 pm   



W dniu 11.01.2024 o 23:29, sundayman pisze:
Quote:
W dniu 2024-01-11 o 15:54, Adam Górski pisze:
A ten pobór prądu to masz z zamkniętym K1 ?

oj nie czytasz. Pisałem że :


przy braku zasilania Vcc - pobór 26,8uA ( włączony MIP ), albo 25uA (
wyłączony MIP).
Przy obecności Vcc - 5.5uA (włączony MIP ) albo 900nA ( wyłączony MIP ).


Przy czym istotne jest włączenie/wyłączenie MIP w układzie. Jeśli jest
MIP wyłączone, to nawet przy zwartym kontaktronie prąd spada.
A jeśli jest MIP włączony to przy wyłączeniu kontaktrona MIP się wyłącza
- ergo prąd spada.

Podsumowując - wpływ na prąd ma włączenie funkcji MIP ( co zresztą w
dataszicie jest chyba opisane, że jest upływność na wejściu INT ).


Oscylator masz zasilany z domeny Vbat, ale INT i logikę już nie.
No i jeżeli K1 jest zamknięty cały czas to domena VCC się zasila przez
R15. Tam jeszcze może być pull-down na INT wewnętrznie bo inaczej się
wyzwoli z powietrza.

K1 powinien być zwierany przy otwarciu. Wtedy pull down na INT nie
przeszkodzi.

Teoria ładna, ale chyba nie Smile
Jak robiłem pomiary to kontaktron w ogóle był rozwarty cały czas o ile
pamiętam. Ale jeszcze wrócę do tego i dam znać.

Patrząc z boku mowa była o tym że pobór prądu z baterii 900nA

miał być wg autora bez VCC i tego bym się spodziewał sam osobiście.
A z drugiej strony przy obecności VCC spodziewał bym się poboru 0nA
a nie ciągłego zżerania baterii...
Dziwny ten RTC.
Taki DS1307 pobiera 500nA z włączonym oscylatorem bez VCC a z VCC
5 max 50nA a nie 900nA.



--
pzdr, j.r.

sundayman
Guest

Fri Jan 12, 2024 12:45 pm   



Quote:
Patrząc z boku mowa była o tym że pobór prądu z baterii 900nA
miał być wg autora bez VCC i tego bym się spodziewał sam osobiście.
A z drugiej strony przy obecności VCC spodziewał bym się poboru 0nA
a nie ciągłego zżerania baterii...
Dziwny ten RTC.
Taki DS1307 pobiera 500nA z włączonym oscylatorem bez VCC a z VCC
5 max 50nA a nie 900nA.

Otóż to właśnie.
Po niedzieli zrobię pomiary jeszcze raz i zobaczymy.

Adam GĂłrski
Guest

Fri Jan 12, 2024 1:54 pm   



W dniu 12.01.2024 o 11:45, sundayman pisze:
Quote:

Patrząc z boku mowa była o tym że pobór prądu z baterii 900nA
miał być wg autora bez VCC i tego bym się spodziewał sam osobiście.
A z drugiej strony przy obecności VCC spodziewał bym się poboru 0nA
a nie ciągłego zżerania baterii...
Dziwny ten RTC.
Taki DS1307 pobiera 500nA z włączonym oscylatorem bez VCC a z VCC
5 max 50nA a nie 900nA.

Otóż to właśnie.
Po niedzieli zrobię pomiary jeszcze raz i zobaczymy.


Proponuję zatem wyizolować problem.

1. Sprawdzić miernik czy prąd dobrze mierzy.

Stosując znany rezystor 100M lub 10 x 10M i znane źródło napięcia np 9V
baterię.

2. Polutuj tego RTC na pająka. Bo może impedancja pomiędzy X1,X2 a GND
przy 32kHz jest tym czego szukasz. Ewentualnie sprawdź prąd przy
zatrzymanym generatorze. W nocie aplikacyjnej jest mowa o ground plane
celem pozbycia się zakłóceń, nie celem minimalizacji zużycia prądu.

3. Jeżeli ten DS1678 pobiera za dużo prądu wisząc w powietrzu bez
kwarcu, to wiele się nie da zrobić.

Pozdrawiam

Adam Górski

Goto page 1, 2  Next

elektroda NewsGroups Forum Index - Elektronika Polska - ktoś tu zna RTC DS1678 ?

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map