RTV forum PL | NewsGroups PL

Geiger STS-5 i wzmacniacz operacyjny

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Geiger STS-5 i wzmacniacz operacyjny

Goto page 1, 2  Next

Atlantis
Guest

Mon May 04, 2020 8:50 pm   



Już w kilku swoich projektach wykorzystałem stary, sowiecki czujnik
Geigera STS-5. Za każdym razem wzorowałem się na schemacie zaczerpniętym
z tego projektu:

https://ep.com.pl/files/2721.pdf

Ze schematu pożyczałem przetwornicę wysokiego napięcia, przyległości
samej "tuby" oraz wzmacniacz operacyjny na LM358. Część cyfrowa była już
projektowana od podstaw, z wykorzystaniem jakiegoś mikrokontrolera.

Ostatnio powróciłem do tego tematu jeszcze raz. Jedyna różnica w
stosunku do poprzednich implementacji polegała chyba tylko na
zastosowaniu LM358 w obudowie THT, a nie SMD.

O dziwo tym razem układ nie chce działać. Objawy są następujące:
1) Licznik nie widzi impulsów przychodzących z czujnika Geigera. Sama
"tuba" jest sprawna, przetestowana w innym układzie. Przetwornica WN
także działa, dając około 400V.
2) Zwarcie wejścia timera do masy skutkuje prawidłowym zliczeniem impulsu.
3) Zwarcie wejścia wzmacniacza operacyjnego (punkt pomiędzy C11 a R10)
do masy także skutkuje zliczeniem impulsu.
4) Zwarcie samej "tuby" także jest rejestrowane jako zliczenie impulsu.

Czyli z jakiegoś powodu albo czujnik Geigera nie generuje impulsów (co
jest mało prawdopodobne, bo ten sam egzemplarz działa w innym układzie
zbudowanym w oparciu o ten sam schemat) albo impulsy nie przechodzą
przez wzmacniacz.

Próbowałem wymienić LM358, ale to nie pomogło.

Jakiś pomysł co do tego, gdzie mogę szukać przyczyny?

Paweł Pawłowicz
Guest

Tue May 05, 2020 9:43 am   



W dniu 04.05.2020 o 22:50, Atlantis pisze:
Quote:
Już w kilku swoich projektach wykorzystałem stary, sowiecki czujnik
Geigera STS-5. Za każdym razem wzorowałem się na schemacie zaczerpniętym
z tego projektu:

https://ep.com.pl/files/2721.pdf

Ze schematu pożyczałem przetwornicę wysokiego napięcia, przyległości
samej "tuby" oraz wzmacniacz operacyjny na LM358. Część cyfrowa była już
projektowana od podstaw, z wykorzystaniem jakiegoś mikrokontrolera.

Ostatnio powróciłem do tego tematu jeszcze raz. Jedyna różnica w
stosunku do poprzednich implementacji polegała chyba tylko na
zastosowaniu LM358 w obudowie THT, a nie SMD.

O dziwo tym razem układ nie chce działać. Objawy są następujące:
1) Licznik nie widzi impulsów przychodzących z czujnika Geigera. Sama
"tuba" jest sprawna, przetestowana w innym układzie. Przetwornica WN
także działa, dając około 400V.
2) Zwarcie wejścia timera do masy skutkuje prawidłowym zliczeniem impulsu.
3) Zwarcie wejścia wzmacniacza operacyjnego (punkt pomiędzy C11 a R10)
do masy także skutkuje zliczeniem impulsu.
4) Zwarcie samej "tuby" także jest rejestrowane jako zliczenie impulsu.

Czyli z jakiegoś powodu albo czujnik Geigera nie generuje impulsów (co
jest mało prawdopodobne, bo ten sam egzemplarz działa w innym układzie
zbudowanym w oparciu o ten sam schemat) albo impulsy nie przechodzą
przez wzmacniacz.

Próbowałem wymienić LM358, ale to nie pomogło.

Jakiś pomysł co do tego, gdzie mogę szukać przyczyny?

Porządnie wymyj płytkę. Pozostałości topnika mogą przewodzić i psuć
zabawę na wysokoomowych ścieżkach.

P.P.

Atlantis
Guest

Tue May 05, 2020 1:34 pm   



On 05.05.2020 11:43, Paweł Pawłowicz wrote:

Quote:
Porządnie wymyj płytkę. Pozostałości topnika mogą przewodzić i psuć
zabawę na wysokoomowych ścieżkach.

Dzięki za sugestię. Faktycznie trochę topnika zostało w tej okolicy
płytki i faktycznie to może być to.
Alternatywnie przychodzi mi do głowy tylko jedno wytłumaczenie - układ
jest moim kolejnym projektem w stylu retro, a rolę timera pełni stary
układ MC6840. Całość jest taktowana zegarem zaledwie 1MHz. Pomyślałem,
że może impulsy z rurki Gaigera są za krótkie, żeby ten układ je
zarejestrował. Jednak nie sądzę, żeby tu miał leżeć przyczyna...

J.F.
Guest

Tue May 05, 2020 3:34 pm   



Użytkownik "Atlantis" napisał w wiadomości grup
dyskusyjnych:5eb16b4f$0$514$65785112_at_news.neostrada.pl...

Quote:
Alternatywnie przychodzi mi do głowy tylko jedno wytłumaczenie -
układ
jest moim kolejnym projektem w stylu retro, a rolę timera pełni stary
układ MC6840. Całość jest taktowana zegarem zaledwie 1MHz.
Pomyślałem,
że może impulsy z rurki Gaigera są za krótkie, żeby ten układ je
zarejestrował. Jednak nie sądzę, żeby tu miał leżeć przyczyna...

LM358 nie byly jakies specjalnie szybkie ... ale moze nowsze sa
ulepszone :)

Podlacz oscyloskop na wyjscie, albo jakis glosnik, to sie okaze, czy
impulsy sa.

Jesli nie ma ... a moze napiecie za niskie i rurka nie impulsuje ?

J.

Janusz
Guest

Tue May 05, 2020 4:27 pm   



W dniu 2020-05-05 o 17:34, J.F. pisze:
Quote:
Użytkownik "Atlantis"  napisał w wiadomości grup
dyskusyjnych:5eb16b4f$0$514$65785112_at_news.neostrada.pl...

Alternatywnie przychodzi mi do głowy tylko jedno wytłumaczenie - układ
jest moim kolejnym projektem w stylu retro, a rolę timera pełni stary
układ MC6840. Całość jest taktowana zegarem zaledwie 1MHz. Pomyślałem,
że może impulsy z rurki Gaigera są za krótkie, żeby ten układ je
zarejestrował. Jednak nie sądzę, żeby tu miał leżeć przyczyna...

LM358 nie byly jakies specjalnie szybkie ... ale moze nowsze sa
ulepszone :)

Podlacz oscyloskop na wyjscie, albo jakis glosnik, to sie okaze, czy
impulsy sa.

Jesli nie ma ... a moze napiecie za niskie i rurka nie impulsuje ?
Przecierz pisał że sprawdzał, ja bym zmienił opornik na tubie z 470k na

1M żeby amplituda impulsów była większa.

--
Janusz

Atlantis
Guest

Tue May 05, 2020 5:58 pm   



On 05.05.2020 17:34, J.F. wrote:

Quote:
LM358 nie byly jakies specjalnie szybkie ... ale moze nowsze sa
ulepszone Smile

Umycie płytki nie pomogło...
Spróbowałem jeszcze podmienić LM358 na egzemplarz od innego producenta,
ale układ nadal zachowuje się tam samo.


Quote:
Podlacz oscyloskop na wyjscie, albo jakis glosnik, to sie okaze, czy
impulsy sa.

Niestety obecnie mam dostęp tylko do starego, polskiego oscyloskopu
analogowego bez wyzwalania i pamięci. Tak więc nie bardzo mam czym
sprawdzić przebiegi na wejściu wzmacniacza, tuż za STS-5. Wyjście
spróbuję sprawdzić za pomocą taniego analizatora logicznego na USB.


Quote:
Jesli nie ma ... a moze napiecie za niskie i rurka nie impulsuje ?

Około 400V powinno jej w zupełności wystarczyć.

J.F.
Guest

Wed May 06, 2020 8:53 am   



Użytkownik "Atlantis" napisał w wiadomości grup
dyskusyjnych:5eb1a92d$0$555$65785112_at_news.neostrada.pl...
On 05.05.2020 17:34, J.F. wrote:
Quote:
Podlacz oscyloskop na wyjscie, albo jakis glosnik, to sie okaze,
czy
impulsy sa.

Niestety obecnie mam dostęp tylko do starego, polskiego oscyloskopu
analogowego bez wyzwalania i pamięci. Tak więc nie bardzo mam czym
sprawdzić przebiegi na wejściu wzmacniacza, tuż za STS-5. Wyjście

A czesto ten licznik liczy w drugim ukladzie ?
Jak co pare s, to mozna i na takim zauwazyc.

Quote:
spróbuję sprawdzić za pomocą taniego analizatora logicznego na USB.

Jesli nie ma ... a moze napiecie za niskie i rurka nie impulsuje ?
Około 400V powinno jej w zupełności wystarczyć.

I jest tyle ?

A te liczniki nie maja + i - ? Moze zamieniles ?

J.

Atlantis
Guest

Wed May 06, 2020 3:06 pm   



On 06.05.2020 10:53, J.F. wrote:

Quote:
A czesto ten licznik liczy w drugim ukladzie ?
Jak co pare s, to mozna i na takim zauwazyc.

Ok, podłączyłem mój wątpliwej jakości oscyloskop do układu.
Na wejściu wzmacniacza (za kondensatorem) daje się zauważyć pojawiające
się nieregularnie impulsy. Częstotliwość z jaką występują pasuje do
tego, co powinna generować STS-5 mierząc promieniowanie tła.
Impulsy te są zauważalnie trwają tylko przez moment, można by je uznać
za jakieś zakłócenie, ale po odpięciu oscyloskopu od układy przestają
się one pojawiać. Impuls wygenerowany przez zwarcie rurki Geigera jest
zauważalnie dłuższy, ma nieco większą amplitudę i jest "postrzępiony".

Potem przełączyłem się na wyjście wzmacniacza. Tutaj impulsy również są
dostrzegalne. Trzeba mocno wytężyć wzrok, żeby zauważyć ich wystąpienie,
ale da się je zaobserwować. Również i tutaj widać, że impuls
wygenerowany ręcznie jest zauważalnie dłuższy.

Czyżby potwierdzało to moją hipotezę, że MC6840 nie radzi sobie z tak
krótkimi impulsami, ale liczniki zintegrowane ze współczesnymi MCU nie
mają z nimi problemu? Jeśli tak, to czy mogę zrobić coś bez drastycznego
przerabiania układu? Niewielki kondensator na wejściu timera może pomóc?
A może układ złożony z kondensatora na wejściu timera i połączonego
równolegle rezystora i diody pomiędzy wejściem timera i wyjściem
wzmacniacza?


Quote:
I jest tyle ?

Jest 410V


Quote:
A te liczniki nie maja + i - ? Moze zamieniles ?

Nie. To sprawdziłem na samym początku. Smile

wowa
Guest

Wed May 06, 2020 7:39 pm   



Quote:

Potem przełączyłem się na wyjście wzmacniacza. Tutaj impulsy również są
dostrzegalne. Trzeba mocno wytężyć wzrok, żeby zauważyć ich wystąpienie,
ale da się je zaobserwować. Również i tutaj widać, że impuls
wygenerowany ręcznie jest zauważalnie dłuższy.

Może głupie, ale.. LM358 zasilasz z 3V? On w pdf ma opis "MIN 3V (+/-

1.5V). Może trafiłeś na wersję +1.5V? Jeśli na smd chodziło to bym
podmienił na taki układ. Oczywiście druku jesteś pewien?
Wojtek

Atlantis
Guest

Wed May 06, 2020 9:33 pm   



On 06.05.2020 21:39, wowa wrote:

Quote:
Może głupie, ale.. LM358 zasilasz z 3V? On w pdf ma opis "MIN 3V (+/-
1.5V). Może trafiłeś na wersję +1.5V? Jeśli na smd chodziło to bym
podmienił na taki układ. Oczywiście druku jesteś pewien?
Wojtek

W tym układzie LM358 jest akurat zasilany z 5V.
Po obserwacji sygnałów na oscyloskopie skłaniam się jednak ku hipotezie,
że winę ponosi za to szerokość impulsu, który najwyraźniej przechodzi na
wyjście wzmacniacza..

J.F.
Guest

Thu May 07, 2020 8:46 am   



Użytkownik "Atlantis" napisał w wiadomości grup
dyskusyjnych:5eb2d27e$0$540$65785112_at_news.neostrada.pl...
Quote:
Potem przełączyłem się na wyjście wzmacniacza. Tutaj impulsy również

dostrzegalne. Trzeba mocno wytężyć wzrok, żeby zauważyć ich
wystąpienie,
ale da się je zaobserwować. Również i tutaj widać, że impuls
wygenerowany ręcznie jest zauważalnie dłuższy.

Czyżby potwierdzało to moją hipotezę, że MC6840 nie radzi sobie z tak
krótkimi impulsami, ale liczniki zintegrowane ze współczesnymi MCU
nie
mają z nimi problemu?

Byc moze - nie znak tego ukladu, ale uklady mikroprocesorowe w tamtych
czasach miewaly swoje niuanse, typu wlasnie tego, ze wejscie bylo
sprawdzane na zboczu sygnalu zegarowego, i krotki impuls mogl zostac
niezauwazony.

Czy np polaczenie INT i A6 w ZX81.

Quote:
Jeśli tak, to czy mogę zrobić coś bez drastycznego
przerabiania układu? Niewielki kondensator na wejściu timera może
pomóc?

Bardzo drastycznego ? Bo pewnie jakis podzielnik przez 2 zalatwilby
sprawe radykalnie.
Albo wydluzenie impulsu na 555 ... a w ogole czy 555 nie jest
wystarczajaco czuly, zeby bez opampa sie obyc ?


Kondensator moze sprawe zalatwic, ale tak sie patrze ... czy nie
zapiac kondensatorka malego miedzy 1 a 3 w LM358?
Dodatnie sprzezenie powinno wydluzyc impuls, a po chwili kondensator
je zablokuje.
Ewentualnie w szereg z rezystorem, zeby sie uklad nie wzbudzal.

Quote:
A może układ złożony z kondensatora na wejściu timera i połączonego
równolegle rezystora i diody pomiędzy wejściem timera i wyjściem
wzmacniacza?

Bylby lepszy.

J.

J.F.
Guest

Thu May 07, 2020 10:21 am   



Użytkownik "wowa" napisał w wiadomości grup
dyskusyjnych:5eb31285$0$17346$65785112_at_news.neostrada.pl...
Quote:
Może głupie, ale.. LM358 zasilasz z 3V? On w pdf ma opis "MIN 3V (+/-
1.5V). Może trafiłeś na wersję +1.5V?

A nie oznacza ten zapis "pojedyncze napiecie 3V, lub symetryczne
2*1.5V" ?

Co prawda nie widzialem jeszcze opampa, ktory by mial pin masy, wiec
opamp nie rozroznia pojedyncze czy symetryczne.

J.

Atlantis
Guest

Thu May 07, 2020 1:35 pm   



On 07.05.2020 10:46, J.F. wrote:

Quote:
Albo wydluzenie impulsu na 555 ... a w ogole czy 555 nie jest
wystarczajaco czuly, zeby bez opampa sie obyc ?

Złożyłem na skrawku płytki uniwersalnej niewielki moduł z NE555 w
układzie monostabilnym. Na wyjściu BC547 celem odwrócenia stanu.
Zastosowałem kondensator 220pF i rezystor 100k, co powinno dać impuls o
długości 20us.

Wpiąłem ten układ między wyjście opampa i wejście licznika. Impulsy z
rurki Geigera nadal nie są rejestrowane, choć widzę je na oscyloskopie
na wejściu timera. Zwarcie STS-5 powoduje (jak do tej pory generowanie
impulsów).

Czyżby 20us to za mało? Mam jeszcze bardziej wydłużyć impuls?

Dokumentacja MC6840 wspomina, że czasy opadania i narastania impulsów na
wejściach nie powinny być większe niż 1 us. NE555 jest w stanie spełnić
ten warunek, zakładając że tranzystor na wyjściu jest podciągnięty do
VCC rezystorem 3.3k?

Widzę jeszcze, że w dokumentacji jest taka wartość jak "input setup
time", wynosząca minimum 200 ns oraz input synchronization time,
wynosząca 250 ns. Czyli mój impuls trwa jednak zdecydowanie dłużej...

Janusz
Guest

Thu May 07, 2020 1:59 pm   



W dniu 2020-05-07 o 15:35, Atlantis pisze:
Quote:
On 07.05.2020 10:46, J.F. wrote:

Albo wydluzenie impulsu na 555 ... a w ogole czy 555 nie jest
wystarczajaco czuly, zeby bez opampa sie obyc ?

Złożyłem na skrawku płytki uniwersalnej niewielki moduł z NE555 w
układzie monostabilnym. Na wyjściu BC547 celem odwrócenia stanu.
Zastosowałem kondensator 220pF i rezystor 100k, co powinno dać impuls o
długości 20us.

Wpiąłem ten układ między wyjście opampa i wejście licznika. Impulsy z
rurki Geigera nadal nie są rejestrowane, choć widzę je na oscyloskopie
na wejściu timera. Zwarcie STS-5 powoduje (jak do tej pory generowanie
impulsów).

Czyżby 20us to za mało? Mam jeszcze bardziej wydłużyć impuls?

Dokumentacja MC6840 wspomina, że czasy opadania i narastania impulsów na
wejściach nie powinny być większe niż 1 us. NE555 jest w stanie spełnić
ten warunek, zakładając że tranzystor na wyjściu jest podciągnięty do
VCC rezystorem 3.3k?

Widzę jeszcze, że w dokumentacji jest taka wartość jak "input setup
time", wynosząca minimum 200 ns oraz input synchronization time,
wynosząca 250 ns. Czyli mój impuls trwa jednak zdecydowanie dłużej...

Masz za wąski impuls, podnieś amplitudę jak Ci już pisałem to też Ci sie

on wydłuży, bo jak na razie to sie miotasz.

--
Janusz

J.F.
Guest

Thu May 07, 2020 2:25 pm   



Użytkownik "Atlantis" napisał w wiadomości grup
dyskusyjnych:5eb40e91$0$17353$65785112_at_news.neostrada.pl...
On 07.05.2020 10:46, J.F. wrote:
Quote:
Albo wydluzenie impulsu na 555 ... a w ogole czy 555 nie jest
wystarczajaco czuly, zeby bez opampa sie obyc ?

Złożyłem na skrawku płytki uniwersalnej niewielki moduł z NE555 w
układzie monostabilnym. Na wyjściu BC547 celem odwrócenia stanu.
Zastosowałem kondensator 220pF i rezystor 100k, co powinno dać impuls
o
długości 20us.

Wpiąłem ten układ między wyjście opampa i wejście licznika. Impulsy z
rurki Geigera nadal nie są rejestrowane, choć widzę je na
oscyloskopie
na wejściu timera. Zwarcie STS-5 powoduje (jak do tej pory
generowanie
impulsów).

Czyżby 20us to za mało? Mam jeszcze bardziej wydłużyć impuls?

dorzuc wiekszy kondensator, to sie dowiesz czy to to.
Ale ... przeciez tam od Geigerka leci 27pf i 220k - czyli nawet
zwieranie geigerka daje podobnej dlugosci impuls.

Albo faktycznie 20us jest ciagle za malo, albo chodzi o to, ze zwarcie
generuje wiele impulsow, albo ... czas sie przestawic na ARM, szkoda
czasu na starocie :-P

Quote:
Dokumentacja MC6840 wspomina, że czasy opadania i narastania impulsów
na
wejściach nie powinny być większe niż 1 us. NE555 jest w stanie
spełnić
ten warunek, zakładając że tranzystor na wyjściu jest podciągnięty do
VCC rezystorem 3.3k?

Spokojnie, ale ten twoj tranzystor to niekoniecznie.
Mysle jednak, ze nie w tym problem.

Quote:
Widzę jeszcze, że w dokumentacji jest taka wartość jak "input setup
time", wynosząca minimum 200 ns oraz input synchronization time,
wynosząca 250 ns. Czyli mój impuls trwa jednak zdecydowanie dłużej...

ten setup to mi smierdzi tym, ze wejscie musi byc stabilne okreslony
czas przed "enable".
A tego nie zapewniasz ... ale w losowych impulsach na pewno jest dla
ktorys spelnione.

pdf jest straszny, ale
The high and low
levels of the external clocks must each be stable for at least
one system clock period plus the sum of the setup and hold
times for the clock inputs, The asynchronous clock rate can
vary from dc to the limit Imposed by the Enable Clock Setup,
and Hold times.

Czyli na moj gust - 20us zadziala, ale 1us to niekoniecznie.

The external clock inputs are clocked In by Enable pulses.
Three Enable periods are used to synchronize and process
-, the external clock. The fourth Enable pulse decrements the
internal counter. This does not affect the input frequency, it
merely creates a delay between a clock input transition and
internal recognition of that transition by the PTM.

To moze nie dzialac tak, jak Ci sie wydaje :-)

J.

Goto page 1, 2  Next

elektroda NewsGroups Forum Index - Elektronika Polska - Geiger STS-5 i wzmacniacz operacyjny

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map