RTV forum PL | NewsGroups PL

Dziwne zachowanie przetwornicy na MC34063

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Dziwne zachowanie przetwornicy na MC34063

Goto page Previous  1, 2, 3  Next

szod
Guest

Sun Jan 07, 2018 10:16 am   



W dniu 06-01-2018 o 17:05, Piotr Gałka pisze:

Quote:
Nadal wygląda, że źródłem problemu jest jakiś minimalny t_on i nie
możność zmniejszenia f poniżej jakiegoś minimum tylko mój pomysł na
lekarstwo okazał się nieskuteczny. Zapewne nie doceniłem wydajności przy
tym ustalonym minimalnym wypełnieniu Smile.

Trzeba zrozumieć jak ten scalak działa i czy da się aby dawał jeden
impuls t_on raz na sekundę/minutę/godzinę.

Ostatnio się nim bawiłem i uzyskałem ok 145Hz. Jak zszedłem niżej z
napięciem wejściowym to wyjściowe zaczęło rosnąć z założonych 9V do
ponad 16V. Nie wiem dlaczego, nie wnikałem zbytnio. Obciążenie kilkoma
mA ustabilizowało przetwornicę. Ale ostatecznie zmniejszyłem napięcie
wyjściowe do 6V i przestała świrować.

Ja bym spróbował zmniejszyć wartość kondensatora 1nF i tym zwiększyć
częstotliwość pracy. Przykładowo na 470pF.

Piotr Gałka
Guest

Mon Jan 08, 2018 11:05 am   



W dniu 2018-01-07 o 10:16, szod pisze:
Quote:
Ostatnio się nim bawiłem i uzyskałem ok 145Hz. Jak zszedłem niżej z
napięciem wejściowym to wyjściowe zaczęło rosnąć z założonych 9V do
ponad 16V.

Mi to wygląda na ten sam efekt.
P.G.

Piotr Gałka
Guest

Mon Jan 08, 2018 11:11 am   



W dniu 2018-01-06 o 18:21, Atlantis pisze:
Quote:
On 06.01.2018 17:05, Piotr Gałka wrote:

Nadal wygląda, że źródłem problemu jest jakiś minimalny t_on i nie
możność zmniejszenia f poniżej jakiegoś minimum tylko mój pomysł na
lekarstwo okazał się nieskuteczny. Zapewne nie doceniłem wydajności przy
tym ustalonym minimalnym wypełnieniu Smile.

Jakiś pomysł na możliwe rozwiązanie? ;)


Aby mieć szansę na pomysł musiałbym zagłębić się _dokładnie_ w kartę
katalogową. Dokładnie bo nie umiem czytać czegokolwiek po łebkach - albo
dokładnie, albo wcale.
Jak ostatnio zagłębiłem się w karty kilku DCDC TI to zajęło mi ponad dwa
tygodnie. Nie mam na to czasu.
P.G.

Atlantis
Guest

Tue Jan 09, 2018 8:28 am   



Hmm... Istnieje możliwość, że sposób prowadzenia ścieżek albo bardziej
gęste (niż w przypadku wersji THT) upakowanie elementów może mieć wpływ
na zachowanie przetwornicy?
Na wszelki wypadek wrzucam ten fragment płytki.

https://ibb.co/faoiCR

Atlantis
Guest

Fri Jan 12, 2018 10:40 pm   



On 07.01.2018 10:16, szod wrote:

Quote:
Ja bym spróbował zmniejszyć wartość kondensatora 1nF i tym zwiększyć
częstotliwość pracy. Przykładowo na 470pF.

Po wymianie kondensatora z 1nF na 470pF zupełnie nic się nie zmieniło.
Napięcie wciąż jest za wysokie i wciąż zależy od zasilania na wejściu -
różnica rzędu 40-50V. Powoli kończą mi się pomysły. W tej chwili tylko
do głowy przychodzi mi jeszcze próbowanie wymiany transformatora albo
spróbowanie z kolejnym egzemplarzem scalaka (chociaż wydaje mi się
naprawdę mało prawdopodobne, żeby do tej pory trafiły mi się dwa różne z
takim samym uszkodzeniem.
Jakakolwiek wada w transformatorze w teorii może powodować taki efekt?
Jak krytyczny jest rezystor 0,22 oma?

Skończy się tak, że przeprojektuję płytkę z myślą o przetwornicy w
wersji THT - ta do tej pory działa we wszystkich egzemplarzach
poprzedniej wersji urządzenia...

J.F.
Guest

Fri Jan 12, 2018 11:07 pm   



Dnia Fri, 12 Jan 2018 22:40:06 +0100, Atlantis napisał(a):
Quote:
On 07.01.2018 10:16, szod wrote:
Ja bym spróbował zmniejszyć wartość kondensatora 1nF i tym zwiększyć
częstotliwość pracy. Przykładowo na 470pF.

Po wymianie kondensatora z 1nF na 470pF zupełnie nic się nie zmieniło.
Napięcie wciąż jest za wysokie i wciąż zależy od zasilania na wejściu -
różnica rzędu 40-50V. Powoli kończą mi się pomysły. W tej chwili tylko


To moze powieksz
https://www.electro-tech-online.com/threads/strange-behaviour-of-mc34063-step-up-circuit.146261/

Quote:
do głowy przychodzi mi jeszcze próbowanie wymiany transformatora albo
spróbowanie z kolejnym egzemplarzem scalaka (chociaż wydaje mi się
naprawdę mało prawdopodobne, żeby do tej pory trafiły mi się dwa różne z
takim samym uszkodzeniem.

Moze jakas uszkodzona seria ?

Podlacz oscyloskop i zobacz jakie impulsy generuje.


Quote:
Jakakolwiek wada w transformatorze w teorii może powodować taki efekt?

Nie, sprzezenie zwrotne powinno regulowac.

www.ti.com/litv/pdf/slla339

"The MC34063A (figure 1) supplies fixed on time drive to the internal
power switch whenthe "Comparator inverting input" (abbreviated as
"Cii") is less than the internal 1.25V reference voltage.
When the Cii is greater than the internal reference, the output switch
will remain off. Therefore, keeping the Cii pin above 1.25V will stop
the output switch (the oscillator will continue to run)"

Quote:
Jak krytyczny jest rezystor 0,22 oma?

Dosc krytyczny, jesli dochodzisz do nasycenia cewki.
Co u Ciebie nie powinno miec miejsca.

Ale powieksz go, nawet do 1 ohm, ... powinien skrocic impuls, to i
napiecie spadnie.

No i obciaz wyjscie opornikiem np 2M (2*1M) - moze zdusi napiecie :-)


Quote:
Skończy się tak, że przeprojektuję płytkę z myślą o przetwornicy w
wersji THT - ta do tej pory działa we wszystkich egzemplarzach
poprzedniej wersji urządzenia...

Rezystory w sprzezeniu byly takie same w wersji THT ?

Bo tak patrze ... w przykladach sa raczej mniejsze rezystancje, moze
za duzo masz i komparator nie dziala ?
Przy czym tu sie liczy ten od nogi 5 do masy.

J.

J.F.
Guest

Fri Jan 12, 2018 11:14 pm   



Dnia Tue, 9 Jan 2018 08:28:42 +0100, Atlantis napisał(a):
Quote:
Hmm... Istnieje możliwość, że sposób prowadzenia ścieżek albo bardziej
gęste (niż w przypadku wersji THT) upakowanie elementów może mieć wpływ
na zachowanie przetwornicy?
Na wszelki wypadek wrzucam ten fragment płytki.

https://ibb.co/faoiCR

Duzy prad cewki z nogi 2 plynie przez sciezke masy, i gdzies tam jest
kondensator CT przypiety ... jakies zaklocenia oscylatora groza ...

A moze ... miernik masz uszkodzony ?

zmierz napiecie na nodze 5 - jest 1.25 V czy wiecej ?

J.

Atlantis
Guest

Sat Jan 13, 2018 8:57 am   



On 12.01.2018 23:14, J.F. wrote:

Quote:
Duzy prad cewki z nogi 2 plynie przez sciezke masy, i gdzies tam jest
kondensator CT przypiety ... jakies zaklocenia oscylatora groza ...

Hmm... Faktycznie... Czy będzie ok, jeśli kondensator będzie podłączony
do masy w pobliżu nogi 4, a zaraz obok dam przelotkę do pola masy?
Może w ogóle powinienem przesunąć granicę pola masy po drugiej stronie
nieco w prawo i również dać przelotkę przy nodze 2?

J.F.
Guest

Mon Jan 15, 2018 2:12 am   



Dnia Sat, 13 Jan 2018 08:57:13 +0100, Atlantis napisał(a):
Quote:
On 12.01.2018 23:14, J.F. wrote:
Duzy prad cewki z nogi 2 plynie przez sciezke masy, i gdzies tam jest
kondensator CT przypiety ... jakies zaklocenia oscylatora groza ...

Hmm... Faktycznie... Czy będzie ok, jeśli kondensator będzie podłączony
do masy w pobliżu nogi 4, a zaraz obok dam przelotkę do pola masy?
Może w ogóle powinienem przesunąć granicę pola masy po drugiej stronie
nieco w prawo i również dać przelotkę przy nodze 2?

Ja bym go testowo obrocil poziomo i przylutowal w blizen nogi nr 4
....ale watpie czy to to.

A moze jeszcze testowo dolutowac jakis kondensator miedzy nogi
zasilania tego ukladu ...

J.

Atlantis
Guest

Thu Jan 18, 2018 10:24 pm   



Zauważyłem jeden błąd w projekcie płytki - transformator w projekcie
Eagle został przez pomyłkę umieszczony po stronie elementów. W
zmontowanym układzie znajduje się po drugiej stronie, przez co końcówki
uzwojeń są zamienione miejscami. Same uzwojenia są jednak na swoich
miejscach. Czy taka sytuacja może mieć negatywny wpływ na działanie
przetwornicy (albo wręcz powodować problemy, z którymi mam do
czynienia)? A może mogę to zostawić w takiej formie i źródło problemu
najpewniej leży gdzie indziej?

Na schemacie z którego korzystałem są zaznaczone początki uzwojeń i w
taki sposób zostało to zaimplementowane w pierwszej, działającej wersji
urządzenia, tej z elementami THT.

J.F.
Guest

Fri Jan 19, 2018 1:39 am   



Dnia Thu, 18 Jan 2018 22:24:17 +0100, Atlantis napisał(a):
Quote:
Zauważyłem jeden błąd w projekcie płytki - transformator w projekcie
Eagle został przez pomyłkę umieszczony po stronie elementów. W
zmontowanym układzie znajduje się po drugiej stronie, przez co końcówki
uzwojeń są zamienione miejscami. Same uzwojenia są jednak na swoich
miejscach. Czy taka sytuacja może mieć negatywny wpływ na działanie
przetwornicy (albo wręcz powodować problemy, z którymi mam do
czynienia)?

Tam jest istotne kropkowanie. Jesli jednak zamieniles konce obu
uzwojen, to powinno sie zgadzac.

Tym niemniej nie to jest powodem problemow.


J.

Atlantis
Guest

Sat Jan 20, 2018 9:24 am   



On 19.01.2018 01:39, J.F. wrote:

Quote:
Tam jest istotne kropkowanie. Jesli jednak zamieniles konce obu
uzwojen, to powinno sie zgadzac.

Tym niemniej nie to jest powodem problemow.

Ok, udało mi się kilka rzeczy ustalić.
Po pierwsze zmontowałem układ na nowej płytce, modyfikując niektóre
połączenia. Teraz pin 2 nie łączy się już z masą koło kondensatora
oscylatora. Dałem osobną przelotkę do ogólnego pola masy.
Udało mi się też sprawdzić układ lepszym oscyloskopem cyfrowym i okazało
si, że:
1) Napięcie na wejściu jest względnie stabilne.
2) Napięcie na wyjściu cyklicznie waha się o kilkadziesiąt V.
3) Z każdym takim "wahnięciem" koreluje chwilowy brak oscylacji na
kondensatorze 1 nF.
4) Po wylutowaniu transformatora oscylator cały czas pracuje prawidłowo.

Wyglądało więc na to, że działa zabezpieczenie wyłączające przetwornicę
po przekroczeniu określonego prądu na wejściu (pomiar na rezystorze 0.22
ohm). Przyjąłem roboczą hipotezę, że coś nie tak może być z
transformatorem i wlutowałem inny egzemplarz. Sytuacja się nieco
poprawiła, ale przetwornica wciąż nie pracowała poprawnie.

I wtedy zauważyłem pewną rzecz - jeśli wykonuję pomiar kiepskim,
chińskim multimetrem, przetwornica zaczyna działać poprawnie -pojawia
się nawet charakterystyczne "ćwierkanie". Zmierzyłem innym multimetrem
wewnętrzny opór miernika - okazało się, że ma tylko 1 Mohm. Wychodzi
więc na to, że w chwili obecnej obciążenie przetwornicy pomaga. Przy
czym nawet z podłączonym miernikiem nie startuje ona natychmiast -
napięcie narasta powoli od około 250 do 370V, trwa to może trochę mniej
niż 10 sekund. Potem napięcie jest już stabilne, taką samą wartość
pokazuje każdy multimetr - pod warunkiem, że ten o małej rezystancji
jest cały czas podłączony. Jeśli go odepnę - napięcie znów spada.

Skąd się bierze takie dziwne zachowane przetwornicy? Dlaczego wersja THT
w starej konstrukcji spokojnie pracowała z dwoma kondensatorami 10M w
pętli sprzężenia zwrotnego, a teraz 2x4,7M to wciąż za małe obciążenie?

Marvin
Guest

Sat Jan 20, 2018 8:57 pm   



Quote:
Skąd się bierze takie dziwne zachowane przetwornicy? Dlaczego wersja THT
w starej konstrukcji spokojnie pracowała z dwoma kondensatorami 10M w
pętli sprzężenia zwrotnego, a teraz 2x4,7M to wciąż za małe obciążenie?


Moim zdaniem po prostu ta przetwornica się wzbudza, bo jej pętla
sprzężenia zwrotnego ma parametry, które prowadzą do niestabilności.
Powodem mogą być dwa kondensatory po 1 nF które tam widziałem na
schemacie w dzielniku, a dokładniej C8=1 nf.

Moim zdaniem, ten kondensator jest tam źle wsadzony i ja bym go testowo
usunął. On w transmitancji pętli sprzężenia zwrotnego miesza, bo opóźnia
sygnał sprzężenia zwrotnego w czasie. A ponieważ dzielnik ma sporą
rezystancję, jego pojemność jest znacząca z punktu widzenia jej stabilności.
Te opóźnienie powoduje, że przetwornica zaczyna się podwzbudzać na małej
częstotliwości ustalonej przez stałą RC dzielnika.
Moją hipotezę popiera to, że dołączenie do wyjścia rezystora 1 M
poprawia warunki pracy. Bezsprzecznie tłumi on oscylacje, zmieniając
wzmocnienie pętli sprzężenia zwrotnego na niższe, a jak wiadomo warunki
do oscylacji to wzmocnienie ponad 1 i przesuniecie fazy.

Uprzedzając kolejne pytanie powiem, że układ z elementów THT mógł
działać ponieważ większy ESR takich kondensatorów dołożył do
transmitancji zero i bieguny nie wylazły za oś urojoną.

Marvin

Atlantis
Guest

Sun Jan 21, 2018 9:33 am   



On 20.01.2018 20:57, Marvin wrote:

Quote:
Uprzedzając kolejne pytanie powiem, że układ z elementów THT mógł
działać ponieważ większy ESR takich kondensatorów dołożył do
transmitancji zero i bieguny nie wylazły za oś urojoną.

Zapomniałem dodać, że poprzednia wersja urządzenia nie była w 100%
oparta o elementy THT. Tam gdzie było to wygodne, stosowałem elementy
dyskretne SMD. Właśnie przyglądam się projektowi płytki tej starej
przetwornicy i widzę, że:

1) Wszystkie rezystory w pętli sprzężenia zwrotnego były standardowymi
rezystorami THT.

2) Kondensator filtrujący napięcie pętli (1nF na pinie 5) był
kondensatorem SMD, nawet mniejszym niż obecnie (0603 zamiast 1206).
Widzę jednak, że zastosowane wtedy ustawienie elementów pozwoliło mi go
umieścić w pobliżu pinu 4 (GND).

Marvin
Guest

Sun Jan 21, 2018 7:01 pm   



Quote:
2) Kondensator filtrujący napięcie pętli (1nF na pinie 5) był
kondensatorem SMD, nawet mniejszym niż obecnie (0603 zamiast 1206).
Widzę jednak, że zastosowane wtedy ustawienie elementów pozwoliło mi go
umieścić w pobliżu pinu 4 (GND).


Co do zasady - napięcia w pętli sprzężenia zwrotnego się nie filtruje.
Bo takie działanie jest bez sensu - chodzi przecież aby wzmacniacz
napięcia błędu reagował jak najszybciej na zmiany na wyjściu
przetwornicy, a ta pojemność filtrująca daje mu sygnał z opóźnieniem. A
reagowanie z opóźnieniem prowadzi do przerzutów i niestabilności -> a
więc wzbudzeń.
Elementy R-C które tam się umieszcza to zwykle dobrze dobrana
kompensacja pętli po to, aby była ona stabilna. Elementy te kompensują
bieguny lub zera wzmacniacza i filtru wyjściowego ale nic nie filtrują.
Ale dołączanie kondensatora 1n w tym miejscu "na pałę", to ignorancja
taka sama jak elektrolit na wyjściu stabilizatora 7805.

Zatem odłącz ten 1n i zobacz czy problemy nie ustąpią. A jak nie to
wsadź jeszcze szeregowo z kondensatorem filtrującym na wyjściu
przetwornicy rezystor, np. 10 omów-100 omów. Taki który mu zrobi, temu
kondensatorowi duży ESR. I pewnie będzie zonk :)


Ściskam dłoń,
Marvin

Goto page Previous  1, 2, 3  Next

elektroda NewsGroups Forum Index - Elektronika Polska - Dziwne zachowanie przetwornicy na MC34063

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map