RTV forum PL | NewsGroups PL

Diagnozowanie RPi

NOWY TEMAT

elektroda NewsGroups Forum Index - Elektronika Polska - Diagnozowanie RPi

Andrzej W.
Guest

Wed Feb 07, 2024 1:09 am   



Cześć.

Miałem serwerek na RPi 4, działał sobie kilka lat 24/7
Ale powoli się degradował, najpierw zaczął zanikać sygnał na jednym
złączu HDMI potem na drugim na koniec przestał się uruchamiać kernel.
Ale całkiem sporo w tym RPi "działa".
W tym bootloaderze z EEPROMu włączyłem debugowanie i przetestowałem
rożne tryby.
- Boot z karty SD, bootloader widzi kartę SD i partycje na niej oraz
pliki konfiguracyjne
- Boot z dysku USB HDD, bootloader widzi dysk HDD i partycje na nim oraz
pliki konfiguracyjne
- Boot z sieci, bootloader dostaje IP z DHCP oraz dane serwera, usiłuje
łączyć się z serwerem tftp (nie chciało się mi go już stawiać).

Wszystkie komunikaty bootloadera są ok. tak jak powinny być, żadnych
błędów i wszystko się zatrzymuje w miejscu gdzie powinny się pojawić
komunikaty z kernela ale nic się nie dzieje.

Próbowałem różnych kart SD, różnych systemów operacyjnych, koniec zawsze
jest taki sam.


--
AWa.

Marek
Guest

Wed Feb 07, 2024 1:32 am   



On Wed, 7 Feb 2024 00:09:27 +0100, "Andrzej W."
<awa_wp.a_to_wytnij.@wp.pl> wrote:
Quote:
Wszystkie komunikaty bootloadera są ok. tak jak powinny być,
żadnych
błędów i wszystko się zatrzymuje w miejscu gdzie powinny się
pojawić
komunikaty z kernela ale nic się nie dzieje.

Działający uboot tylko do momentu załadowania jądra sugeruje problemy
z pamięcią, przelutować DRAM.

--
Marek

Andrzej W.
Guest

Fri Feb 09, 2024 8:54 pm   



W dniu 07.02.2024 o 00:32, Marek pisze:
Quote:
On Wed, 7 Feb 2024 00:09:27 +0100, "Andrzej W."
awa_wp.a_to_wytnij.@wp.pl> wrote:
Wszystkie komunikaty bootloadera są ok. tak jak powinny być, żadnych
błędów i wszystko się zatrzymuje w miejscu gdzie powinny się pojawić
komunikaty z kernela ale nic się nie dzieje.

Działający uboot tylko do momentu załadowania jądra sugeruje problemy z
pamięcią, przelutować DRAM.


Chyba jednak jestem trochę za cienki na lutowanie tej pamięci...
Czy jest może jakiś "mem test" co się go da w bootloadera upchnąć i
przetestować to bez ładowania całego systemu?
Skoro da się tam upchnąć DHCP, tftp itp. to czemu nie mem test.

--
AWa.

Marek
Guest

Sat Feb 10, 2024 10:11 am   



On Fri, 9 Feb 2024 19:54:39 +0100, "Andrzej W."
<awa_wp.a_to_wytnij.@wp.pl> wrote:
Quote:
Chyba jednak jestem trochę za cienki na lutowanie tej pamięci...

Może pomóc zwykłe podgrzanie... Heby chyba coś takiego robił.


Quote:
przetestować to bez ładowania całego systemu?

Dawno już uboota nie składałem ale coś takiego może tam być.
Ewentualnie powinno się dać przenieść do ubota kod memtest (o ile
wspiera tą arch.).

Przypomniał mi się jeszcze jeden powód takiego zachowania jak u
ciebie. Kiedyś budowałem ubota na mipsa i problem z botnięciem
kernela był spowodowany nieprawidłową autodetekcją zakresu adresacji
dostępnej pamięci przez uboot. Ale to trochę inny case, zakładam że u
Ciebie działało i nagle przestało.

--
Marek

elektroda NewsGroups Forum Index - Elektronika Polska - Diagnozowanie RPi

NOWY TEMAT

Regulamin - Zasady uzytkowania Polityka prywatnosci Kontakt RTV map News map