RTV forum PL | NewsGroups PL

Włączanie silnika dalekopisu

NOWY TEMAT

elektroda.net NewsGroups Forum Index - Elektronika Polska - Włączanie silnika dalekopisu

Goto page 1, 2  Next

Atlantis
Guest

Fri Nov 17, 2017 11:15 am   



Wróciłem ostatnio do projektu swojego interfejsu dalekopisowego.
Projektuję właśnie PCB, która zastąpi prowizoryczną płytkę prototypową.
Dodaję przy tej okazji kilka nowych funkcji, m.in. włączanie silnika
dalekopisu z poziomu mikrokontrolera. I właśnie tutaj natknąłem się na
pewne wątpliwości, które chciałem rozwiać.

1) Zakładam wykorzystanie optotriaka z wykrywaniem zera (MOC3041)
sterującego triakiem, który będzie załączał silnik. Nie udało mi się
jednak dotrzeć do dokładnych parametrów silnika stosowanego w T100. Wiem
właściwie tylko tyle, że został zaprojektowany z myślą o pracy przy
napięciu AC 220V, nie znam jednak jego mocy.
Nie mam w chwili obecnej możliwości wykonania wymiarów (brak dostępu do
sprzętu), a i tak chciałbym dać tutaj rozsądny zapas. Czy coś w rodzaju
standardowego BT138 będzie odpowiednim rozwiązaniem?
2) Jak powinien wyglądać gasik dla takiego silnika? Jaki kondensator
(typ i parametry) oraz rezystor powinienem zastosować?

J.F.
Guest

Fri Nov 17, 2017 1:32 pm   



Użytkownik "Atlantis" napisał w wiadomości grup
dyskusyjnych:5a0eb6b2$0$15190$65785112_at_news.neostrada.pl...
Quote:
Wróciłem ostatnio do projektu swojego interfejsu dalekopisowego.
Projektuję właśnie PCB, która zastąpi prowizoryczną płytkę
prototypową.
Dodaję przy tej okazji kilka nowych funkcji, m.in. włączanie silnika
dalekopisu z poziomu mikrokontrolera. I właśnie tutaj natknąłem się
na
pewne wątpliwości, które chciałem rozwiać.

1) Zakładam wykorzystanie optotriaka z wykrywaniem zera (MOC3041)

to niekoniecznie jest dobry pomysl.
daj podstawke I kup od razu taki bez wykrywania.

Albo daj przekaznik, to nie bedzie problemow :-)

Quote:
sterującego triakiem, który będzie załączał silnik. Nie udało mi się
jednak dotrzeć do dokładnych parametrów silnika stosowanego w T100.
Wiem
właściwie tylko tyle, że został zaprojektowany z myślą o pracy przy
napięciu AC 220V, nie znam jednak jego mocy.
Nie mam w chwili obecnej możliwości wykonania wymiarów (brak dostępu
do
sprzętu), a i tak chciałbym dać tutaj rozsądny zapas. Czy coś w
rodzaju
standardowego BT138 będzie odpowiednim rozwiązaniem?

Mysle ze tak - ten silnik ma jakies 100W

Quote:
2) Jak powinien wyglądać gasik dla takiego silnika? Jaki kondensator
(typ i parametry) oraz rezystor powinienem zastosować?

Duzy Smile
A jeszcze sa "snubberless triac"


J.

Atlantis
Guest

Fri Nov 17, 2017 2:38 pm   



On 17.11.2017 13:32, J.F. wrote:

Quote:
to niekoniecznie jest dobry pomysl.
daj podstawke I kup od razu taki bez wykrywania.

Mogę zapytać dlaczego? Wydawało mi się, że włączanie/wyłączanie
urządzenia w zerze jest wskazane. No chyba, że chodzi o coś związanego
ze specyfiką obciążenia indukcyjnego?


Quote:
Albo daj przekaznik, to nie bedzie problemow Smile

Jaka jest żywotność takiego przekaźnika, w porównaniu do triaka?


Quote:
Duzy Smile

To znaczy? Wink

J.F.
Guest

Fri Nov 17, 2017 7:30 pm   



Dnia Fri, 17 Nov 2017 14:38:17 +0100, Atlantis napisał(a):
Quote:
On 17.11.2017 13:32, J.F. wrote:
to niekoniecznie jest dobry pomysl.
daj podstawke I kup od razu taki bez wykrywania.

Mogę zapytać dlaczego? Wydawało mi się, że włączanie/wyłączanie
urządzenia w zerze jest wskazane. No chyba, że chodzi o coś związanego
ze specyfiką obciążenia indukcyjnego?

specyfika
-w normalnej pracy to w zerze napiecia przez cewke ciagle plynie prad,
ktory dopiero zanika, przechodzi przez zero, narasta ... a jestesmy
juz po kawalku polokresu okresu i do jego konca juz niecaly.
Jak wlaczysz dokladnie w zerze, to mamy caly polokres napiecia,
prad narasta dluzej, grozi nam nasycenie zera, oraz przez pewien czas
jest spora skladowa stala.

-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

Quote:
Albo daj przekaznik, to nie bedzie problemow Smile
Jaka jest żywotność takiego przekaźnika, w porównaniu do triaka?

Trudno powiedziec. Czasem triak pracuje latami, czasem pada
blyskawicznie :-)

A przeciez caly dalekopis masz na przekaznikach.

J.

Atlantis
Guest

Sun Nov 19, 2017 6:56 pm   



On 17.11.2017 19:30, J.F. wrote:

Quote:
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

Hmm... Twoim zdaniem powinien w takim razie zrezygnować z zestawu
optotriak-triak, czy po prostu odpuścić sobie stosowanie optotriaka z
funkcją wykrywania zera?

Bo jakby nie patrzeć - izolacja galwaniczna zapewniana przez optotriak
to całkiem fajny dodatek do układu.

W przypadku zastosowania przekaźnika niby też można dać izolację
optyczną - popularne moduły do Arduino wykorzystują czasem zestaw
transoptor-tranzystor-przekaźnik, ale co to za izolacja, skoro
fototranzystor transoptora i tranzystor sterujący cewką przekaźnika są
podłączone do tego samego VCC, co cała reszta układu? W przypadku
uszkodzenia przekaźnika napięcie sieci i tak może pójść na elektronikę
cyfrową, a przecież m.in. przed tym ma chronić optoizolacja...

J.F.
Guest

Sun Nov 19, 2017 8:21 pm   



Dnia Sun, 19 Nov 2017 18:56:26 +0100, Atlantis napisał(a):
Quote:
On 17.11.2017 19:30, J.F. wrote:
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

Hmm... Twoim zdaniem powinien w takim razie zrezygnować z zestawu
optotriak-triak, czy po prostu odpuścić sobie stosowanie optotriaka z
funkcją wykrywania zera?

Moim zdaniem to powinienies sie liczyc z klopotami przy optoriaku z
wykrywaniem zera i przygotowac sobie plan B.

Quote:
Bo jakby nie patrzeć - izolacja galwaniczna zapewniana przez optotriak
to całkiem fajny dodatek do układu.

Przekaznik tez izoluje :-)

J.

Paweł Pawłowicz
Guest

Sun Nov 19, 2017 10:34 pm   



W dniu 17.11.2017 o 19:30, J.F. pisze:
[...]
Quote:
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

W datasheecie jest napisane, że jeżeli napięcie między pinami 4 i 6 jest
większe od 5V, to optotriak się nie włączy. A to może spowodować, że
będzie się włączał co drugi półokres, i mamy piękną składową stałą.
Gasik zmniejszy dU/dt, ale trudno przewidzieć, jak taki układ się zachowa.

p.p.

J.F.
Guest

Mon Nov 20, 2017 8:59 am   



Dnia Sun, 19 Nov 2017 22:34:40 +0100, Paweł Pawłowicz napisał(a):
Quote:
W dniu 17.11.2017 o 19:30, J.F. pisze:
[...]
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

W datasheecie jest napisane, że jeżeli napięcie między pinami 4 i 6 jest
większe od 5V, to optotriak się nie włączy. A to może spowodować, że
będzie się włączał co drugi półokres, i mamy piękną składową stałą.
Gasik zmniejszy dU/dt, ale trudno przewidzieć, jak taki układ się zachowa.

Trudno przewidziec, przejscie przez zero ciagle jest, jesli LED stale
swieci ...

dU/dt szkodzi tez samemu triakowi - moze sie wlaczyc nieproszony.

Ktos tu niedawno publikowal zdjecia SSR, tam dwa tyrystory byly ...
ale czy im duze dU/dt nie szkodzi ?

J.

Paweł Pawłowicz
Guest

Mon Nov 20, 2017 11:50 am   



W dniu 2017-11-20 o 08:59, J.F. pisze:
Quote:
Dnia Sun, 19 Nov 2017 22:34:40 +0100, Paweł Pawłowicz napisał(a):
W dniu 17.11.2017 o 19:30, J.F. pisze:
[...]
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

W datasheecie jest napisane, że jeżeli napięcie między pinami 4 i 6 jest
większe od 5V, to optotriak się nie włączy. A to może spowodować, że
będzie się włączał co drugi półokres, i mamy piękną składową stałą.
Gasik zmniejszy dU/dt, ale trudno przewidzieć, jak taki układ się zachowa.

Trudno przewidziec, przejscie przez zero ciagle jest, jesli LED stale
swieci ...

dU/dt szkodzi tez samemu triakowi - moze sie wlaczyc nieproszony.

Ktos tu niedawno publikowal zdjecia SSR, tam dwa tyrystory byly ...
ale czy im duze dU/dt nie szkodzi ?

Tyrystor i triak to dwie różne bajki.
W kwestii zasadniczej: po co włączanie w zerze przy obciążeniu
indukcyjnym ;-)

P.P.

J.F.
Guest

Mon Nov 20, 2017 12:09 pm   



Użytkownik "Paweł Pawłowicz" napisał w wiadomości grup
dyskusyjnych:5a12b37c$0$662$65785112_at_news.neostrada.pl...
W dniu 2017-11-20 o 08:59, J.F. pisze:
Quote:
dU/dt szkodzi tez samemu triakowi - moze sie wlaczyc nieproszony.
Ktos tu niedawno publikowal zdjecia SSR, tam dwa tyrystory byly ...
ale czy im duze dU/dt nie szkodzi ?

Tyrystor i triak to dwie różne bajki.

Pod wzgledem dU/dt to zdaje sie podobna.

Quote:
W kwestii zasadniczej: po co włączanie w zerze przy obciążeniu
indukcyjnym Wink

Otoz to - moze bardziej zaszkodzic niz pomoc.

Gdyby sie jednak kolega uparl na polprzewodniki ... lepszy triak czy
dwa tyrystory/SSR z dwóch tyrystorow ?

A silnik malutki, mysle ze 100W nawet nie ma ... zadne obciazenie :-)

J.

J.F.
Guest

Mon Nov 20, 2017 4:23 pm   



Użytkownik antispam napisał w wiadomości grup
dyskusyjnych:ouuqt3$guk$1_at_z-news.wcss.wroc.pl...
J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
Quote:
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz
spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych
50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

To nie powinno byc problemem. Szybkie narastanie napiecia jest
problemem zaraz po wylaczeniu. Po wlaczeniu triaka (zakladajac
ze prad jest dostatecznie duzy by triak sie faktycznie wlaczyl)
optotriak sie wylacza i w momencie gdy triak sie wylacza optotriak
byl juz przez sporo czasu wylaczony.

Cos w tym jest ... ale czy nie zadziala w druga strone ?

Bo faktycznie - przy rezystancyjnym obciazeniu to dziala tak, ze po
wyzwoleniu optotriak ma na sobie jakies znikome napiecie, ktore w
pewnym momencie sie zeruje i zmienia bieguny - jak w tym momencie LED
swieci, to triak sie powinien otworzyc.
Jak napiecie jest wyzsze - to juz nie nie powinien.

A z cewka tu mamy bardzo szybki wzrost napiecia.

Quote:
Do tego moc strat w gasiku
optotriaka moze byc spora czescia mocy optotriaka, czyli gasik
moze skuteczeniej dzialac. W efekcie np. moze wystarczyc
optotriak 600V pomimo tego ze triak musi byc 800V (przy duzej
indukcynosci mozna sie spodziewac 700V na triaku).

A tego to nie jestem pewien. Wylaczenie w koncu w zerze pradu.

Quote:
Przy tym silniki nie sa az tak bardzo indukcyjne, komutatorowe
to chyba gdzies kolo 1/10 skladowj indukcyjnej, silniki
indukcyjne tez maja cosinus fi sporo ponizej 1.

ale tam indukcyjny czy synchroniczny jednak.
Owszem - pewnie skladowa rezystancyjna ma spora, bo moc raczej mala,
tym niemniej nam wystarczy troche skladowej indukcyjnej aby bylo
ryzyko cudow.

Quote:
Waldek Hebisch

J.

Guest

Mon Nov 20, 2017 5:04 pm   



J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
Quote:
Dnia Fri, 17 Nov 2017 14:38:17 +0100, Atlantis napisa?(a):
On 17.11.2017 13:32, J.F. wrote:
to niekoniecznie jest dobry pomysl.
daj podstawke I kup od razu taki bez wykrywania.

Mog? zapyta? dlaczego? Wydawa?o mi si?, ?e w??czanie/wy??czanie
urz?dzenia w zerze jest wskazane. No chyba, ?e chodzi o co? zwi?zanego
ze specyfik? obci??enia indukcyjnego?

specyfika
-w normalnej pracy to w zerze napiecia przez cewke ciagle plynie prad,
ktory dopiero zanika, przechodzi przez zero, narasta ... a jestesmy
juz po kawalku polokresu okresu i do jego konca juz niecaly.
Jak wlaczysz dokladnie w zerze, to mamy caly polokres napiecia,
prad narasta dluzej, grozi nam nasycenie zera, oraz przez pewien czas
jest spora skladowa stala.

-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych 50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

To nie powinno byc problemem. Szybkie narastanie napiecia jest
problemem zaraz po wylaczeniu. Po wlaczeniu triaka (zakladajac
ze prad jest dostatecznie duzy by triak sie faktycznie wlaczyl)
optotriak sie wylacza i w momencie gdy triak sie wylacza optotriak
byl juz przez sporo czasu wylaczony. Do tego moc strat w gasiku
optotriaka moze byc spora czescia mocy optotriaka, czyli gasik
moze skuteczeniej dzialac. W efekcie np. moze wystarczyc
optotriak 600V pomimo tego ze triak musi byc 800V (przy duzej
indukcynosci mozna sie spodziewac 700V na triaku).

Przy tym silniki nie sa az tak bardzo indukcyjne, komutatorowe
to chyba gdzies kolo 1/10 skladowj indukcyjnej, silniki
indukcyjne tez maja cosinus fi sporo ponizej 1.

--
Waldek Hebisch

Guest

Mon Nov 20, 2017 8:02 pm   



J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
Quote:
U?ytkownik antispam napisa? w wiadomo?ci grup
dyskusyjnych:ouuqt3$guk$1_at_z-news.wcss.wroc.pl...
J.F. <jfox_xnospamx_at_poczta.onet.pl> wrote:
-przychodzi zero napiecia, ale prad ciagle plynie, tyle ze juz
spada.
Prad dochodzi do zera, a w sieci powiedzmy 50V.
triak sie wylacza, napiecie na nim blyskawicznie rosnie do tych
50V
.. i otworzy sie optotriak teraz, czy poczeka do zera napiecia ?

To nie powinno byc problemem. Szybkie narastanie napiecia jest
problemem zaraz po wylaczeniu. Po wlaczeniu triaka (zakladajac
ze prad jest dostatecznie duzy by triak sie faktycznie wlaczyl)
optotriak sie wylacza i w momencie gdy triak sie wylacza optotriak
byl juz przez sporo czasu wylaczony.

Cos w tym jest ... ale czy nie zadziala w druga strone ?

Bo faktycznie - przy rezystancyjnym obciazeniu to dziala tak, ze po
wyzwoleniu optotriak ma na sobie jakies znikome napiecie, ktore w
pewnym momencie sie zeruje i zmienia bieguny - jak w tym momencie LED
swieci, to triak sie powinien otworzyc.
Jak napiecie jest wyzsze - to juz nie nie powinien.

A z cewka tu mamy bardzo szybki wzrost napiecia.

Nie znam detali konstrukcji optotriakow (tzn. jak dziala
ten uklad zalaczania w zerze). Ale z tego co
rozumiem to optotriak moze sie wlaczyc w miare szybko
(rzedu mikrosekundy). Jak sie wlaczy to napiecie juz
nie narasta tak szybko, prad jest ograniczony przez
cewke i spadek napiecia na optotriaku jest maly. Przy
tym gasik ogranicza tempo wzrostu napiecia na optotriaku.
Producenci optotriakow podaja przykladowe gasiki do
obciazen indukcyjnych, wiec mozna przyjac ze z takim
gasikiem optotriak ma dosc czasu by sie wlaczyc.

Quote:

Do tego moc strat w gasiku
optotriaka moze byc spora czescia mocy optotriaka, czyli gasik
moze skuteczeniej dzialac. W efekcie np. moze wystarczyc
optotriak 600V pomimo tego ze triak musi byc 800V (przy duzej
indukcynosci mozna sie spodziewac 700V na triaku).

A tego to nie jestem pewien. Wylaczenie w koncu w zerze pradu.

Czego? Tego 700V? Przy wylaczaniu w zerze pradu indukcyjnosc
i pojemnosci rownolegle do triaka (czyli co najmniej pojemnosc
pasozytnicza triaka) robia z obwod rezonansowy w ktorym pojawiaja
sie drgania gasnace z poczatkowa amplituda rowna napieciu V_0
zasilania w momencie wylaczenia. Po pol okresu tego obwodu
napiecie na indukcyjnosci i zasilanie sie dodaja i na triaku
dostaje sie w przyblizeniu 2V_0. Jak duza indukcyjnosc to
zero pradu to szczyt napiecia, czyli triak musi wytrzymac
(przez pare mikrosekund) podwojone napiecie szczytowe sieci.

W szereg z optotriakiem daje sie opornik, zas kondesator
gasika dobiera tak by stala obwodu RC byla wieksza od
okresu drgan na triaku. Wtedy optotriak dostaje usrednione
napiecie i szczyty sa duzo nizsze niz na triaku. Dla
triaka opor szeregowy nie moze byc duzy i gasik jest
mniej skuteczny. W zasadzie, prosciej jest dac triak na
dostatecznie wysokie napiecie i malutki gasik albo nic
(jak triak jest snubberless).

Quote:
Przy tym silniki nie sa az tak bardzo indukcyjne, komutatorowe
to chyba gdzies kolo 1/10 skladowj indukcyjnej, silniki
indukcyjne tez maja cosinus fi sporo ponizej 1.

ale tam indukcyjny czy synchroniczny jednak.
Owszem - pewnie skladowa rezystancyjna ma spora, bo moc raczej mala,
tym niemniej nam wystarczy troche skladowej indukcyjnej aby bylo
ryzyko cudow.

Przy silniku, jak mamy cos fi np. 0.7 to w zerze pradu mamy 0.71
szczytowego i przy wylaczaniu zamiast triaka 800V (jak przy
czysto indukcyjnym) wystarczy triak 600V. Czyli jest latwiej,
ale dalej trzeba gasik czy triak snubberless.
Jak ktos da zwykly triak 400V bez gasika to moga byc cuda...

--
Waldek Hebisch

Paweł Pawłowicz
Guest

Mon Nov 20, 2017 10:03 pm   



W dniu 20.11.2017 o 19:02, antispam_at_math.uni.wroc.pl pisze:
[...]
Quote:
Nie znam detali konstrukcji optotriakow (tzn. jak dziala
ten uklad zalaczania w zerze).

Lektura pdf-ów pozwala wywnioskować, że w sposób bardzo prosty. Układ
blokuje możliwość wyzwolenia triaka przy napięciu na nim większym niż
pewna wartość. Pewien problem jest z ową wartością, Toshiba podaje, że
to max. 40V, Motorola, że max. 20V, ale w innym miejscu, że to 5V, co
wydaje się mało prawdopodobne.

Pozdrawiam,
Paweł

Paweł Pawłowicz
Guest

Mon Nov 20, 2017 10:51 pm   



W dniu 20.11.2017 o 22:03, Paweł Pawłowicz pisze:
Quote:
W dniu 20.11.2017 o 19:02, antispam_at_math.uni.wroc.pl pisze:
[...]
Nie znam detali konstrukcji optotriakow (tzn. jak dziala
ten uklad zalaczania w zerze).

Lektura pdf-ów pozwala wywnioskować, że w sposób bardzo prosty. Układ
blokuje możliwość wyzwolenia triaka przy napięciu na nim większym niż
pewna wartość. Pewien problem jest z ową wartością, Toshiba podaje, że
to max. 40V, Motorola, że max. 20V, ale w innym miejscu, że to 5V, co
wydaje się mało prawdopodobne.

Pozdrawiam,
Paweł

Sprawdziłem Smile
MOC3043 Motorola. Przy 17.5V włącza się, przy 17.6V już nie.
TLP3043 Toshiby włącza się przy 30.7V, przy 30.8 już nie.

P.P.

Goto page 1, 2  Next

elektroda.net NewsGroups Forum Index - Elektronika Polska - Włączanie silnika dalekopisu

NOWY TEMAT

RTV map News map