RTV forum PL | NewsGroups PL

orangepi, GPIO, odfiltrowanie 50Hz

NOWY TEMAT

elektroda.net NewsGroups Forum Index - Elektronika Polska - orangepi, GPIO, odfiltrowanie 50Hz

Budyń
Guest

Wed Jun 07, 2017 9:11 am   



Prosta rzecz: odczytać stan pinu gpio w orangepi.
Z pinu 3,3V poprzez przycisk i rezystor rzędu kilku kom daję sygnał na czytany pin.
Ale jesli na pinie cokolwiek przyłącze to przewód zbiera przydzwiek od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy przycisk wciśniety czy nie.
1) czy mam to filtrowac na zewnątrz (w raspberrypi takich jazd nie miałem). Jesli tak to jak?
2) moze to trzeba programowo zwalczyć typu podciągnac pullup itp pina?
3) istnieje opcja ze całe to orange jest uszkodzone (padł jeden port USB) mimo ze udaje ze działa.


b.

J.F.
Guest

Wed Jun 07, 2017 9:11 am   



Użytkownik "Budyń" napisał w wiadomości grup
dyskusyjnych:87d6bc1a-e620-4125-8364-9a3988484db3_at_googlegroups.com...
Prosta rzecz: odczytać stan pinu gpio w orangepi.
Quote:
Z pinu 3,3V poprzez przycisk i rezystor rzędu kilku kom daję sygnał
na czytany pin.
Ale jesli na pinie cokolwiek przyłącze to przewód zbiera przydzwiek
od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy przycisk
wciśniety czy nie.

A to troche dziwne, ze niezalezne od przycisku.

Quote:
1) czy mam to filtrowac na zewnątrz (w raspberrypi takich jazd nie
miałem). Jesli tak to jak?
2) moze to trzeba programowo zwalczyć typu podciągnac pullup itp
pina?

Normalnie Pull-up (lub pull-down) by pomogl. Jesli nie wewnetrzny, to
zewnetrzny.
Ale jesli przycisk nie ma wplywu, to moze problem jest inny ?
Softwareowy np - wlaczyles jakis timer.

Jeszcze mozesz dac transoptor na wejsciu.

J.

Grzegorz Kurczyk
Guest

Wed Jun 07, 2017 9:11 am   



W dniu 07.06.2017 o 10:02, Budyń pisze:
Quote:
W dniu środa, 7 czerwca 2017 09:54:25 UTC+2 użytkownik Budyń napisał:
W dniu środa, 7 czerwca 2017 09:48:41 UTC+2 użytkownik J.F. napisał:
Normalnie Pull-up (lub pull-down) by pomogl. Jesli nie wewnetrzny, to
zewnetrzny.
Ale jesli przycisk nie ma wplywu, to moze problem jest inny ?

no wlasnie podejrzewam ze sprzęt jest strzelony :/

tzn dla jasnosci: przyciskanie daje zauważalne efekty, w czasie zmiany stanu przycisku te układy stanów w 100Hz cyklu sie troche zakłócają


b.


Witam.
Spróbuj dać rezystor rzędu 3k3 bezpośrednio między pin wejściowy a pin
3,3V na płytce orangepi i na kabelkach przycisk między ten pin wejściowy
pin masy. (w tym układzie przycisk wciśnięty daje 0 a puszczony 1)

--
Pozdrawiam
Grzegorz

Budyń
Guest

Wed Jun 07, 2017 9:54 am   



W dniu środa, 7 czerwca 2017 09:48:41 UTC+2 użytkownik J.F. napisał:
Quote:
Normalnie Pull-up (lub pull-down) by pomogl. Jesli nie wewnetrzny, to
zewnetrzny.
Ale jesli przycisk nie ma wplywu, to moze problem jest inny ?

no wlasnie podejrzewam ze sprzęt jest strzelony :/





b.

Budyń
Guest

Wed Jun 07, 2017 10:02 am   



W dniu środa, 7 czerwca 2017 09:54:25 UTC+2 użytkownik Budyń napisał:
Quote:
W dniu środa, 7 czerwca 2017 09:48:41 UTC+2 użytkownik J.F. napisał:
Normalnie Pull-up (lub pull-down) by pomogl. Jesli nie wewnetrzny, to
zewnetrzny.
Ale jesli przycisk nie ma wplywu, to moze problem jest inny ?

no wlasnie podejrzewam ze sprzęt jest strzelony :/

tzn dla jasnosci: przyciskanie daje zauważalne efekty, w czasie zmiany stanu przycisku te układy stanów w 100Hz cyklu sie troche zakłócają


b.

Marek
Guest

Wed Jun 07, 2017 2:09 pm   



On Wed, 7 Jun 2017 00:11:56 -0700 (PDT),
Budyń<budynpl.poland_at_gmail.com> wrote:
Quote:
ydzwiek od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy

jak zmierzyłes to 100Hz?

--
Marek

J.F.
Guest

Wed Jun 07, 2017 2:38 pm   



Użytkownik "Budyń" napisał w wiadomości grup
dyskusyjnych:59b421e0-af93-425e-9780-8ceca4dcc75b_at_googlegroups.com...
W dniu środa, 7 czerwca 2017 16:10:54 UTC+2 użytkownik Marek napisał:
Quote:
On Wed, 7 Jun 2017 00:11:56 -0700 (PDT),
Budyń<budynpl.poland_at_gmail.com> wrote:
ydzwiek od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy

jak zmierzyłes to 100Hz?

kazałem wypisac na ekran czas gdy zachodzi zmiana stanu.
Ale: własnie zrobilem próbe na raspberry pi - mam dokladnie ten sam
efekt. Czyli sprzet jest dobry.

Procesor, bo przycisk jest zly, albo kabel :-)

Quote:
Na tym raspberry czytałem kiedys obroty za pomocą
http://electropark.pl/moduly-optyczne/3291-modul-detektora-szczelinowego-10mm.html
i to działało poprawnie a ten moduł był kilka metrów od .

A teraz w to miejsce dalem przycisk i jest wspomiana kaszana.

I myslisz, ze teraz cos indukuje 100Hz w kablu ? Ktory tez ma pare m ?
Malo prawdopodobne.

Dobrze podlaczyles przycisk do masy ? Tej masy od procesora.
Kabel nie jest urwany ? Bo o ile rozne zaklocenia sobie potrafie
wyobrazic, to brak wplywu przycisku juz gorzej.

J.

Grzegorz Niemirowski
Guest

Wed Jun 07, 2017 3:44 pm   



Budyń <budynpl.poland_at_gmail.com> napisał(a):
Quote:
Prosta rzecz: odczytać stan pinu gpio w orangepi.
Z pinu 3,3V poprzez przycisk i rezystor rzędu kilku kom daję sygnał na
czytany pin. Ale jesli na pinie cokolwiek przyłącze to przewód zbiera
przydzwiek od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy
przycisk wciśniety czy nie. 1) czy mam to filtrowac na zewnątrz (w
raspberrypi takich jazd nie miałem). Jesli tak to jak? 2) moze to
trzeba programowo zwalczyć typu podciągnac pullup itp pina? 3) istnieje
opcja ze całe to orange jest uszkodzone (padł jeden port USB) mimo ze
udaje ze działa.
b.

Jak masz podłączony ten rezystor? Niech on będzie pullupem a przycisk niech
zwiera pin do masy. Nie powinno być wtedy problemu z przydźwiękiem.

--
Grzegorz Niemirowski
http://www.grzegorz.net/

Mirek
Guest

Wed Jun 07, 2017 4:21 pm   



On 07.06.2017 16:38, J.F. wrote:

Quote:
Dobrze podlaczyles przycisk do masy ? Tej masy od procesora.
Kabel nie jest urwany ?

Ja takie cuda kiedyś miałem na 20C51. Tak się zafiksowałem na odkłócaniu
wejść, że nie zauważyłem że kostka nie ma w ogóle podłączonego pinu
zasilania, tylko zasila się pasożytniczo z pullupów.

--
Mirek.

Budyń
Guest

Wed Jun 07, 2017 4:24 pm   



W dniu środa, 7 czerwca 2017 16:10:54 UTC+2 użytkownik Marek napisał:
Quote:
On Wed, 7 Jun 2017 00:11:56 -0700 (PDT),
Budyń<budynpl.poland_at_gmail.com> wrote:
ydzwiek od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy

jak zmierzyłes to 100Hz?


kazałem wypisac na ekran czas gdy zachodzi zmiana stanu.
Ale: własnie zrobilem próbe na raspberry pi - mam dokladnie ten sam efekt. Czyli sprzet jest dobry.
Na tym raspberry czytałem kiedys obroty za pomocą
http://electropark.pl/moduly-optyczne/3291-modul-detektora-szczelinowego-10mm.html
i to działało poprawnie a ten moduł był kilka metrów od . A teraz w to miejsce dalem przycisk i jest wspomiana kaszana.


b.

Grzegorz Niemirowski
Guest

Wed Jun 07, 2017 5:08 pm   



Budyń <budynpl.poland_at_gmail.com> napisał(a):
Quote:
rozebralem i zlozylem jak piszesz - zadzialalo. Cos tam nie halo w tych
sprzetowych pullapach, ale na razie dalej nie szukam.
thx!
b.

OK Smile
Możliwe, że sprzętowy był za słaby i przy silnych zakłóceniach jednak stan
pinu się zmieniał.

--
Grzegorz Niemirowski
http://www.grzegorz.net/

Budyń
Guest

Wed Jun 07, 2017 7:04 pm   



W dniu środa, 7 czerwca 2017 17:44:06 UTC+2 użytkownik Grzegorz Niemirowski napisał:
Quote:
Budyń <budynpl.poland_at_gmail.com> napisał(a):
Prosta rzecz: odczytać stan pinu gpio w orangepi.
Z pinu 3,3V poprzez przycisk i rezystor rzędu kilku kom daję sygnał na
czytany pin. Ale jesli na pinie cokolwiek przyłącze to przewód zbiera
przydzwiek od sieci i stan 0 - 1 mam ładnie w 100Hz niezależnie czy
przycisk wciśniety czy nie. 1) czy mam to filtrowac na zewnątrz (w
raspberrypi takich jazd nie miałem). Jesli tak to jak? 2) moze to
trzeba programowo zwalczyć typu podciągnac pullup itp pina? 3) istnieje
opcja ze całe to orange jest uszkodzone (padł jeden port USB) mimo ze
udaje ze działa.
b.

Jak masz podłączony ten rezystor? Niech on będzie pullupem a przycisk niech
zwiera pin do masy. Nie powinno być wtedy problemu z przydźwiękiem.

rozebralem i zlozylem jak piszesz - zadzialalo. Cos tam nie halo w tych sprzetowych pullapach, ale na razie dalej nie szukam.

thx!

b.

J.F.
Guest

Wed Jun 07, 2017 10:10 pm   



Dnia Wed, 7 Jun 2017 10:04:51 -0700 (PDT), Budyń napisał(a):
Quote:
W dniu środa, 7 czerwca 2017 17:44:06 UTC+2 użytkownik Grzegorz Niemirowski napisał:
Budyń <budynpl.poland_at_gmail.com> napisał(a):
Prosta rzecz: odczytać stan pinu gpio w orangepi.
Z pinu 3,3V poprzez przycisk i rezystor rzędu kilku kom daję sygnał na
czytany pin.

Jak masz podłączony ten rezystor? Niech on będzie pullupem a przycisk niech
zwiera pin do masy. Nie powinno być wtedy problemu z przydźwiękiem.

rozebralem i zlozylem jak piszesz - zadzialalo. Cos tam nie halo w tych sprzetowych pullapach, ale na razie dalej nie szukam.

A jak to miales podlaczone ?
Tak jak napisales - od +3.3V przycisk, rezystor, i pin wejsciowy ?
A kable gdzie ?

Bo:
a) co robilo za pull-down ? Przy rozlaczonym switchu cos powinno
wymuszac stan, bo inaczej smieci lapie. No ale przy wlaczonym to juz
nie powinno

b) jesli pull-down byl ... to przy wlaczonym switchu ten rezystor
szeregowy wraz z pull-downem tworza dzielnik, i napiecie na wejsciu
moze byc akurat bliskie progu i wszelkie smieci lapie ... ale tylko
przy wlaczonym switchu.

J.

Budyń
Guest

Thu Jun 08, 2017 8:14 am   



W dniu czwartek, 8 czerwca 2017 00:10:14 UTC+2 użytkownik J.F. napisał:
Quote:
Dnia Wed, 7 Jun 2017 10:04:51 -0700 (PDT), Budyń napisał(a):
W dniu środa, 7 czerwca 2017 17:44:06 UTC+2 użytkownik Grzegorz Niemirowski napisał:
Budyń <budynpl.poland_at_gmail.com> napisał(a):
Prosta rzecz: odczytać stan pinu gpio w orangepi.
Z pinu 3,3V poprzez przycisk i rezystor rzędu kilku kom daję sygnał na
czytany pin.

Jak masz podłączony ten rezystor? Niech on będzie pullupem a przycisk niech
zwiera pin do masy. Nie powinno być wtedy problemu z przydźwiękiem.

rozebralem i zlozylem jak piszesz - zadzialalo. Cos tam nie halo w tych sprzetowych pullapach, ale na razie dalej nie szukam.

A jak to miales podlaczone ?
Tak jak napisales - od +3.3V przycisk, rezystor, i pin wejsciowy ?

jakos tak, przynajmniej w którejs konfiguracji

Quote:
A kable gdzie ?

krótkie, zresztą wystarczyło 10cm kabel jako antene podłączyć do pina (drugi koniec luźny) by zbierał te śmieci

Quote:
Bo:
a) co robilo za pull-down ? Przy rozlaczonym switchu cos powinno
wymuszac stan, bo inaczej smieci lapie. No ale przy wlaczonym to juz
nie powinno

b) jesli pull-down byl ... to przy wlaczonym switchu ten rezystor
szeregowy wraz z pull-downem tworza dzielnik, i napiecie na wejsciu
moze byc akurat bliskie progu i wszelkie smieci lapie ... ale tylko
przy wlaczonym switchu.

pullup/downy usilowalem robic programowo, dzielnik faktycznie sie robił bo z 3,3 robilo sie cos 1,6



b.

J.F.
Guest

Thu Jun 08, 2017 9:52 am   



Użytkownik "Budyń" napisał w wiadomości grup
dyskusyjnych:782260bf-79bb-49e3-8844-7bb788bb5c2a_at_googlegroups.com...
W dniu czwartek, 8 czerwca 2017 00:10:14 UTC+2 użytkownik J.F.
napisał:
Quote:
A jak to miales podlaczone ?
Tak jak napisales - od +3.3V przycisk, rezystor, i pin wejsciowy ?

jakos tak, przynajmniej w którejs konfiguracji

A kable gdzie ?
krótkie, zresztą wystarczyło 10cm kabel jako antene podłączyć do pina
(drugi koniec luźny) by zbierał te śmieci

Bo:
a) co robilo za pull-down ? Przy rozlaczonym switchu cos powinno
wymuszac stan, bo inaczej smieci lapie. No ale przy wlaczonym to
juz
nie powinno

b) jesli pull-down byl ... to przy wlaczonym switchu ten rezystor
szeregowy wraz z pull-downem tworza dzielnik, i napiecie na wejsciu
moze byc akurat bliskie progu i wszelkie smieci lapie ... ale tylko
przy wlaczonym switchu.

pullup/downy usilowalem robic programowo, dzielnik faktycznie sie
robił bo z 3,3 robilo sie cos 1,6

I jesli te 1.6V to prog odrozniajacy 0 od 1 na wejsciu, to jakis
drobny przydzwiek mogl powodowac odczyt 50 czy 100Hz.

J.

elektroda.net NewsGroups Forum Index - Elektronika Polska - orangepi, GPIO, odfiltrowanie 50Hz

NOWY TEMAT

RTV map News map