RTV forum PL | NewsGroups PL

ESP8266 SDK

NOWY TEMAT

elektroda.net NewsGroups Forum Index - Elektronika Polska - ESP8266 SDK

Atlantis
Guest

Thu Jun 15, 2017 12:46 pm   



Po dłuższej przerwie chciałem powrócić do programowania modułów ESP8266.
Odkąd ostatnio się tym bawiłem zdążyło wyjść kilka kolejnych wersji SDK.

Po raz kolejny zabrałem się za instalację SDK (już w wersji 2.0) i
konfigurację Code::Blocks, zgodnie z tą instrukcją:

http://tomeko.net/other/ESP8266/native.php

Na początek chciałem testowo skompilować jeden ze swoich starych
projektów, pisanych jeszcze z SDK 1.3.x (albo może nawet 1.1.x ?). Nie
udało się - kompilator wywalił całe mnóstwo będów "implicit
declaration", głównie w plikach sterowników uart.h i i2c_master.h.
Pomyślałem, że pewnie nowe SDK nie jest zgodne ze starymi sterownikami
(znajdowały się one lokalnie w katalogu projektu).

Utworzyłem więc nowy projekt i zaimportowałem przykład "sysinfo",
dostarczony do ściągniętej wersji SDK. Znów ta sama sytuacja - błędy
"implicit declaration" w kodzie sterownika uart.

Zaimportowałem coś jeszcze prostszego - przykład "blinky". On z kolei
podczas kompilacji wielokrotnie wywalił "implicit declaration" w pliku
osapi.h, znajdującym się wśród plików SDK.

Ktoś wie o co może chodzić? Mam coś źle skonfigurowane? A może producent
udostępnił nowe SDK nie zwracając uwagi, że w przykładach jest
niekompatybilny z nim kod?

Waldemar
Guest

Thu Jun 15, 2017 1:26 pm   



Am 15.06.2017 um 14:46 schrieb Atlantis:
Quote:
Po dłuższej przerwie chciałem powrócić do programowania modułów ESP8266.
Odkąd ostatnio się tym bawiłem zdążyło wyjść kilka kolejnych wersji SDK.

Po raz kolejny zabrałem się za instalację SDK (już w wersji 2.0) i
konfigurację Code::Blocks, zgodnie z tą instrukcją:

http://tomeko.net/other/ESP8266/native.php

Na początek chciałem testowo skompilować jeden ze swoich starych
projektów, pisanych jeszcze z SDK 1.3.x (albo może nawet 1.1.x ?). Nie
udało się - kompilator wywalił całe mnóstwo będów "implicit
declaration", głównie w plikach sterowników uart.h i i2c_master.h.
Pomyślałem, że pewnie nowe SDK nie jest zgodne ze starymi sterownikami
(znajdowały się one lokalnie w katalogu projektu).

Utworzyłem więc nowy projekt i zaimportowałem przykład "sysinfo",
dostarczony do ściągniętej wersji SDK. Znów ta sama sytuacja - błędy
"implicit declaration" w kodzie sterownika uart.

Zaimportowałem coś jeszcze prostszego - przykład "blinky". On z kolei
podczas kompilacji wielokrotnie wywalił "implicit declaration" w pliku
osapi.h, znajdującym się wśród plików SDK.

Ktoś wie o co może chodzić? Mam coś źle skonfigurowane? A może producent
udostępnił nowe SDK nie zwracając uwagi, że w przykładach jest
niekompatybilny z nim kod?

Wygląda na to, że brak prototypów funkcji.Możliwe, że przykłady nie
zostały dopasowane.

Waldek

w systemie siła 'POPIS/E
Guest

Thu Jun 15, 2017 3:55 pm   



a można zapytać skąd to sdk ściągnąć? bo jest chyba z milion stron fejkow...

elektroda.net NewsGroups Forum Index - Elektronika Polska - ESP8266 SDK

NOWY TEMAT

RTV map News map